Jump to content
stevewilley

What did you do to your E39 today ?

Recommended Posts

Thanks GTE, I ask because I'm not 100% sure that the one on my car since I bought it is genuine or not, it's not sat completely right. Only a tiny bit out of line with wheel arch joint from wing, but after noticing it whilst cleaning not long ago, can't un-see it. One day I'll get around to taking it off and checking for BMW stamps. If its genuine, I'll have to start looking at the side brackets for it, see if either are bent or other indication that it's had a whack at somepoint. 

 

If it turns out to be copy then I'll be looking to replace it with something which does fit properly, and given how used and undamaged genuine sport bumpers are like hens teeth, good to know that some copies are up to scratch :)

Share this post


Link to post
Share on other sites

Took the 540 for mot, passed with no advisories. Mind you, I have done all of 565 miles in the past year so should be okay  :mellow:.
Speedo now on 75953 km (47470 miles)

 

Edited by timbolina
Incorrect photo

Share this post


Link to post
Share on other sites

Is there any value in my old damaged bumper? Not to make money but as in would people buy a damaged genuine bumper for some beer tokens?

Seems silly to bin it if I could let someone have it to repair 

Share this post


Link to post
Share on other sites
1 hour ago, Gte86 said:

Is there any value in my old damaged bumper? Not to make money but as in would people buy a damaged genuine bumper for some beer tokens?

Seems silly to bin it if I could let someone have it to repair 

 

Probably - £10 buys gold membership and you can advertise ;)

Share this post


Link to post
Share on other sites

Just home from driving it c.1800miles round-trip for walking hols : Bath-Skye-Wester Ross & rtn via Lake District & N York Dales.

 

Utterly serene & soothing drive enjoyed , obviously! 

I will update when I've downloaded camera card & calculated o/a mpg...

 

ETA: 1796miles; 282litres;  28.9x -mumble mpg overall having taken phone pics of mileage and pump readout to cut-off on refill,

  • Incremental highs on long motorway legs, easily better than 33;
  • lows crawling the narrow single-track for 600+miles, and a few traditional excursions like the Bealach Na Ba  - still better than 25.

It doesn't matter to me - but I'm v happy with that, esp from petrol V8 auto....

Edited by Huff

Share this post


Link to post
Share on other sites

Drive to the seaside with family and noticed some electrics stopped working like Sun visier lamp or rear view camera. Checked the amps and 7.5Amp gone for lighter socket tried putting in new but all went bust. Any electricians here? :)

Share this post


Link to post
Share on other sites
6 hours ago, JonJon said:

Drove it for the first time in getting on for three years, having spent the last 12 months going through a fairly comprehensive restoration. It was a good day :)

CB62F9D6-77A5-460A-B876-B8A0567FB6FE.jpeg

737C836A-C774-4788-ADD6-321D9A7313BD.jpeg

2851B119-30DE-4844-9395-FF0ACBEADFBD.jpeg

Wow must have been a joy. I’ve got sometimes people coming up and thanking me for saving motoring history lol. What I like about my 540i touring it is so understated… no one ever expects the sound coming from the exhaust and turn their heads. 

Edited by Adrian1662

Share this post


Link to post
Share on other sites

Replaced AC condenser which had a slow leak. Opted to go with the radiator out method. Once the radiator is out, the transmission and power steering coolers can be unclipped from the holding bracket (without disconnecting the lines) and then the condenser and holding bracket can be removed together. Cleaned 25 years' worth of dead bugs and leaves that had turned into a big oily mess.

 

 

Share this post


Link to post
Share on other sites

Got fed up of just looking at it through the cobwebs which it has amassed since everything went a bit Mad Max, and went for a drive despite not needing to (and now being able to finally fill it up again as Brighton seems to have been the last place to stop panic buying fuel)... And in typical 'Munich's finest' style, found my latest fault to deal with. 

 

Wandler vorne mitte links, or to the Anglo speakers, another bloody PDC sensor bites the dust. Rear middle left,  which I replaced last year along with rear mid right whilst I had bumper off. Admittedly with some cheap Amazon jobbies, but sure I used the same brand on my previous 528 which lasted the remaining three years which I had that car for.

 

So, anyone recommend any particular cheap but at least vaguely reliable sensors? 

20211007_184616.jpg

Share this post


Link to post
Share on other sites
54 minutes ago, Pzero said:

Got fed up of just looking at it through the cobwebs which it has amassed since everything went a bit Mad Max, and went for a drive despite not needing to (and now being able to finally fill it up again as Brighton seems to have been the last place to stop panic buying fuel)... And in typical 'Munich's finest' style, found my latest fault to deal with. 

 

Wandler vorne mitte links, or to the Anglo speakers, another bloody PDC sensor bites the dust. Rear middle left,  which I replaced last year along with rear mid right whilst I had bumper off. Admittedly with some cheap Amazon jobbies, but sure I used the same brand on my previous 528 which lasted the remaining three years which I had that car for.

 

So, anyone recommend any particular cheap but at least vaguely reliable sensors? 

20211007_184616.jpg

Just a gamble I would say. I have £5 Chinese eBay sensor working perfectly in my front bumper since summer 2019, and car been driven a lot. First eBay sensor was defective, seller sent replacement sensor, and it's working faultless even after being painted and now having fair few stone chips all over it. 

Share this post


Link to post
Share on other sites
10 hours ago, Pzero said:

Got fed up of just looking at it through the cobwebs which it has amassed since everything went a bit Mad Max, and went for a drive despite not needing to (and now being able to finally fill it up again as Brighton seems to have been the last place to stop panic buying fuel)... And in typical 'Munich's finest' style, found my latest fault to deal with. 

 

Wandler vorne mitte links, or to the Anglo speakers, another bloody PDC sensor bites the dust. Rear middle left,  which I replaced last year along with rear mid right whilst I had bumper off. Admittedly with some cheap Amazon jobbies, but sure I used the same brand on my previous 528 which lasted the remaining three years which I had that car for.

 

So, anyone recommend any particular cheap but at least vaguely reliable sensors? 

20211007_184616.jpg

 

This reseller: https://www.ebay.co.uk/itm/261822774094?fits=Car+Make%3ABMW|Plat_Gen%3AE39&hash=item3cf5da7b4e:g:7wAAAOSwkLJbIdVz

 

Never had any issues with them

Share this post


Link to post
Share on other sites

My heater fan has been playing up for a week or so. Sometimes not working. Sometimes working after a while. 

Got myself a Febi heater resistor and fitted it and it all seems to be working OK. 

 

20211014_195521.jpg

20211014_195518.jpg

20211014_184250.jpg

20211014_184240.jpg

Share this post


Link to post
Share on other sites

Changed the rear brake pads after a verrrrryyyy long time (I can't actually ever remember doing them in over ten years of ownership). It actually went surprisingly easily despite not being touched in a decade.

Share this post


Link to post
Share on other sites
On 14/10/2021 at 23:34, Gte86 said:

My heater fan has been playing up for a week or so. Sometimes not working. Sometimes working after a while. 

Got myself a Febi heater resistor and fitted it and it all seems to be working OK. 

 

 

 

 

 

 

The old ones all seem to go bad sooner or later. The newer style one you got (with more cooling spikes) seem to last forever, I have not had to replace one.

Share this post


Link to post
Share on other sites

I did notice the part number had changed. 

Car is now at 160k and 18 years old so I'll be surprised if its the original one in there 

Share this post


Link to post
Share on other sites

Picked the car up from the bodyshop today.

 

They had repaired and fitted the fibreglass top tailgate spoiler that I sourced from the US a while ago. Tin worm around the top and bottom tailgates was addressed as well.

All the black work has been refreshed and a few surface scabs around the arch lips were also treated.

 

20211016_154841.thumb.jpg.620c31665108c45f1e91f67b90935937.jpg

 

20211016_154916.thumb.jpg.52971a484dc4a006601c15c43c5244ec.jpg

 

B)

Share this post


Link to post
Share on other sites

I had the aircon regassed today as the system was emptied out during the recent refurb works.  The car is now icy cold again and I'm £65 poorer.  Worth it though!

Share this post


Link to post
Share on other sites
On 10/14/2021 at 10:34 PM, Gte86 said:

My heater fan has been playing up for a week or so. Sometimes not working. Sometimes working after a while. 

Got myself a Febi heater resistor and fitted it and it all seems to be working OK. 

 

20211014_195521.jpg

20211014_195518.jpg

20211014_184250.jpg

20211014_184240.jpg

Out of interest, when you did this, are you able to see the heater matrix?

Share this post


Link to post
Share on other sites
On 10/16/2021 at 4:15 PM, Hippy said:

Picked the car up from the bodyshop today.

 

They had repaired and fitted the fibreglass top tailgate spoiler that I sourced from the US a while ago. Tin worm around the top and bottom tailgates was addressed as well.

All the black work has been refreshed and a few surface scabs around the arch lips were also treated.

 

20211016_154841.thumb.jpg.620c31665108c45f1e91f67b90935937.jpg

 

20211016_154916.thumb.jpg.52971a484dc4a006601c15c43c5244ec.jpg

 

B)

Genuine?

Share this post


Link to post
Share on other sites
39 minutes ago, AdamB said:

Out of interest, when you did this, are you able to see the heater matrix?

Definitely no, because heater matrix will be inside housing, so air from blower motor goes through matrix. And it's higher up behind dashboard. I believe you can see condenser housing, which is just above centre tunnel.

Share this post


Link to post
Share on other sites

@AdamB

I'm not too sure to be honest. I just removed this. I believe the matrix is pretty buried and this just sits in the air duct housing 

Share this post


Link to post
Share on other sites
20 hours ago, Clavurion said:

It's AC evaporator matrix. (Condenser is next to radiator.)

 

image.png.328dba175ef338af31dac5f9b50a9e5d.png

So theoretically I might be able to get to the stinky bit and spray some of the ac cleaning foam at it? 
 

sorry, I kind of meant evaporator instead of heater matrix anyway.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×