Jump to content
stevewilley

What did you do to your E39 today ?

Recommended Posts

58 minutes ago, d_a_n1979 said:

New front lower suspension arms & drop links

 

New front brake discs and pads

 

New tie rod ends and inner rods being fitted tomorrow/Friday...

 

See my project for further details/pics if you're interested :lol:  :roll: 

Got a link? 

Share this post


Link to post
Share on other sites
10 minutes ago, PL523i said:

Got a link? 

 

The links in my signature below & my project is in the Projects group :)

Share this post


Link to post
Share on other sites
4 hours ago, PL523i said:

Hmm I'm on android, signatures don't appear to be showing. No worries, I'll, Check it out later, cheers. 

 

Maybe I should do the same.. It's never ending!

Turn your phone 90° into landscape mode, you can then see all the stuff, sig's etc.

Share this post


Link to post
Share on other sites
1 minute ago, PL523i said:

Not on mine it's not

Do you have screen rotation turned on?

 

I'm on a Samsung and it works great for me...

Share this post


Link to post
Share on other sites

Both rads cleaned and tested and both hold good pressure. The original from 1999 that was on the car had some internal corrosion that's inhibiting flow but it's still OK. The new(ish) Nissens was fine, so a bargain for £26.

Thoroughly reccommend Sheldrake and Wells. Less than £40 to get 2 rads cleaned and tested within 24 hours. 

https://www.sheldrakeandwells.co.uk/

Share this post


Link to post
Share on other sites

MoT passed :D 

 

One advisory - N/S headlamp dim... I'm wondering if it's actually dim, or the arse has fallen out of the adjusters on that side. Both lights still do the uppy-downy thing on switch on so does that mean it's broken or just badly aimed? I'll try and tweak the aim myself with the screw on top of the unit. Still, not bad for very nearly 19 years old and 196000 miles! 

Share this post


Link to post
Share on other sites
Just now, PL523i said:

Another year of motoring :)

Could just need a different bulb? 

Indeed - another year legal!

 

I don't believe it to be the bulb, when I've parked up against a wall the light output either side is the same, just the N/S is noticeably lower in aim. Ah well, definitely can't complain, plus I changed both bulbs about 2 years ago, and as they're xenon bulbs I'd hope for a bit more life! 

Share this post


Link to post
Share on other sites
22 minutes ago, PL523i said:

Both rads cleaned and tested and both hold good pressure. The original from 1999 that was on the car had some internal corrosion that's inhibiting flow but it's still OK. The new(ish) Nissens was fine, so a bargain for £26.

Thoroughly reccommend Sheldrake and Wells. Less than £40 to get 2 rads cleaned and tested within 24 hours. 

https://www.sheldrakeandwells.co.uk/

Ok but from where was coolant leaking then if old radiator hold pressure?

Share this post


Link to post
Share on other sites

Good question!

I can only assume that it wasn't. It must have leaked when I removed the breather hose to fit the new shroud and then sat in the rad fins? I'm guessing but that the only place it could have come from as it was after the refitting of the shroud I noticed all the Coolant. I had thought I had damaged the core when fitting it orbthe fan blades.. That appears to not be the case. 

Proof will be after the refit and a dry system. 

Share this post


Link to post
Share on other sites
3 hours ago, Ray112 said:

Ok but from where was coolant leaking then if old radiator hold pressure?

Good question!

I can only assume that it wasn't. It must have leaked when I removed the breather hose to fit the new shroud and then sat in the rad fins? I'm guessing but that the only place it could have come from as it was after the refitting of the shroud I noticed all the Coolant. I had thought I had damaged the core when fitting it orbthe fan blades.. That appears to not be the case. 

Proof will be after the refit and a dry system. 

 

Also my new waterpump arived today. I know you all haev your preferred ebay sellers but ive used MJD128 (JD Motorsport) for a long time and consitently good prices. if you do your home work on the relevant apps and search by partnumber they are usually good value. My Mahle waterpump, although sold as Hella arrived in Mahle box, (same company) wasunder £28 delivered. 

Share this post


Link to post
Share on other sites

To end the work on the car this week; new inner tie rods and track rod ends fitted, along with a full set-up:

 

trends.jpg

set-up.jpg

 

That's it now; every part of the suspension (bar the rear rose bushes) has been replaced on this car now :lol:;) :mrgreen:

 

Feel like I need a certificate to say well done :lol: 

 

Share this post


Link to post
Share on other sites
1 hour ago, d_a_n1979 said:

To end the work on the car this week; new inner tie rods and track rod ends fitted, along with a full set-up:

 

trends.jpg

set-up.jpg

 

That's it now; every part of the suspension (bar the rear rose bushes) has been replaced on this car now :lol:;) :mrgreen:

 

Feel like I need a certificate to say well done :lol: 

 

Heyy Dan, does the car ride/handle/feel different with all the new parts now? I've never refreshed the whole of a car's underpinnings and wondered whether because it's been replaced, you expect it to do so - AKA the Placebo effect. 

Share this post


Link to post
Share on other sites
12 minutes ago, Loadmaster said:

Heyy Dan, does the car ride/handle/feel different with all the new parts now? I've never refreshed the whole of a car's underpinnings and wondered whether because it's been replaced, you expect it to do so - AKA the Placebo effect. 

 

Hi Keith

 

The car handles superbly on it's suspension; the shocks and Eibach springs made the most difference etc (the rear subframe bushes made a lot of difference too, as the original ones were fairly battered when they were removed, so you could see why the rear end was a bit 'loose' at times, more so in bends)

 

Overall it's firmer and well planted now :) 

Share this post


Link to post
Share on other sites

Weather was crap so no action... Just another £80 on parts via bmwmotormec on eBay. 

Thermostat and housing

Top hose

Waterpump pulley

 

Next on the list is to fit the suspension parts to get it through the mot and get it re-tested before Christmas. 

 

Going to have to explain to the kids that Santa got Covid at this rate!

 

Monday lunchtime edit: fitted the waterpump

 

 

Edited by PL523i

Share this post


Link to post
Share on other sites

Finally a break in the weather at lunch time so got the new t-stat, pulley and then the belts on. Will get the rad back in and new coolant pipes back on at the weekend.

Weather permitting. 

Share this post


Link to post
Share on other sites
26 minutes ago, Mr C said:

It's at the Quiraing and Staffin slipway, north end of the Isle of Skye 

 

 

Nature looks amazing around there, nevar been myself but seen some pictures. Maybe some day, it's about 10 hour drive for me, but I love driving, so why not to do it:D

Share this post


Link to post
Share on other sites

Drove it, first time in a week... 

 

Got it absolutely filthy too as the weather's foul as 40 arseholes here currently :roll::lol:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×