Jump to content
RichardP

Firmware V6.02-7058 and User Guide

Recommended Posts

Hello,

 

@RichardP may I ask some help ?

 

I updated my FW to 7058 but had a lot of failed / retry while flashing...

 

Now I see there is newer FW here, but I'm not able to flash it anymore, no matter what I do, I have 2 laptops, one with usb to serial, and one with genuine serial, both do the same strange characters when plugged to intravee.

 

On the car, the intravee works fine, music, ipod, controls... just the auto close feature does not work (2003' 530i E39)

 

Thank you.

fw_update.png

Share this post


Link to post
Share on other sites

This is a serial port issue.  If you were not using a native serial port on one PC i’d Blame the USB adapter.

 

The port speed is correct for the default Intravee settings, I’m wondering if at some point the Intravee itself has have its serial port speed changed.  Try setting the speed to 64,000 and if that does not work 32,000 in the serial port settings dialog in the downloaded. Use the PC that has the native serial port if you can.

Share this post


Link to post
Share on other sites
1 hour ago, RichardP said:

This is a serial port issue.  If you were not using a native serial port on one PC i’d Blame the USB adapter.

 

The port speed is correct for the default Intravee settings, I’m wondering if at some point the Intravee itself has have its serial port speed changed.  Try setting the speed to 64,000 and if that does not work 32,000 in the serial port settings dialog in the downloaded. Use the PC that has the native serial port if you can.

Ok I'll try this evening

I tried 9600 and did not work

Thank you

 

Edit : For the record I flashed with the USB to Serial adaptor first time, and after a lot of fail/retry it finally updated, but then the strange char appeared.

Since then, both laptop have the same issue, so I'll try lower value this evening.

 

Thanks

Edited by Orphee

Share this post


Link to post
Share on other sites

@RichardP and other question/info, I have a "little" bug when the radio TMC info traffic is enabled.

 

When a traffic info is received, the screen automatically switch to INFO menu, then at the end, or when you push INFO button, it leaves INFO traffic mode, but then the Intravee screen is frozen.

I have to use the little icon button near MODE twice to leave and go back to intravee screen.

 

 

Share this post


Link to post
Share on other sites

Someone must have set the baud rate in the Intravee to a lower rate at some point, probably due to a dodgy USB serial adapter. I can’t remember off the top of my head how to change it back to the default!  I’ll look it up and post it here later.

Edited by RichardP

Share this post


Link to post
Share on other sites
23 minutes ago, RichardP said:

Someone must have set the baud rate in the Intravee to a lower rate at some point, probably due to a dodgy USB serial adapter. I can’t remember off the top of my head how to change it back to the default!  I’ll look it up and post it here later.

Not really a big deal as I won't connect it quite often...

So I tried again the "auto close" window feature, and no matter what I do, it simply does not work at all. No reaction.

Tried E38/E39 type and E39 Late, same behavior.

Share this post


Link to post
Share on other sites

To change the Intravee baud rate (and DO NOT DO THIS UNLESS YOU HAVE TO!!!)

 

Enter the boot loader with the 'boot' command.

Enter programming mode with the 'p' command.

Set the new baud rate with the 'B xx' command where XX is :

01 = 1200 baud

02 = 9600 baud

03 = 38400 baud

04 = 57600 baud

05 = 115200 baud

Exit programming mode with the 'e' command

Reboot the Intravee with the 'b' command.

 

You will now have to change the downloader serial port rate to match the rate set above, otherwise you'll just get garbage.

 

 

Share this post


Link to post
Share on other sites
15 minutes ago, Orphee said:

Not really a big deal as I won't connect it quite often...

So I tried again the "auto close" window feature, and no matter what I do, it simply does not work at all. No reaction.

Tried E38/E39 type and E39 Late, same behavior.

You will need to have comfort closing enabled as an option for this to work.  The comfort closing option will instigate the window close, this option in the Intravee should enable the windows to close fully even if you release the lock button.

Share this post


Link to post
Share on other sites

I don't know why it does not work then, some of the iBus codes are very specific to certain module revisions so maybe your GM has been replaced at some point for a version that's not normally in an E39.

 

You could try the 'cw' command followed by any of these command codes :

44 o/s/r up

45 o/s/r down

46 n/s/r up

47 n/s/r down

65 both front down

66 both rear down

87 comfort opening

88 comfort closing

 

for example

 

cw 45

 

should cause the off side rear window to go down.

 

Share this post


Link to post
Share on other sites
11 hours ago, RichardP said:

I don't know why it does not work then, some of the iBus codes are very specific to certain module revisions so maybe your GM has been replaced at some point for a version that's not normally in an E39.

 

You could try the 'cw' command followed by any of these command codes :

44 o/s/r up

45 o/s/r down

46 n/s/r up

47 n/s/r down

65 both front down

66 both rear down

87 comfort opening

88 comfort closing

 

for example

 

cw 45

 

should cause the off side rear window to go down.

 

Hello :)

I just tried, absolutly no reaction at all with cw commands.

No error, command sent, back to "ready", but nothing happens.

Share this post


Link to post
Share on other sites
On 27/05/2019 at 20:28, RichardP said:

To change the Intravee baud rate (and DO NOT DO THIS UNLESS YOU HAVE TO!!!)

 

Enter the boot loader with the 'boot' command.

Enter programming mode with the 'p' command.

Set the new baud rate with the 'B xx' command where XX is :

01 = 1200 baud

02 = 9600 baud

03 = 38400 baud

04 = 57600 baud

05 = 115200 baud

Exit programming mode with the 'e' command

Reboot the Intravee with the 'b' command.

 

You will now have to change the downloader serial port rate to match the rate set above, otherwise you'll just get garbage.

 

 

Thank you, it worked, back to 115200 :)

 

And auto close does not work on the M5 too... it also has confort closing...

Edited by Orphee

Share this post


Link to post
Share on other sites

GM_530i.png

 

In fact I can't find the module to test windows in ISTA/D...

I was able to do it on my 330 E46, but here I can't find it.

Edited by Orphee

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×