Jump to content
STAPO

MOT Pass!

Recommended Posts

...15 years old and 137,000 miles... all it needed was a lower suspension arm. The week before I had two tyres fitted to the back.

I have, today changed the engine oil and filter and air filter, and given it a quick look over, lubed the locks, etc.

All in, I have spent less than £500 on this car, which a year or so ago cost me £950. At the time I thought it would keep me going for a while and then I would scrap it, if it was too costly at MOT time.

These really are good cars.

BTW it is a 1995 525 saloon.

Share this post


Link to post
Share on other sites

Good to hear :D

I've got my MOT coming up in a few weeks, not looking forward to it lol.

Mine's a 1993 520i SE with a few niggles here and there, I just hope it's mechanically safe and passes...

Share this post


Link to post
Share on other sites

Great news to hear another E34 stays on the road. I will be doing mine shortly I hope as soon as I get to fitting the exhaust on it.

Have you posted any pictures of yours yet

Share this post


Link to post
Share on other sites

Just did mine last week, & just needed a repair on the fuel return line right at the fuel tank which I knew about (thought the tank might have needed dropped for access so left it for garage). Did a fair bit of work in the months beforehand to make sure it wouldn't need too much.

Share this post


Link to post
Share on other sites

Have you posted any pictures of yours yet

...Well I'll eventually get around to this but it's no oil painting. :(

BTW does anyone know what has happened to BMWORX at Aylesbury, their website has been down for ages...

Share this post


Link to post
Share on other sites

Hi,

Just looking for a little advice: The car has developed a knocking sound from the engine, related to RPM. It seems to run OK. I am wondering how bad this could be. The MOT expires next month, so I may change it, rather than spend on the MOT.

It's a 1995 525 petrol auto.

Any thoughts?

Share this post


Link to post
Share on other sites

Thanks, might change the oil tomorrow and see it that makes a difference, if I can I will post a video.

Share this post


Link to post
Share on other sites

I have a video taken on a BlackBerry, with the sound, it's a .3GP file but can't get it up uploaderise.

Anyway I have changed the oil and it sounds the same. The noise seems to come from the lower drivers side of the engine.

Share this post


Link to post
Share on other sites

Something has popped. Was driving along the Dual Carriagway and something popped. It ran really rough but got me the last 2 miles home. Inside the noise is from the drivers side and sounds like a blowing of air. also there is some oil spray...

Share this post


Link to post
Share on other sites

My MOT is due in October and is also 15 years and 137,000 miles old! What was the symptom of the lower arm being worn?

My steering has a lot of slack in it which seems to be getting worse. Definitely bad enough to fail the MOT.

Other than that, the only other fault is the airbag light stays on.

Sorry to hear about your Dual carrigeway popping. The only time I've heard a loud blowing of air noise on these old BMWs is when the fan is stuck on full pelt.

Share this post


Link to post
Share on other sites

My MOT is due in October and is also 15 years and 137,000 miles old! What was the symptom of the lower arm being worn?

My steering has a lot of slack in it which seems to be getting worse. Definitely bad enough to fail the MOT.

Other than that, the only other fault is the airbag light stays on.

Sorry to hear about your Dual carrigeway popping. The only time I've heard a loud blowing of air noise on these old BMWs is when the fan is stuck on full pelt.

...It was a clonking from that area.

Share this post


Link to post
Share on other sites

I’m back in the game!

 

Recently bought an E60, 530i M Sport, 130,000 miles with a few neat things I think were options like keyless entry, etc. 
 

After my old 525 expired I had to get a car quick so I bought an old LS 400 for about £900. Ran it for a few years then bought a GS 300. That cost me a bit over about 4 years and I never really liked it. I had to run that into the ground so wasn’t too sad to see it go. 
 

I’m really happy with this new car. I’ll probably be posting some questions in due course. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×