Jump to content
Sign in to follow this  
David6GT

Alexa integration with OS6

Recommended Posts

Morning,

 

Hope someone can help.  I have just discovered that Alexa is available for OS6.  I've done everything required but find that the ability to use it is intermittent.  Sometimes it will work and sometimes I get the BMW voice telling me this function is not available or a display on the screen telling me it's not available.

 

When it does work I'm really impressed with it.  Does anyone know any hints or tips to make it more reliable on an every time basis.?

 

I also have access to CarPlay but like the Alexa functionality.

 

Any thoughts much appreciated.

 

Thanks

Share this post


Link to post
Share on other sites

First thing will be check the wifi connection to the car and whether the permission is given as "always" for connecting the APP. However, this is from the iDrive 7 user. 

Share this post


Link to post
Share on other sites

Bluetooth gives you basic handfree and basic music playing. If you need things like CarPlay or even Alexa integration, you will also need to connect the onboard wifi. At least this is the case for iDrive 7. But, I think this is also the case for iDrive 6 as BMW's CarPlay implementation is via wireless communication instead of wired communication. Best way to check is use the MyBMW App. At the page of the car you are configuring (if you have more than one cars associated to your bmw account), scroll down to almost the bottom of the page and you will see a tab call "Device Connection". When you are in your car and open this tab, you will see whether all three items (Bluetooth, Apps, Wi-Fi) in the page are connected.

Share this post


Link to post
Share on other sites

Thanks for the advice.  It’s not showing as Apps connected when I’m in the car.  I followed the instructions in the My BMW App which says to disconnect the phone and then reconnect it via Bluetooth but to connect it as an App device (I.e not as a telephone)

 

Last week the option to connect as App device was there, today it isn’t, I’m now only offered to connect as phone, Bluetooth Music device or CarPlay device.

 

any other thoughts would be great. Thanks 

Share this post


Link to post
Share on other sites

I can't help too much with why the App connection is sometime there and sometime not. But, I think the App connection isn't established is the reason of why Alexa works intermittently. If the car is still under warranty, let the dealer update the software (or, what dealer may call reinstall the OS) with the reason of Alexa integration or App connection isn't stable. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×