Jump to content
GruntBoy

I-Drive 6 Bluetooth problem

Recommended Posts

I have a MY2017 G30 with idrive 6. Got my iPhone 8 connected and stream music via Bluetooth. For the first month of ownership (bought in Feb 2021) the Bluetooth music was random as to whether it would connect or not. Phone capability always connects. Apple released an update about 3-4 weeks ago and I thought that had fixed it. Drove the car today though. Lunchtime it was fine. Evening back to not working. Realised when I got back this evening was the first time in weeks I’d been wearing my Apple Watch too. Did two journeys this evening, both with the watch in the car, both times music failed to connect. Two journeys this morning, both without the watch on, both times music worked fine. 
 

I can’t find anything about this online. Has anyone else noticed this being an issue with Apple watches screwing up phone music connection please? I know I’m probably clutching at straws. Just so frustrating this stuff doesn’t just work!

 

Thanks for any help. 

Share this post


Link to post
Share on other sites

I had an iPhone X when I first bought my car just over 2 years ago (68 plate) and never had any issues streaming music through the car (Apple music on the phone) ... and I always had the apple watch on while driving. 

 

I moved to android about 18 months ago and have had no issues with that either using the Spotify app in the car which works really well while connected to the phone through Bluetooth.

 

I've since moved to using the car built in Online Entertainment package with Deezer which I really like.

 

I'm sure there will be lots of other Apple users who will be able to share their experiences. 

Share this post


Link to post
Share on other sites
3 minutes ago, JDX-90 said:

I had an iPhone X when I first bought my car just over 2 years ago (68 plate) and never had any issues streaming music through the car (Apple music on the phone) ... and I always had the apple watch on while driving. 

 

I moved to android about 18 months ago and have had no issues with that either using the Spotify app in the car which works really well while connected to the phone through Bluetooth.

 

I've since moved to using the car built in Online Entertainment package with Deezer which I really like.

 

I'm sure there will be lots of other Apple users who will be able to share their experiences. 

Thanks a lot.
 

Were you using the idrive and iPhone or Apple car play please? 

Share this post


Link to post
Share on other sites
Just now, GruntBoy said:

Thanks a lot.
 

Were you using the idrive and iPhone or Apple car play please? 

 

I was just using the iDrive directly with the iPhone.

Share this post


Link to post
Share on other sites
11 hours ago, GruntBoy said:

I have a MY2017 G30 with idrive 6. Got my iPhone 8 connected and stream music via Bluetooth. For the first month of ownership (bought in Feb 2021) the Bluetooth music was random as to whether it would connect or not. Phone capability always connects. Apple released an update about 3-4 weeks ago and I thought that had fixed it. Drove the car today though. Lunchtime it was fine. Evening back to not working. Realised when I got back this evening was the first time in weeks I’d been wearing my Apple Watch too. Did two journeys this evening, both with the watch in the car, both times music failed to connect. Two journeys this morning, both without the watch on, both times music worked fine. 
 

I can’t find anything about this online. Has anyone else noticed this being an issue with Apple watches screwing up phone music connection please? I know I’m probably clutching at straws. Just so frustrating this stuff doesn’t just work!

 

Thanks for any help. 

 

Look here for a Bluetooth software update: https://www.bmw.com/en/footer/software-updates.html

 

If there is nothing available for your car then the only fix is a full car software update that can be done by BMW. But as your car is out of warranty it will be chargeable.

Share this post


Link to post
Share on other sites
1 hour ago, Matthew Ashton said:

 

Look here for a Bluetooth software update: https://www.bmw.com/en/footer/software-updates.html

 

If there is nothing available for your car then the only fix is a full car software update that can be done by BMW. But as your car is out of warranty it will be chargeable.

Thanks ms a lot for this. Checked on the link and car is up to date. 
 

Went out this morning without the watch (having not worked twice last night with it) and it was back to working perfectly. 
 

I can see this becoming one of those things where BMW just say it’s an Apple issue and Apple say it’s BMW’s. 

Share this post


Link to post
Share on other sites
3 hours ago, GruntBoy said:

Thanks ms a lot for this. Checked on the link and car is up to date. 
 

Went out this morning without the watch (having not worked twice last night with it) and it was back to working perfectly. 
 

I can see this becoming one of those things where BMW just say it’s an Apple issue and Apple say it’s BMW’s. 

 

BMW's integration with Apple devices is generally rock solid. Software updates have generally resolved any issues raised.

Share this post


Link to post
Share on other sites

I'm wondering if it's something to do with the watch being set up to remotely control music on the phone which is interfering with the music streaming to the car? 

 

Maybe you could try setting the watch to play music locally (stored on the watch) and then see if the phone plays music in the car?

Share this post


Link to post
Share on other sites
34 minutes ago, JDX-90 said:

I'm wondering if it's something to do with the watch being set up to remotely control music on the phone which is interfering with the music streaming to the car? 

 

Maybe you could try setting the watch to play music locally (stored on the watch) and then see if the phone plays music in the car?

Any idea how to change this please? Can’t see anything in the watch settings or on the phone. Thanks. 

Share this post


Link to post
Share on other sites
30 minutes ago, Carrman2018 said:

I have an iPhone 12 Pro and Apple Watch 5 which work fine - but I have BMW OS7 so that might not be relevant….

Thanks Carman. 
 

Do you mean idrive 7 or is os7 something else BMW related please? 

Share this post


Link to post
Share on other sites
1 hour ago, GruntBoy said:

Any idea how to change this please? Can’t see anything in the watch settings or on the phone. Thanks. 

 

I can't remember what the steps were but it was similar to if you're using the watch with a Bluetooth headset without the phone. It could be that this is automatic in later versions of iOS/WatchOS now though.

 

Do you lose the audio streaming symbol (shown in the picture) against the phone in the iDrive menu when you have the watch connected? 

 

P. S. OS7 is Operating System 7 which is the new name for iDrive and comes after ID6. 

 

 

 

Screenshot_20210520-195520_DRIVERS GUIDE.jpg

Share this post


Link to post
Share on other sites

Yes I do lose the symbol. If I go to the phone and then settings in idrive it just sits there trying to connect to it and never manages it. 
 

Thanks a lot RE: OS7 - didn’t know that. 

Share this post


Link to post
Share on other sites

Very strange, it sounds like the watch is interfering with the phone being able to connect for Bluetooth audio. 

 

Might be an Apple issue rather than BMW... although you'd expect more members to have experienced it unless there's something specific to your set up. Do you have a family member or friend with an iPhone and apple watch to test with? 

Share this post


Link to post
Share on other sites

Yeah I think you’re right. 
 

It’s not great as the watch always loses connection to the phone unless both on wifi at home. Leave the house and 90% of the time the watch and phone lose each other. 

Share this post


Link to post
Share on other sites

Same problem for me recently. First glitch in almost three years ownership. Seems random as well, hadn’t thought of the watch aspect.

I have the latest Bluetooth software as well. The phone still works but no audio. 

 

I did resolve it tonight with a phone reboot. Feels more like it may be an Apple issue.

Will see what it does tomorrow! 

Share this post


Link to post
Share on other sites
11 hours ago, GruntBoy said:

Thanks Carman. 
 

Do you mean idrive 7 or is os7 something else BMW related please? 

BMW operating system 7 - iDrive 7 if you like.

Share this post


Link to post
Share on other sites
10 hours ago, GruntBoy said:

Yeah I think you’re right. 
 

It’s not great as the watch always loses connection to the phone unless both on wifi at home. Leave the house and 90% of the time the watch and phone lose each other. 

The watch and phone should talk to other by  Bluetooth unless you are in the same Wi-fi network when this can use that.

 

So if you leave the house without you phone (but with your watch) there will be a red (phone?) symbol at the top of the watch.

 

Have you tried unpairing and re-pairing the watch (sorry if you’ve already said that you have)?

Share this post


Link to post
Share on other sites

No if I leave the house with the phone and the watch the phone loses the watch Bluetooth connection 90% of the time. 
 

I’ve tried all sorts. Un pairing. Deleting the watch from the phone. Nothing fixes it. Probably needs a visit to Apple for them to look into it. 

Share this post


Link to post
Share on other sites

That doesn’t sound right…I did mean the Bluetooth connection between phone and watch?

 

Nothing to do with the car.

Edited by Carrman2018

Share this post


Link to post
Share on other sites

Yeah I know. It’s a pain in the arse. So it must be a problem with the phone and the watch. Which is then screwing the idrive connection up if the phone is in the picture too. 

Share this post


Link to post
Share on other sites

I seem to remember some sort of setting in either the phone or watch that I had to toggle on or off when I initially set it up a year  ago. But I’m b@@g@@ed if I can find it again.

 

I think it turned off the music controls on the watch whenever music was played…

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.