Jump to content
Sign in to follow this  
Shaz-bmw87

Help!! Car cranks but doesnt start!! Error code reading?!

Recommended Posts

Hi,

My 120d 2007 bmw cranks but wont start. Did a computer error check and this appears;

EKP - CED4 - 28

Something to do with my electronic fuel pump module?? Does anyone know where this is located and if I replace will the car turn on? Anyone have similar issues they can help me out with please? Or is there another problem? 
 

When ignition is on i can hear the passenger side pump  priming. 

Thanks

Edited by Shaz-bmw87

Share this post


Link to post
Share on other sites

Rediagnose. If you can hea the fuel pump on ignotion then it could be something else. Is the car still original or have you coded new keys or remap etc...which could have upset the DME?


Is there any other errors? Try unplugging the DME and re-plugging it ensuring a good connection. Also check the earth point. It sounds moe CANBUs disabled than a physical fault and could be anything from a fuse or lose wire to a failed module  or water ingress. 

 

Also just to check - the cam chain hasn't snapped has it? (everytime I see/hear 20d engine, it's first thing goes through my mind)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×