Jump to content
Carrman2018

2020-4 Live maps full download available on Download Manager

Recommended Posts

Hmm. But not for those of us without? Just checked Download Manager and it is still showing 2020-3 as being current i.e. already downloaded??

Share this post


Link to post
Share on other sites

I’m sure the changes are not significant however there is also a big OS7 update (v. 11/20) being rolled out from today which may be relevant.

 


https://www.press.bmwgroup.com/global/article/detail/T0326465EN/new-remote-software-upgrade-available-for-over-one-million-bmw-vehicles-worldwide?language=en

Edited by Carrman2018

Share this post


Link to post
Share on other sites

I manually downloaded version 4 and installed it on my Nov 19 530e. Really irritating to see BMW announcing yet more ID7 updates (albeit mostly gimmicks) that for those of us with ‘ID7 Lite’ we can’t get. 
 

I switched to BMW after having 6 Merc’s - one of the reasons was BMW customer services and the dealer promising that the car I ordered would have the new operating system 7 which would be constantly updated ‘over the air’. They also said reverse assistant and drive recorder would be part of the package. All untrue but hidden in small print so customer service and the dealers team all missed it. BMW issued an internal announcement with the differences between SP15 and SP18 but deliberately didn’t change the marketing info. The dealer’s team has done its best so no complaints there. 
 

I am off to JLR by ordering a Range Rover Valar - their reputation for software ‘glitches’ is as bad as BMW’s but at least I’ll get ota fixes and won’t feel I was miss-sold a car 

Share this post


Link to post
Share on other sites

Thanks - I may need to be !  At least the JLR dealer is only 3 miles away - my BMW dealer is 40 miles away. They were so embarrassed initially they gave me a 850 as a loan car for 2 days but as the visits had to continue (3 software overlays / updates) I ended up with a Mini ! They really did do all they could. 
 

I was offered nearly £30k off a new 745e but found out that yet again there was an updated version coming so would be outdated when I bought it. I buy my car and the residuals on the 5 series are really poor and the 7 series crippling  - the Range Rovers seem to hold their value much better - don’t ask me why as they have a poor long term reputation. 

Share this post


Link to post
Share on other sites

In the UK. It listed at £90k+ offered at £ 64k and as you say worth no more than say £ 35k in less than 2 years. My 530e melted too - I do realise you shouldn’t chop them in within 3 years but still, it listed at £ 62k bought for £ 53k, 17 months later can’t get any more than £ 27,500 so more than 50% loss in 18 months. I bought mine so I had to swallow it. The Velar P400e is listed at £ 76k I’m paying £ 67k and 2 year old lesser spec with 46k is going for £ 62k on Autotrader.

 

I suspect there will be nobody on PCP’s seeing any equity in their cars when they return them. 

Share this post


Link to post
Share on other sites
2 hours ago, Wivenhoe said:

State of the market in used 530e’s - 

 

4CB6BDED-C48C-441F-ADB6-0411100B26BD.jpeg


Surprisingly low -  I get a higher quote on Webuyanycar for my 2019 (but 68 reg) 530d G31 with 4 times the mileage and I’d have thought the 530e carried a substantial premium.

Share this post


Link to post
Share on other sites

If only that was the case Boba !  The market doesn’t seem to like the plug-in BM’s yet the battery has a 6 year or 40,000 warranty. Strange as the Ranger Rover plug-ins have exceptional residuals. 

Share this post


Link to post
Share on other sites

I manually downloaded the 2020-4 update.  Unzipped it into a folder and then transferred the files to a flash drive. (This was advised to do as last time i tried to unzip the folder directly to the flash drive and it took 12 hours and still didn't work)

Plugged the drive in (same drive as I used when updating to 2020-3), car recognised the drive and started to update.  Got to 1% and then it came up with some error.  Unplugged the drive and back in, update - yes - 2% - error

unplugged, - back in - update - yes - 3% - error

I then went for a drive and the same sequence kept repeating although each time it got 1% more than the previous effort.  Gave up when it threw a fit at 7%

 

drive is the same as used last time, so is formatted correctly.

 

Ideas?

Share this post


Link to post
Share on other sites
16 minutes ago, SteveW said:

I manually downloaded the 2020-4 update.  Unzipped it into a folder and then transferred the files to a flash drive. (This was advised to do as last time i tried to unzip the folder directly to the flash drive and it took 12 hours and still didn't work)

Plugged the drive in (same drive as I used when updating to 2020-3), car recognised the drive and started to update.  Got to 1% and then it came up with some error.  Unplugged the drive and back in, update - yes - 2% - error

unplugged, - back in - update - yes - 3% - error

I then went for a drive and the same sequence kept repeating although each time it got 1% more than the previous effort.  Gave up when it threw a fit at 7%

 

drive is the same as used last time, so is formatted correctly.

 

Ideas?

I don’t recognise your process - as far as I’m concerned it does everything for me (I just click a few buttons for it to proceed and it saves it to the USB stick - I then plug it into the car).

 

Never been complicated in the 5 years plus I’ve used the service...

Share this post


Link to post
Share on other sites
29 minutes ago, SteveW said:

I manually downloaded the 2020-4 update.  Unzipped it into a folder and then transferred the files to a flash drive. (This was advised to do as last time i tried to unzip the folder directly to the flash drive and it took 12 hours and still didn't work)

Plugged the drive in (same drive as I used when updating to 2020-3), car recognised the drive and started to update.  Got to 1% and then it came up with some error.  Unplugged the drive and back in, update - yes - 2% - error

unplugged, - back in - update - yes - 3% - error

I then went for a drive and the same sequence kept repeating although each time it got 1% more than the previous effort.  Gave up when it threw a fit at 7%

 

drive is the same as used last time, so is formatted correctly.

 

Ideas?

It did that to me for the 2020-3 update; I had to do a complete re-format (the full one not the "quick") and then it worked fine.

Share this post


Link to post
Share on other sites

Ok, I'll try that.  The internet has been acting up in Helsinki today, so I thought it might be to do with that also.

Share this post


Link to post
Share on other sites
2 hours ago, SteveW said:

I manually downloaded the 2020-4 update.  Unzipped it into a folder and then transferred the files to a flash drive. (This was advised to do as last time i tried to unzip the folder directly to the flash drive and it took 12 hours and still didn't work)

Plugged the drive in (same drive as I used when updating to 2020-3), car recognised the drive and started to update.  Got to 1% and then it came up with some error.  Unplugged the drive and back in, update - yes - 2% - error

unplugged, - back in - update - yes - 3% - error

I then went for a drive and the same sequence kept repeating although each time it got 1% more than the previous effort.  Gave up when it threw a fit at 7%

 

drive is the same as used last time, so is formatted correctly.

 

Ideas?

2020-04 Downloaded and written to flash drive using the downloader tool from BMW - no problems at all for me .... have you tried using a different flash drive? - they don't last for ever

Share this post


Link to post
Share on other sites
53 minutes ago, SJL said:

2020-04 Downloaded and written to flash drive using the downloader tool from BMW - no problems at all for me .... have you tried using a different flash drive? - they don't last for ever

Are you iD7 or iD6??

Share this post


Link to post
Share on other sites

I believe i'm ID7 but with SP15 and no chance to go up to SP18.... or so the receptionist at BMW said.  Car is 530e with a production date of 8/2019

 

Don't have Android Auto, but do have Carplay. OTA updates don't happen and when the assistant asks how she can help (in car) and i say i'm cold, she says she is not equipped with that function.

Share this post


Link to post
Share on other sites

Job complete.  After upgrading to 2020-3 which took forever to transfer to a flash drive on a Mac, i was advised to unzip the folder first and then transfer to a flash drive. Which I did, but clearly that wasn't the way to do it.

Formatted drive, and transferred using BMW download manager and it's all done.

 

ID7 Lite - yes, i wasn't aware that my car had a lite version. and presumed that as it was manufactured in 08/2019 that it would in fact be a relatively modern car.....

Next service is in August, so maybe then there might be some updates

Share this post


Link to post
Share on other sites
1 hour ago, SteveW said:

 

ID7 Lite - yes, i wasn't aware that my car had a lite version. and presumed that as it was manufactured in 08/2019 that it would in fact be a relatively modern car.....

Next service is in August, so maybe then there might be some updates


Good to hear.

 

I have learnt never to buy a new BMW in the year before LCI.

 

They did the same with the F10 where they bring in a suite of updates but not the full house until the LCI so you don’t get the full benefit...

Share this post


Link to post
Share on other sites
1 hour ago, Carrman2018 said:

Your profile says an F11?

 


^^^ Read his car history though - G31.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×