Jump to content
5mithy

Coil pack problem?

Recommended Posts

1998 528i, 149k on the clock. It's recently developed a very slight case of the hiccups, hesitancy trying to accelerate in high gear. Only seems to do it when it's raining. It feels exactly how my previous car used to when it was suffering from a damp dizzy cap.

The engine light and ABS lights have come on, and gone out, a couple of times. But from what I've read I might not get a definitive code for coil packs if I take it to my local garage to have the codes read.

I've read up on how to test the coil packs with a meter, but if my problem is only slight and intermittent, I don't have much confidence that measuring the impedances will give me a definitive answer either.

 

But as the car has 149k on the clock, is it time to change them anyway, and look into it further if there's still a problem? I've never had a car with coil packs before, so they're not on my usual service item radar, so to speak...

Share this post


Link to post
Share on other sites

I had one coil pack fail on my M54 at around 140-145k miles, running on 5 cylinders, and two others were weak as well, so replaced the whole six. So yes I think you're probably due even if it may not be your actual problem !

Share this post


Link to post
Share on other sites

I’d hope even a fairly basic code reader would give misfire on cylinder x. If it does, pull the coil and swap with cylinder y, clear the codes and drive it. Read the codes again and hopefully you should get misfire on cylinder y - that proves your coil. I used to keep a spare coil in the boot of my e46 M3 after a couple of failures. 

Share this post


Link to post
Share on other sites
On 19/01/2021 at 18:25, 5mithy said:

The engine light and ABS lights have come on, and gone out, a couple of times.


Does that happen in conjunction with the stuttering?

 

I had a dodgy relay on my old E34 535i that caused the whole car to lose power for a second or so & cut out simultaneously flashing those lights on. 
 

It happened again when I forgot to tighten up the nut on the power distribution block on my 335i, it flashed up those same lights & caused it to stutter when hitting a bump. 

Could well have nothing to do with your issue though! 
 

If it’s only happening to you in rain it could be a bad earth somewhere, but that’s clutching at straws. 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×