Jump to content
jc7

Alpina D10

Recommended Posts

Any Alpina D10 owners or anyone with knowledge about them. 
 

Have a few questions. Regarding the fuel system. Please dm me.

 

Thanks. 

Share this post


Link to post
Share on other sites

I don't think there are on here - try the Alpinaregister; fuel system is similar in most respects to the 530d but the injectors IIRC are Alpina specific are command alpina prices.

Share this post


Link to post
Share on other sites

Alpina register for some reason Im having difficulty signing in. 
 

Unfortunately alpina come with a price tag. 
Just wanted to see if there are any owners that had the same symptoms. Injectors seem to be all good. 
It’s high pressure pump and fuel pump related. 

Share this post


Link to post
Share on other sites

Have you checked the Alpina D10 parts catalogue to see if the pumps are BMW or Alpina parts?

 

Try and e-mail the alpinaregister mods directly to see if they can help with logging in and posting your question there.

Share this post


Link to post
Share on other sites

Thanks 

 

Basically the car just cranks but doesn’t start. 
I have changed the in tank fuel pump, fuel filter, fuel pump relay, crank shaft and cam shaft. 
checked all fuses, all good.  
And to make matters better no codes show up. 
 

And D10s it seems that they don’t come with in line pump. 
 

thanks. 

Share this post


Link to post
Share on other sites

Assume you mean cam and crank sensors which would have been my guess. Had similar on an e46 330d that wouldn't start warm without codes.

Assuming it's getting fuel to the injectors?

Immobiliser issue? I've read something I'm sure about the key getting out of sync. Rolling codes or something.




Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites

Thanks for the reply. 
yea I replaced them sensors. 
though it was the key as well but the other 2 keys do the same thing. Plus I’m sure it shouldn’t crank.


there’s fuel in the fuel rail although not a lot of pressure. 
 

im just hoping it’s not high pressure pump. 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×