Jump to content
PatMo

BMW e12 m535i speedo stopped working

Recommended Posts

Hi, after recently removing my instrument cluster, when I put it back in the speedo has stopped working.

 

The mileage counter, which runs off the same wire has not which is strange, as I can't see how one can work and not the other?

 

Has anyone ever had a similar issue?

 

Thanks 

Edited by PatMo

Share this post


Link to post
Share on other sites

Hi PatMo

I would have to look at an e12 speedo to refresh my memory. I once did an e28 speedo to e12. The e28 it is possible to have a working speedometer and no mileage which of course is the ideal way,  your car does not decrease in value. The drive gears  can break and the mileage does not change. The speed comes from the differential and still works. The e28 is electro-mechanical.

The e12 is mechanical so the most likely cause is a gear problem. I will see if I can find a gauge to look at.

 

Share this post


Link to post
Share on other sites

Hi PatMo

Had a look at an old speedometer which was either e21 or e12. As I said it is a mechanical gauge. The speed and mileage are run from gears. The gears in the unit I have are all plastic and there are a lot of them so the most likely scenario is something broken or jammed. What did you do to your unit? Check the drive cable is in good condition and correctly inserted. To test the unit I have, I put a small torx bit in the cable entry and ran a drill at speed. There is no needle but the shaft moved and mileage increased. You could do this with your gauge. The bit I used was a T-10 and fitted without any force.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×