Jump to content
simufly

Radio switches off every 25-30 mins

Recommended Posts

So frustrating! I had the same issue and it was one of the functions for tp or rds, now I don't recall and can't for the life of me find the manual.

My radio would switch off or drop the volume to a point where I thought it was off after a given amount of time. Now it doesn't do that anymore. I can't recall if setting it to a different area code was key in the issue or not.

Share this post


Link to post
Share on other sites

I wonder if anyone has a pin wiring diagram of the flat pin socket for the radio. I could then do a bit more investigation work to see whether it’s the head unit or the car that is at fault.

Share this post


Link to post
Share on other sites

I believe this may be caused by a faultily ignition switch.

 

If the radio turns off after almost exactly 20 minutes than this points to the radio working in 'ignition off' mode, it's designed to turn off after 20 min to save power.  My guess is that the radio comes on when you pass through the accessory position I, but then the ignition power is not live when in the running position II.

 

This is the flat pin radio pinout (ignore sub connectors B and C as the 'Integrated' radio does not use them)

 

64_1284060146.jpg

Check the voltage on pin 16 with the ignition in various positions.

Share this post


Link to post
Share on other sites
6 hours ago, RichardP said:

I believe this may be caused by a faultily ignition switch.

 

If the radio turns off after almost exactly 20 minutes than this points to the radio working in 'ignition off' mode, it's designed to turn off after 20 min to save power.  My guess is that the radio comes on when you pass through the accessory position I, but then the ignition power is not live when in the running position II.

 

 

Uhhh this is a gold nugget. (The suggestion of checking the feed once it's running)

 

Edited by jicaino

Share this post


Link to post
Share on other sites
20 hours ago, RichardP said:

I believe this may be caused by a faultily ignition switch.

 

If the radio turns off after almost exactly 20 minutes than this points to the radio working in 'ignition off' mode, it's designed to turn off after 20 min to save power.  My guess is that the radio comes on when you pass through the accessory position I, but then the ignition power is not live when in the running position II.

 

This is the flat pin radio pinout (ignore sub connectors B and C as the 'Integrated' radio does not use them)

 

64_1284060146.jpg

Check the voltage on pin 16 with the ignition in various positions.

Great, thanks for the info. My initial thoughts too were the ignition switch, so I replaced it with an OE new one. Can you help with what the (30) in pin 15 and  (R) in pin 16 means? I assume that pin 15 is the main feed and pin 16 the acc feed?

Still I will get the AVO out and do some more investigation.

Edited by simufly
Typo

Share this post


Link to post
Share on other sites
7 hours ago, simufly said:

Great, thanks for the info. My initial thoughts too were the ignition switch, so I replaced it with an OE new one. Can you help with what the (30) in pin 15 and  (R) in pin 16 means? I assume that pin 15 is the main feed and pin 16 the acc feed?

Still I will get the AVO out and do some more investigation.

 

R means that it sees power only with contact on. terminal 30 means always hot.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×