Jump to content
Sign in to follow this  
525tds

525 tds random power loss help!!!

Recommended Posts

Hi guys, I bought a 525 tds e39 as a daily car a few months back, it needed a hell of a lot of work to get it back on the road, most of which I have sorted except this stupid power issue. 

 

Sometimes when full throttle nothing it barely manages to acceleerate, then after a while, say stopping at some lights and taking off the power comes back on and it accellerates fine, it's really doing my head in, I've exhauted the following 

 

New lift pump
replaced high pressure fuel pump

checked & replaced vacuum lines

changed fuel filter

replaced turbo 

checked all the wiring 

blanked the EGR at the exhaust end

 

Theres no bubbles coming when first starting and has no issues firing up first thing, leak off pipes are all good. The car is really annoying to drive, please can someone help me out? My INPA is not working so can't scan atm. Many thanks, 

Share this post


Link to post
Share on other sites

Can you hear a grinding noise coming from under or around the passenger site when turning the key to the II position?  If so it maybe the in line fuel pump under the passenger side, I have similar issues when accelerating and getting above 3000 rpm. I have the part ordered so cant say it fixes the issue yet. if you get INPA working check pre-supply pressure. 

Share this post


Link to post
Share on other sites

Is it manual or automatic? If automatic, maybe something to do with transmission. Honesty very first step should be faults scanned and some live data reading, because it could be anything. 

Share this post


Link to post
Share on other sites

Thanks for the replies, it is a manual. The lift fuel pump is working, it's super strange some days when you first turn it on it drives normal other days no power getting everywhere is a crawl. I had it scanned for fault codes none I'm struggling to get INPA to work as my laptop has got other software on. I thought by swapping all these bits over I would have fixed it, it feels like a restriction in the fuel lines, a little jerking and power is back on, super strange.

Share this post


Link to post
Share on other sites

Sounds throttle pedal related, given they are FBW.

 

these also use a MAF i believe, unlike the older variant of the engine, what year is it?

Share this post


Link to post
Share on other sites

pray its not the pedal potentiometer, I just looked up how much they are :blink:

 

shared with all the fbw diesls from 1990 to 2000 though.

 

 

definitely need to be able to read live data should be obvious what it is when it does happen.

Share this post


Link to post
Share on other sites
43 minutes ago, welshpug said:

pray its not the pedal potentiometer, I just looked up how much they are :blink:

 

shared with all the fbw diesls from 1990 to 2000 though.

 

 

definitely need to be able to read live data should be obvious what it is when it does happen.

Exactly, without reading live data and faults, and only replacing something with hope it will sort the problem is like dumping good parts one by one down the drain.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×