Jump to content
Joss

Compression. F##k

Recommended Posts

10 hours ago, duncan-uk said:

arse...

Indeed. Well it’s head off time. 
 

So what are we betting on? No blue smoke, no chuffing back up inlet, no coolant loss or oil mix And rockers checked. None broken

 

Place your bets people

 

Cracked head

Burnt/chipped exhaust valve

coked exhaust valve
 

 

 

Share this post


Link to post
Share on other sites
6 minutes ago, Joss said:

Indeed. Well it’s head off time. 
 

So what are we betting on? No blue smoke, no chuffing back up inlet, no coolant loss or oil mix And rockers checked. None broken

 

Place your bets people

 

Cracked head

Burnt/chipped exhaust valve

coked exhaust valve
 

 

 

Hi Joss, broken valve spring or stuck valve, but if you are really lucky, broken rocker shaft or follower...……..all of which I  have, so shout?

Share this post


Link to post
Share on other sites

Well mate. We’ll have to see. Here’s hoping it’s a cheaper fix 

Share this post


Link to post
Share on other sites
34 minutes ago, Ordnator said:

Valve stem seals?

Won’t cause low comp. will cause oil on over run. Also I changed them not ling ago. 

Share this post


Link to post
Share on other sites
3 hours ago, duncan-uk said:

Assume 1.72  unless you are skimming in which case 2.2 would be my guess.

That was my thought unless someone knew a reason  

Share this post


Link to post
Share on other sites

Engine on TDC. Most ancillaries removed now so almost ready to pull the head. Head bolts. Are we undoing in a pattern to reduce head stress? Reverse of tightening? 
 

 

Share this post


Link to post
Share on other sites

Yes. Remove head bolts in reverse sequence to installation.  You may be lucky to find one or two loose or snapped bolts.

 

FWIW, I'd go for a light head gasket blow, possibly between adjacent cylinders or worst case scenario, it could be cracked on a exhaust port. Not heard of burnt valves on these but it's a possibility. 

 

M90's were the doyen of the early series of m30 motors. But due to the race inspired spec, turned out to be a bit more fragile in service, something rectified with the later productionised 3430 big block. 

 

good luck. 

Share this post


Link to post
Share on other sites

 Get me that casting number on the head, I will double check stock

Share this post


Link to post
Share on other sites
6 hours ago, Tims said:

 Get me that casting number on the head, I will double check stock

1304473

Share this post


Link to post
Share on other sites
12 hours ago, Sir Anthony Regents-Park said:

A later L Jet 358 (525i 528i) head will fit iirc.

 

 Is there anywhere a ready rekoner for what head's fit what?

Share this post


Link to post
Share on other sites

Not that I know of. The 358 arrived around 1978 for the 528i. 473's are fitted to 3210 cc engines in the old L Jet stuff (633CSi, 733i etc) and the 3453 cc 3.5. 

 

Tbh, they all need a full rebuild now so you might as well have the correct head fitted. A cracked head would cause overheating issues - that sort of compression loss would be a burnt valve. 

Share this post


Link to post
Share on other sites

Just to update. Head is striped. Did a very basic tip petrol in upside down head chamber. 1 and 5  l leaked in less than a minute. All the others including 3 were fine so who knows. It’s being dropped at the engine builder tomorrow for pressure testing. Then if it’s good I’ll check the valves. 

Share this post


Link to post
Share on other sites
33 minutes ago, Joss said:

Just to update. Head is striped. Did a very basic tip petrol in upside down head chamber. 1 and 5  l leaked in less than a minute. All the others including 3 were fine so who knows. It’s being dropped at the engine builder tomorrow for pressure testing. Then if it’s good I’ll check the valves. 

 Hey Joss,

 

The petrol test 1 & 5 result doesn't quite line up with your low 3 compression test result.

 

If this is the first time the head has been off then it has had a good run so far, and likely a little past being due some love.

 

Best regards,

 

Mick

 

Share this post


Link to post
Share on other sites
15 minutes ago, Ordnator said:

 Hey Joss,

 

The petrol test 1 & 5 result doesn't quite line up with your low 3 compression test result.

 

If this is the first time the head has been off then it has had a good run so far, and likely a little past being due some love.

 

Best regards,

 

Mick

 

Hi Mick. 
 

was new to the car 30-40k ago. It’s was off a race car and was raced for 3 seasons before it was put on this car. Yes agreed doesn’t make sense. Wish I could post all the pictures I have but they’re too big to load here. Will have more info from the builder this week. Valves look fairly shitty tbh. Once the head is checked they’ll be pulled, cleaned, replaced if required and re lapped so head will be good hopefully. Beginning to suspect rings but the wet comp test made no difference to comp. gasket was also showing signs of leaking all around 1 and between 1-2 and 5-6 

Edited by Joss

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×