Jump to content
The Situation

Oil/burn smell after oil service

Recommended Posts

I had the oil and micro filter service done at BMW last week and since then, I have noticed a kind of oil heat/burning smell come through the vents after a while.

 

Has anyone any ideas what this could mean/or related to the oil service?

Share this post


Link to post
Share on other sites
21 minutes ago, McBeemer said:

I would hazard they’ve spilt oil on the refill or removing the oil filter and not cleared the spillage. 


I hope that’s the only issue, smell worse now like BBQ briquettes and smoke comes out the front bonnet area.

 

Theres no error message or anything showing overheating etc so just hoping the spillage burns off asap.

Share this post


Link to post
Share on other sites
5 minutes ago, Pedro79 said:

Why? Surely no consideration here. It needs to go back. 


Trust me I know, it’s just a hassle dropping off and taking the train back/forth as in order to get a loan car there’s like a 4-6 week bloody wait at Sytner Chigwell!

 

However I have warranty left for a couple of months so plan was to always take back one more time before it expires.

Edited by The Situation

Share this post


Link to post
Share on other sites

Take it back immediately and they will look at it immediately. 

 

No wait required. 

 

It could be serious. I'd be tempted to get it towed by them or an engineer called out. 

Share this post


Link to post
Share on other sites
5 minutes ago, Skynet5 said:

Take it back immediately and they will look at it immediately. 

 

No wait required. 

 

It could be serious. I'd be tempted to get it towed by them or an engineer called out. 


Im off work all week next week so you have persuaded me, will call tomorrow

Share this post


Link to post
Share on other sites
Just now, IINexusII said:

or how about opening the bonnet and taking a look instead of speculating here?


I did earlier - could not see anything nor heavy smoke coming out.

Share this post


Link to post
Share on other sites

Can you get someone to rev the car while you look at the engine? With the cover off. 

 

Is it definitely the smell of oil burning? Or could it be the exhaust fumes? 

 

I would just check and make sure the manifold hasn't cracked, as you really don't want to be driving it around if you have exhaust gasses coming into the cabin. 

 

I would guess they have just spilt some oil on the block, but get someone to rev it while you're looking at the engine just in case. 

 

Also, check there is no oil leaking around the filter housing, seems strange it is still smelling now. Normally burns off after a few miles. 

 

 

 

Share this post


Link to post
Share on other sites
18 hours ago, gIzzE said:

Can you get someone to rev the car while you look at the engine? With the cover off. 

 

Is it definitely the smell of oil burning? Or could it be the exhaust fumes? 

 

I would just check and make sure the manifold hasn't cracked, as you really don't want to be driving it around if you have exhaust gasses coming into the cabin. 

 

I would guess they have just spilt some oil on the block, but get someone to rev it while you're looking at the engine just in case. 

 

Also, check there is no oil leaking around the filter housing, seems strange it is still smelling now. Normally burns off after a few miles. 

 

 

 


Not exhaust fume smell have to say.

 

Either way it’s booked to go in tomorrow and with my warranty still valid, hoping one way or another it’s sorted as 10 days in from the oil service, there was still a little smoke today and smell.

Share this post


Link to post
Share on other sites
16 hours ago, marko530d said:

Keep us updated 


So just got back - they confirmed was oil that was spilt, they did a clean up and said there will be smoke/smell for a couple of more days.

 

They kept for a few hours while I waited so sure they checked for leaks or anything else.

 

Will keep an eye on it

 

Share this post


Link to post
Share on other sites
1 hour ago, The Situation said:

 

Will keep an eye on it

 

 

If it still smells after a day or too, go straight back, do not pass go and stamp your feet and make a fuss in the dealership.  They shouldn't have been sloppy and spilt oil in the first place.  On the N53 the filter and filler cap are right on top of the engine, the filter being next to the cold inlet manifold and the filler cap is in the centre of the head so far enough away from the hot exhaust manifold.  Sounds like the must have really sloshed oil about to get it on the exhaust.

Share this post


Link to post
Share on other sites

Oh my n53 ears picked up... does OP have an n53?  If so agree with what Andrew says but also if they are that sloppy oil will be down in the coilpack recesses and oil can cause all sorts of problems there. Needs careful cleanup.  In fact on the n53 it's really hard not to get a little dribble down there, and over 50k or so the oil filler cap o-ring weakens and can dribble a tiny bit of oil when you take the cap off. Builds up over time. Right over cylinder 3.

 

Could apply to other engines. 

 

Not sure OP has a n53 though...

Share this post


Link to post
Share on other sites
15 minutes ago, bmwmike said:

 

 

Not sure OP has a n53 though...

 

No he doesn't, I was talking complete bollox as he has an N20.  I read it he had a 530i not a 520i.  D'oh.  My bad, sorry.  Should have gone to spec savers.

 

N20, has the oil filler cap at the front and side of the cylinder head so could be near part of the hot exhaust manifold.  Certainly nearer than on an N53.

 

You are dead right Mike, you don't want oil down in the spark plug tubes.

 

 

Share this post


Link to post
Share on other sites
1 hour ago, 535i Andrew said:

I don't think petrol injectors have leak off return pipes.

 

Well my N55 doesn't or not that I can see

 

IMG-5315.jpg

 

but as we all know, it's an N20 the OP has.;)

My bad :shock:

Share this post


Link to post
Share on other sites

All I wanted was the oil service - had known idea they could balls it up that badly.

 

I’m glad one of the members here persuaded me not to wait and take to dealers, will drive further for another day and just book back in if no better.

Share this post


Link to post
Share on other sites
1 hour ago, 535i Andrew said:

Yes, don't let them fob you off. 

 

They had the car, you got it back, it wasn't right, they need to fix it.


I bet they charged this work onto the warranty as I still have it until April, even though it’s an issue they caused!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×