Jump to content
Iain525

E34 525i 1994 running cold

Recommended Posts

1994 BMW E34 525i Touring

 

Noticed the temps are staying at around 1/4 or lower, so I've changed the thermostat with a new genuine BMW 88C one (matching original). 

 

When trying to run it up to temperature to get it all bled/checked over the temps are still taking forever to even rise past the blue.  Heaters are warm, rad top hose is warm but bottom is cold.  Radiator is stone cold to the touch.

 

What should I be looking at next?!

Share this post


Link to post
Share on other sites

Does the viscous fan spin freely or is it locked up? It should spin freely with the engine cold, and only lock up when the car is hot. If it's locked up, then it'll be overcooling the radiator. Also, if your car has an auxiliary fan (I know A/C equipped cars do, not sure about others) then check that's not running.

Share this post


Link to post
Share on other sites

I can only think that either the thermostat is at fault, despite being new, or the gauge is miss-reading either due to a fault with the gauge or the sensor. 

Share this post


Link to post
Share on other sites

In this weather the bottom of the rad and hose should be cold. Old style wax thermostats are a lottery. I refused to pay 50 quid+ from BMW (they only buy them in) so went for a Febi one. That, when tested in a pan of water didn't open at all. The Circoli one I replaced it with did, and the car (E36) warms up in 2 miles. 

 

Tbh, you may as well fit a 92 degree stat. That's what I used. 

Share this post


Link to post
Share on other sites

Funny this subject should be brought up.

I recently coughed up for a genuine BMW thermostat and I'm not happy with it either.

When cruising at a constant speed, the temp guage fluctuates between 11 o'clock to 12 o'clock.

 

Water pump and radiator also brand new so the only thing I can put it down to is the thermostat. No air locks what so ever and heater working perfectly.

 

May well be giving Cotswold a ring soon regarding a replacement as it's only a couple of months old

Edited by boiliebasher

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×