Jump to content
Wolfgang009

Bmw e60 dsc issue

Recommended Posts

Hi all,

I am having problem with my e60 2007 525i. I have had the dsc light on sice bought and wanted to fix it. I have scanned through Inpa and get several code from szl and dsc please see attached picture. I have changed the SZl unit and coded the new vin using ncsexpert but still same issue. My question is how do you remove or deactivate the brake air flaps from the car system as they are not mounted on the car? And other question is on Ncsexpert I do not have the option to code my dsc when reading ecu the dsc just does not appear but I can read fault through inpa by going directly to chassis-dsc then read the faults. If someone could help would be greatfull I think it is a coding problem but not very familliar with ncs. Thanks

D279BAF2-6EED-4511-A2ED-52E8747C3660.jpeg

B34C9311-E7C8-4A0D-918D-123F060A6E11.jpeg

468C6BDC-E339-42E7-9F73-1E596FA08501.jpeg

2AD656E5-22A8-4059-8F44-38C48A383A00.jpeg

53AC1C8D-54E3-40A4-A9CE-060F6301C639.jpeg

905E2065-DF88-4C21-8E3F-FA4B71DD82A7.jpeg

C33A5BB7-5F2E-42EC-8F4F-E0417963B92F.jpeg

6E2BD2B6-6EA0-4094-9A7A-B3480C0E7F83.jpeg

D7EC0014-4033-4312-9934-9D3A82DE9E42.jpeg

Share this post


Link to post
Share on other sites

DSC = EHB3

 

And I wasn't aware you could decode the vin with NCS, you have to do that with WinKFP.

Share this post


Link to post
Share on other sites

Yes via winKFP my bad. So I just code the ehb3 then? I will try it just now and see how it goes then let you know. Im not used to this at all everything I do I verify online first in case the car does not switch on

Share this post


Link to post
Share on other sites

@GoNz0 so I went through ncs expert selected ehb3 and execute jod under sg_codieren then same for szl fired up inpa cleared faults and still the same. Im I doing it correctly or missing some stuff? It seems too easy and straight forward so I thing I am missing something. Inpa does not give me the option to select the szl please see attached pic. If you could assist me please as I am really struggling with this

77FC4BDF-2C53-46AB-ACA6-7D5BC53AB64E.jpeg

image.jpg

Share this post


Link to post
Share on other sites

So I tried to use winkfp but I cannot see the spdaten files that needs to be loaded. But when I use tools32 I can see that the szl the vin correspond to my car vin. This is what I did on tools32 like 2-3weeks ago so the vin is good for the szl. Now what do tou think I should do?

FB23B30C-DE03-4EC4-9699-1483058881AA.jpeg

Share this post


Link to post
Share on other sites

Update guys fault cleared perfectly wouhou thank you for helping out. So for those having the same issue if it worked for me might work for you

1. Changed Szl Vin Number using tool32

2. Verified Dsc Vin using tool32 to make sure everything was done

3. Then using tool32 look for dsc_60pp

then test_auto_codierung as I was not able to locate Lenkwinkel ausgleichen so trial and error and it worked. 

65AB89F7-2CB2-4B74-888F-19D9FBB3E497.jpeg

EB238004-593A-48F4-ADB2-78FF0B260EEC.jpeg

82F423C5-07A0-472F-8A1F-E431931D8578.jpeg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×