Jump to content
Riverside98

Bmw e61 m54b25 oil leak and rough start

Recommended Posts

hello! recently got a massive oil leak a couple of weeks ago, i am loosing 1 litre of oil after a week of regular driving.

replaced my valve cover gasket a while ago due to it being cracked, replaced oil filter at the same time. 

I thought the ccv was the culprit but i am not really sure, the oil cap is easily removed when the car is on but i've noticed the idle is changing when the cap is off. Thoughts? Maybe the oil filter housing?

 

About the rough start.

The car does start fine sometimes, other times it has a rough time to start. The engine is turning and i can smell gas. I've noticed that if i lock and unlock the doors from the inside it will have a good start (almost everytime). 

I should mention that my diamond key is dead, does nothing when i press any of the buttons.

Share this post


Link to post
Share on other sites

Yeah, all the oil is dripping down on the ground. No smoke etc so i guess the oil is just leaking. Is it possible that the car can loose that much oil from a leaking oil drain plug and oil filter housing gasket?

I do know oil is leaking from the drain plug but i'm not sure if its leaking from the oil filter housing gasket. Any more spots to check where its leaking from?

 

The oil pan had alot of oil around it but its dry oil, i did find wet oil under the engine block, front side.

Share this post


Link to post
Share on other sites

I just fixed Oil Filter Housing, KGE, Vanos and Valve Cover Gaskets.....This fixed many issues, but still my oil pan gasket is giving me trouble. I hope I make it still through German inspection by TÜV (every 2 years).

 

I my case opening the cover underneath and taking a look from below revealed that my prob is the oil pan....

Share this post


Link to post
Share on other sites

What is kge? I will have the vanos done soon, havent found any trouble with it yet though.

 

In my case i completely removed the plastic cover under the car so i could see the oil pan, at first i thought it was the oil pan gasket but it was dry and old oil all around the pan. I found wet oil on some spots of tve engine though so i am going to have a look later today. I really do hope its nothing major that is broke.

Share this post


Link to post
Share on other sites
49 minutes ago, Riverside98 said:

What is kge? I will have the vanos done soon, havent found any trouble with it yet though.

 

In my case i completely removed the plastic cover under the car so i could see the oil pan, at first i thought it was the oil pan gasket but it was dry and old oil all around the pan. I found wet oil on some spots of tve engine though so i am going to have a look later today. I really do hope its nothing major that is broke.

 

Sorry my bad...KGE (sorry im German) is Crankcase ventilation system...This together with Oil Filter Housing Gasket is on the right side (of the M54 engine) and on left is Vanos and Valve Cover Gaskets....These are the major things to fix on every M54 engine after 10-15+ years. Some of the work is the same....so usually it makes sense once done either left or right side, to do both things because its just little more work...

 

Oil pan gasket is often needed as well after some 15+ years...and when not done by yourself quite costly (400-600 EUR at regular garage in Germany...do not want to know prices at BMW!) because axis needs to be lowered and engine to be lifted...5 hours of work....there is an easier way which repairs it to 98%...cutting the gasket into 2 pieces...then axis and engine stays the same and amount of work is signifikantly less....

 

 

Share this post


Link to post
Share on other sites

Oh okey, kge = crankcase ventilation systems.

 

I think i got the oil leak covered right now, going to check it out today. I washed under the car yesterday and did some driving just to get an easier clue to where the leak is coming from.

 

Still got the random hard start problem to fix though, the car is not throwing any codes about misfiring, ignition, fuel etc so i dont really know where to begin. I installed new spark plugs, the old ones were pretty old but it did no difference. 

Any thoughts on where to begin? Doesnt matter if the car is warm or cold, no loss of power or rough idle so i'm clueless right now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×