Jump to content
Chu

Wobble diagnosis

Recommended Posts

5 hours ago, Chu said:

Yes fog/spotlight in bumper.

Indy only uses genuine parts but tempted to do drivers side myself if aftermarket light is identical to gen.

Bumper had to come off to do passenger side..not the case with passenger side?

 

 

Bumper doesn't have to come off at all, you come up from the underneath. three screws hold it in iirc. 

Share this post


Link to post
Share on other sites
18 hours ago, Deviant said:

 

 

Bumper doesn't have to come off at all, you come up from the underneath. three screws hold it in iirc. 

Have you done this yourself?

The washer bottle makes it a bumper off. Unless chris plummer is a liar which i dont think he is. He has always been no nonsense and straight.

Share this post


Link to post
Share on other sites

Yes, I have. Once you do the driver's side, you'll know what you're doing on the passenger... You don't need to remove the wheels, just turn them in. I came up under the front bumper where the undertray meets the arch liner. 

 

 

Edited by Deviant

Share this post


Link to post
Share on other sites
43 minutes ago, Deviant said:

Yes, I have. Once you do the driver's side, you'll know what you're doing on the passenger... You don't need to remove the wheels, just turn them in. I came up under the front bumper where the undertray meets the arch liner. 

 

 

So you have done passenger side with the washer bottle?. I dont think its poss as it obscures the spotlight there just isnt room unless my mech found it easier to take bumper off.

Has anyone else done passenger side to confirm this?.

Share this post


Link to post
Share on other sites

I have done both. The passenger side looks impossible until you do the driver's side and understand what needs doing. 

 

https://www.newtis.info/tisv2/a/en/e60-530i-lim/repair-manuals/63-lights/63-17-front-fog-lamps-additional-lamps/G4BYwHi

 

https://www.newtis.info/tisv2/a/en/e60-530i-lim/repair-manuals/63-lights/63-17-front-fog-lamps-additional-lamps/Pd3bneF

 

 

Edited by Deviant

Share this post


Link to post
Share on other sites
23 minutes ago, Deviant said:

Thats that then

 

27 minutes ago, Deviant said:

Guess my mechanic found it easier to just remove bumper. Cheers!.

Share this post


Link to post
Share on other sites

Had wheels refurbed..shop said no buckles or flat spots or cracks. 14 yr old alloys in tip top shape.bmw recall highlighted a couple of likely causes so onto them next. Can see faults in batt recall thread.20190911_193307.thumb.jpg.2ae73abe6acdd514588cb1896c5b6b62.jpg

Share this post


Link to post
Share on other sites

Anyone have the paint code for the Silver paint they used on these alloys? Mine has the same colour, I scraped one side a week after refurb that I want to fill and spray myself.

 

 

 

Share this post


Link to post
Share on other sites
3 hours ago, San75 said:

Anyone have the paint code for the Silver paint they used on these alloys? Mine has the same colour, I scraped one side a week after refurb that I want to fill and spray myself.

 

 

 

These are black chrome.

Share this post


Link to post
Share on other sites
1 hour ago, San75 said:

Thanks Chu. Have you completely sorted your wobble issue?

No.. could be any one of these.20190907_175012.thumb.jpg.7719d0b35cc6bc75ee22e6bcad20e06c.jpg20190907_175021.thumb.jpg.723932744e808571db00ba2810f09a92.jpg

Edited by Chu

Share this post


Link to post
Share on other sites

Hi Chu. I have the same spec car as you, mine had play on the drivers side outer tie rod although the MOT said inner and the top mount was gone. After changing these parts my wobble was still there. I ended up doing all the front suspension, rear shocks, engine mounts and gearbox mount. To this day the wobble is still there after many alignments. Can you please describe your wobble in more detail?

Share this post


Link to post
Share on other sites
41 minutes ago, San75 said:

Hi Chu. I have the same spec car as you, mine had play on the drivers side outer tie rod although the MOT said inner and the top mount was gone. After changing these parts my wobble was still there. I ended up doing all the front suspension, rear shocks, engine mounts and gearbox mount. To this day the wobble is still there after many alignments. Can you please describe your wobble in more detail?

Passenger seat shakes and my love handles dance..this was made better by having the wheels re balanced( new weights can fall off worth checking). There is still a very slight wobble which im hoping is solved by fixing all on list.

Share this post


Link to post
Share on other sites

Have you checked you steering rack for play? I am convinced this is at fault on mine.

Edited by San75

Share this post


Link to post
Share on other sites
2 hours ago, San75 said:

Have you checked you steering rack for play? I am convinced this is at fault on mine.

One of the faults is steering rack related.

I am waiting for a price for all jobs. Mechanic did say he had this issue before on a e60 and after replacing lots of parts it turned out to be driveshaft bearing.however the wobble is not felt through the steering wheel.

Edited by Chu

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×