Jump to content
Norseman

alphanumeric dash display

Recommended Posts

Hope this isn't a daft question (when you are new to a car it's difficult not to ask these) but is it feasible to repair/replace the alpha display at the bottom of the instrument panel?

With 146k under the car's belt many of the characters are now unreadable, though thankfully both the total & trip mileages are still discernible.

I suspect rectification isn't financially viable on a 21 year old car, but I thought I'd at least ask :(

Thanks' all.

Share this post


Link to post
Share on other sites

this ploblem is well known. ebay for diy kit or as above  rudi was / is over west london i think  shout out dennis cooper he will know

 

Share this post


Link to post
Share on other sites
1 hour ago, Norseman said:

Hope this isn't a daft question (when you are new to a car it's difficult not to ask these) but is it feasible to repair/replace the alpha display at the bottom of the instrument panel?

With 146k under the car's belt many of the characters are now unreadable, though thankfully both the total & trip mileages are still discernible.

I suspect rectification isn't financially viable on a 21 year old car, but I thought I'd at least ask :(

Thanks' all.

 

It's a well known issue and there are a lot of places that fix these now.

 

Google Pixel dash repair BMW E39 and it'll bring up a plethora of sits that specialise in this. Think one is BBA Raman; there's also someone on the Facebook pages that specialises in this and travels the country also; this is them: http://pixelsfixed.co.uk/?fbclid=IwAR0ngBEiXCpkuLfcAALW5PKrfELK2qfIa24n7W_gFTUTpIFLeyqGbbkRyds

Share this post


Link to post
Share on other sites

Not a hopeless situation after all then, your help is much appreciated :grin:

Share this post


Link to post
Share on other sites

Not sure what you mean by B10, but if referring to the car > 1998 E39 523i SE auto.

Thank you for your reply.

Share this post


Link to post
Share on other sites
38 minutes ago, Norseman said:

Not sure what you mean by B10

 

On 09/07/2019 at 14:53, Norseman said:

alpha display at the bottom of the instrument panel?

 

I read alpha to be alpina (aka ALPINA) :oops::oops::oops:.  Yesterday I was asked the same question by an ALPINA owner. Somehow I didn’t read it correctly.

 

There is also another company in North London who did similar work for me about 15 years ago on my previous 325. I was impressed with them then, but offhand can’t remember who they’re

 

My cluster also needs to fixing and I’m thinking of either of them doing the job.

 

 

 

Share this post


Link to post
Share on other sites

Hi,

 

I've used AK Speedo in the last couple months for some custom work on a couple of instrument clusters and will be using them again in the near term future for a little more custom work. Very fast turnaround, great communication from James and a big thumbs up from me :)  

 

No missing pixel work as I don't have the MID panel and the small display in my cluster is working just fine and if/when it goes, I'll look to AK Speedo first. 

 

http://www.akspeedo.com/

 

Cheers, Dennis!

Share this post


Link to post
Share on other sites
2 hours ago, DennisCooper said:

No missing pixel work as I don't have the MID panel and the small display in my cluster is working just fine and if/when it goes, I'll look to AK Speedo first. 

 

So you are talking about High cluster with text display? I assume yours is post 2002 model?

Share this post


Link to post
Share on other sites
11 minutes ago, Clavurion said:

 

So you are talking about High cluster with text display? I assume yours is post 2002 model?

 

98 523i by the looks of his details under his username :) 

Share this post


Link to post
Share on other sites

Hi Clavurion,

 

My car has the basic stuff only, instrument cluster looks like this;

 

DSC00366.jpg 

 

My Board Computer has a few functions, 6 I think when scrolled via the 'BC' button on the stalk and the details show in that little text display under the odometer.

 

And the head unit area now looks like this;

 

DSC00597_zpsx1gejarp.jpg

 

My car is a November 2002 build at Police specification.

 

Cheers, Dennis!

Edited by DennisCooper

Share this post


Link to post
Share on other sites
59 minutes ago, DennisCooper said:

My car has the basic stuff only, instrument cluster looks like this;

 

DSC00366.jpg

 

That's LOW cluster without text display.

 

My point was only that the late E39's usually don't suffer this typical cluster pixel problem. Personally I have 9/2002 built original unit with zero pixels missing.

Share this post


Link to post
Share on other sites

Lots of replies here, so to reply to you all my display reads total mileage / trip mileage & (I think) ambient temperature.

Pressing the LH stalk brings up (underneath, in larger pixels) info. like range / average mpg / average mph. plus several others, but the pixels are too bad to read.

Thanks all.

Share this post


Link to post
Share on other sites
On 10/07/2019 at 23:34, Clavurion said:

 

My point was only that the late E39's usually don't suffer this typical cluster pixel problem. Personally I have 9/2002 built original unit with zero pixels missing.

 

I think it's more like the luck of the draw, my Dec '00 build M5 had zero pixels gone after 230k miles - and they still all work when I connect the battery even now. Whereas my current daily is a Sept '02 build and has missing pixels which are a pain in the backside...

 

 

20190710_195153.thumb.jpg.9ed743dfcb96385d06cf5f41b264a39e.jpg

 

20190710_195627.thumb.jpg.70b40b58f91d950c8b353f6556f63ad6.jpg

 

 

Share this post


Link to post
Share on other sites
3 hours ago, Seesure said:

I think it's more like the luck of the draw

 

I bought my 03 reg E39 in 2007 with  60,000 on the clock and it had missing pixels. 

Fixed by Rudi and still working when I sold it in 2017.

Share this post


Link to post
Share on other sites
On ‎10‎/‎07‎/‎2019 at 18:19, nealpina said:

There is also another company in North London who did similar work for me about 15 years ago on my previous 325. I was impressed with them then, but offhand can’t remember who they’re

 

Here is the link to speedofixer 15 years ago without a doubt I will have recommended them, but don't know them now 

Edited by nealpina

Share this post


Link to post
Share on other sites
On ‎12‎/‎07‎/‎2019 at 12:58, Paddy O'Furniture said:

Fixed by Rudi and still working when I sold it in 2017.

 

I have heard a lot of good and positive things about Rudi for over 12 years or more, but lately a fair bit of negativity.

 

Not sure if the negativity is justified but it has placed a doubt in my mind

Share this post


Link to post
Share on other sites

 

On 09/07/2019 at 14:53, Norseman said:

Hope this isn't a daft question (when you are new to a car it's difficult not to ask these) but is it feasible to repair/replace the alpha display at the bottom of the instrument panel?

With 146k under the car's belt many of the characters are now unreadable, though thankfully both the total & trip mileages are still discernible.

I suspect rectification isn't financially viable on a 21 year old car, but I thought I'd at least ask :(

Thanks' all.

Im not far from Chelmsford , can repair the dash , did my M5 recently, drop me a PM and you can pop over to sort 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×