Jump to content
Andyrt200

DME vers / new EWS loosing sync

Recommended Posts

Not sure if this should have gone in the coding section, sorry if so!

 

So to try to cut a long story short, it’s had problems starting for a very long time. Originally it wouldn’t crank over - EWS issue same with both keys, changed ring round ignition, no better so got a new EWS unit from BMW. Obviously comes coded to your keys from factory but still need to be synced to your DME. So I got INPA did that, thought it was fixed. 

 

However since then the new EWS has been occasional losing sync with the DME - car cranks over but won’t fire. It logs a fault code along the lines of “EWS anti tamper”. Plug INPA back in resync EWS with DME again it starts first time again. 

It doesn’t take long, but we have had some very close calls with the laptop getting left on & it having a flat battery! 

I did do a lot of searching about on the web & found a few other people reported the same problem. It seems it has something to do with the only EWS you can buy now being version 4.3, the one it came with was vers 3.(something). I found one thread where a guy in LA took his back to the dealer lots of times till they finally fixed it, he said they eventually found updating the software in the DME fixed it. Of course that’s just one guy... But its the only lead I can find & it sounds quite likely. 

 

I looked into updating the DME my self but chickened out worrying I could easily brick the DME leaving us with a car that wasn’t ever going to start (at last not without a whole heap more work anyway!). 

 

I thought about taking it into BMW to get them to do the update but it seems like a lot of bother for something may not even fix it. 

 

However we got the air bag recall letter last week, so it has to go back to the main dealer, this Friday so I thought as it was going in anyway I may as well ask. 

 

I spoke to the service booking lady about the problem but I could tell she didn’t really know what I was talking about, she said I’d need to talk to one of the guys there when I came in. She did know about DME updates though & said it would be an hours labour - £107!! just to plug it in to see if there were any updates available, if there was it would probably still just be the hours labour to do it. If they do have an update available I don’t mind paying just to try, it’s just paying to be told there’s nothing they can do that gets me! 

 

A good many months ago I did get WinKFP up & running with the latest files loaded in it & it seemed like there were updates available for the DME but it was at that point I decided I really shouldn’t go any further as I really didn’t know what I was doing! 

 

I just tried opening WinKFP again to see if I could at least see if I could first at least check if there were really any updates available for the DME but the program won’t even open on the laptop now, I took that as a sign! 

 

INPA is still fine (luckily or the car would be car would be stuck not starting) so I wondered if anything on the screen shots gives an indication of the software version of the DME? I assume its vers 1.17, but I’m not sure if I can check if BMW would have a higher version than that. There is of course lots of different aftermarket versions / tunes for it. I was looking into just doing an EWS delete on it myself but would rather explore the proper way first. 

 

I note it even said MS 43.0 for M54 with EWS3, if there was one for EWS4 it would be a good sign, but I doubt there is!

 

 

 

0ADC55B3-7A40-4423-B2E1-5CFF95821DC3.jpeg

FD5BD333-0CC2-4307-8C0E-E026EF8A396A.jpeg

Share this post


Link to post
Share on other sites
12 hours ago, Clavurion said:

Last 7 digits on the part nr. = software nr. With that software nr. you can see the updates and newest being 7551616.

 

https://www.realoem.com/bmw/enUS/partxref?q=7518111

 

Ah, great many thanks again!

 

The DME still has that same part number on its sticker too, so I guess it must be the version it left the factory with. I don’t suppose there would have been any reason to update before. 

 

I will report back tomorrow after going to the main dealer. 

Share this post


Link to post
Share on other sites
39 minutes ago, Andyrt200 said:

The DME still has that same part number on its sticker too, so I guess it must be the version it left the factory with. I don’t suppose there would have been any reason to update before. 

 

Then it has the original software from the factory. These older vehicles quite rarely actually needed software updates. 

Share this post


Link to post
Share on other sites

Well it’s looking promising, I’m just sitting in the dealers waiting for them to finish the update.

They said they checked & it will fix the issue with the new EWS 4.3 loosing sync with the old DME, fingers crossed!

I’ll check the part number I get to see what version the DME is running when they give it back. 

Share this post


Link to post
Share on other sites

They charged £90 +VAT for an hour programming, that is all the invoices says, however nothing on those two screen shots from INPA I posted above has changed at all, the part number is still exactly the same one! 

 

So I don’t know if they did something to the EWS instead, they certainly  had it in the workshop for 2.5 hours for the airbag recall & the update. They had said the airbag work would take about an hour. 

 

I don't like going to big garages like that, I’d rather talk to the one specialist who owns & runs the business who did the work him self. I did ask a couple of times what it was exactly they had done but you only get a third hand account from a nice lady at the main desk. She just said they had done the update that would fix it, but we could bring it back if there it happened again.   

 

Just have to keep the laptop with the car for quite a while yet to be safe. 

 

Hopefully I can report back in a few months that it’s been fine since....

Share this post


Link to post
Share on other sites
20 minutes ago, Clavurion said:

So when you check INPA Identification screen the part nr., software nr., or date of manufacture has not changed from the original?

 

Nope! The only thing different (as far as I can see) is today’s date on the PC time. 

 

dFnY2uu.jpg

 

uwqwa6A.jpg

 

Edit: actually there is one difference - they did clear the only fault code stored, the one about EWS anti tamper, it should have had a few counts next to it! 

Edited by Andyrt200
Shown

Share this post


Link to post
Share on other sites

Actually checking things again that 7518111 is hardware number and hardware manufacturing date which won't change.

 

Check F3 Code and it will show you the actual 7 digit software number and as a manufacturing date the updated date.

 

And here is the list of software numbers for 530iA touring. 

 

https://www.realoem.com/bmw/enUS/part?id=DS62-EUR-04-2001-E39-BMW-530i&mg=12&sg=10&diagId=12_2295&q=12147545544

Share this post


Link to post
Share on other sites
39 minutes ago, Clavurion said:

Check F3 Code and it will show you the actual 7 digit software number and as a manufacturing date the updated date.

 

Ah yes thanks:

ljnmxq1.jpg

 

My memory is rubbish! After you told me that, it seems familiar so I had a dig through the PC & found I saved a screenshot of that screen last year when looking into doing an update my self:

z1hFQa3.jpg

 

Unfortunately it seems there is nothing different again :(

 

Share this post


Link to post
Share on other sites
15 hours ago, Clavurion said:

Take it back to the dealer. Your DME software has not been updated. 

 

The newest assembly number should be 7545544 and newest software number 7545545.

 

Thanks, it would seem the DME hasn’t actually been updated. 

I rang them this morning, the service manager said the chap who did the work isn’t in today but checked the job card & it had EWS update on it. She said I was welcome to ring back Monday to find out exactly what they did. 

 

I was only guessing a DME update was needed to fix the problem from reading another forum. I’ll be glad if it turns out I was wrong! 

 

I checked back & unfortunately I didn’t save any screen shots of the EWS information before. I’ll post up what it has now once I’ve confirmed what they did. 

Share this post


Link to post
Share on other sites

EWS module can't be flashed, only coded (parameter value changes). There are only a few coding parameters on EWS which have to be correct in the first place for it to work at all.

.

Edited by Clavurion

Share this post


Link to post
Share on other sites
On 08/06/2019 at 16:06, Clavurion said:

EWS module can't be flashed, only coded (parameter value changes). There are only a few coding parameters on EWS which have to be correct in the first place for it to work at all.

.

 

Yes it’s odd that they should have to do anything to the EWS at all really. It comes specially set up (coded?) for only your car & your keys. You’d have thought everything should have been set right in the first place. It’s certainly why I thought it needed a DME update. 

 

It makes sense that the old DME may need an update to run with the new EWS, not the other way round!

 

Unfortunately the lady on the desk during the week is very new & doesn’t know much, the lady at the weekend was much better.

 

She did go back to check again for me today but could only say the units had definitely been updated to fix my problem & she gave me her “upmost assurance the issue had been addressed”, but couldn’t give any more details than that. She said I would need to bring the car back in if I wanted them to check again. 

 

I get the impression from the difference things they have been saying that they just plugged it in, let it run the full update routine & their computer told them it was fixed with out them really having any clue what it had done! 

 

It’s a good hours drive each way, I lost the whole day after waiting about for them to do it first time, it’s not ideal but I’ll just wait to see if it goes wrong again for now....

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×