Jump to content
Sign in to follow this  
amazighman

530i CCV leaking

Recommended Posts

Hi guys.

 

I have been looking around the engine bay and spotted that the bottom ccv hose to the dipstick is wet and oil seems to be coming under the insulation material. This hose has been replaced few months ago and checked today it is not cracked and is plugged in firmly in place.

Other hoses seem to have a misting of oil around them too, this CCV is Meyle and has been  fitted couple of years ago.

 

My car runs a bit sluggish under 1200 rpm when warmed up, i presume some sort of vaccum leak related to the CCV as all other vaccum leaks have been dealt with.

 

Could it be the CCV valve has failed? I couldn't feel any excessive vaccum at the oil cap.

Car isn't smoking however i had a low oil warning and topped up around 1/2 litre of oil.

 

I know C3bmw do a kit for circa 80 quid but is there any cheaper source?

 

Cheers

Edited by amazighman

Share this post


Link to post
Share on other sites

Stick with the Meyle kit from C3BMW; it works and works well (could be your last one was fitted properly and ham fistedly)

 

Personally, I wouldn't use a cheap eBay special kit for this; least with Meyle you get their warranty

 

It doesn't sound like to me that it's failed though; can you see any cracks or splits at all?

Share this post


Link to post
Share on other sites
2 hours ago, d_a_n1979 said:

Stick with the Meyle kit from C3BMW; it works and works well (could be your last one was fitted properly and ham fistedly)

 

Personally, I wouldn't use a cheap eBay special kit for this; least with Meyle you get their warranty

 

It doesn't sound like to me that it's failed though; can you see any cracks or splits at all?

I couldn't see any obvious damage however access is very limited and visual inspection is quite hard.

 

All i know is the bottom hose had split in the tipical place where the plastic head joins the rubber , so i had that one replaced, i made sure  it clicked in and seated properly.

 

However its still leaking oil between the black mesh insulation and the rubber hose itself, i dont know if the CCV was badly fitted , could be it is cracked or one of the hoses is damaged .

 

Is it normal to have these oily residues around CCV hoses? All i can think is that if oil can get out means air can get in causing a vaccum leak,.maybe worse when engine is warm as plastic gets softer.

Share this post


Link to post
Share on other sites

If the dipstick is blocked then the oil draining from the CCV will back up and likely leak.

 

I'd remove the dipstick and check it's completely clear (its double skinned)

Share this post


Link to post
Share on other sites
3 hours ago, pt530i said:

If the dipstick is blocked then the oil draining from the CCV will back up and likely leak.

 

I'd remove the dipstick and check it's completely clear (its double skinned)

I removed the top hose from the rocker cover and oh boy its full of mayo... I guess the CCV is clogged up.

I will have to remove the dipstick tube before fitting the new CCV and will make sure it is clear although l checked it few month ago by attaching a tube where the CCV drain hose goes and blowing through i could hear the sump gurgling....

Edited by amazighman

Share this post


Link to post
Share on other sites

Get the CCV replaced in one lot pal; as said before, the Meyle kit from C3BMW is spot on. I'd also take the inlet mani off (get those gaskets btoo); it gives you a lot more room to play with and you can ensure that everything is fitted properly/securely and also give it a good once over whilst you're in there too :) 

Share this post


Link to post
Share on other sites
39 minutes ago, d_a_n1979 said:

Get the CCV replaced in one lot pal; as said before, the Meyle kit from C3BMW is spot on. I'd also take the inlet mani off (get those gaskets btoo); it gives you a lot more room to play with and you can ensure that everything is fitted properly/securely and also give it a good once over whilst you're in there too :) 

Parts on order and will renew the lots.

Just been checking the service history and this CCV ( Meyle) has been on the car for about 2 years and it is failing , another meyle was fitted before that one and failed in same amount of time.

The car is mainly driven to work  17 miles away via motorway so has enough time to warm up and prevent mayo buildup...

Share this post


Link to post
Share on other sites

The issue could be that they say it was Meyle, but it wasn't, it wasn't fitted properly/carefully or sods law...

 

Fingers crossed you get it sorted this time around :) 

Share this post


Link to post
Share on other sites
16 hours ago, d_a_n1979 said:

The issue could be that they say it was Meyle, but it wasn't, it wasn't fitted properly/carefully or sods law...

 

Fingers crossed you get it sorted this time around :) 

Its more likely badly fitted as the previous owner was using the same garage for many years...

 

I cant expect much from a garage that replaced the rocker cover gasket and lost one of the bolts so  replaced it with a normal bolt and washer no grommet= vaccum leak

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.