Jump to content
RichardP

Firmware 6.02-7155 - Fix for GPS Epoch limit on 6th April 2019

Recommended Posts

The attached firmware is the latest as of 22 April 2019 and fixes the GPS Epoch limitation in the BMW Nav computer.

 

This fix will allow the Intravee to set the correct date even though the BMW Nav computer does not correct for the current GPS Epoch (1024 week time periods).  The fix should work until 03:14:07 UTC on 19 January 2038 when the time_t variable used to hold the number of seconds elapsed since 1 Jan 1970 will wrap round causing all sorts of time based mayhem - year 2K will have nothing on this!

 

 

fw-app-256 - extras V6.02-7155.zip

Share this post


Link to post
Share on other sites
2 hours ago, RichardP said:

The attached firmware is the latest as of 22 April 2019 and fixes the GPS Epoch limitation in the BMW Nav computer.

 

This fix will allow the Intravee to set the correct date even though the BMW Nav computer does not correct for the current GPS Epoch (1024 week time periods).  The fix should work until 03:14:07 UTC on 19 January 2038 when the time_t variable used to hold the number of seconds elapsed since 1 Jan 1970 will wrap round causing all sorts of time based mayhem - year 2K will have nothing on this!

 

 

fw-app-256 - extras V6.02-7155.zip

Thanks a lot!!!

Share this post


Link to post
Share on other sites

Brilliant, thanks Richard. Now I need to borrow a windows laptop so I can update mine! 

Share this post


Link to post
Share on other sites

If anyone really can’t update their Intravee due to lack of a Windows laptop, USB serial cable or general lack of computer skills, I will always offer an update service. Just send the Intravee to me with a pre paid self addressed envelope. For overseas users, you can PayPal me the cost of return postage. PM me if interested.

Share this post


Link to post
Share on other sites

I noticed my Intravee II was no longer giving me the correct time/date and so learned about the Week Number Roll Over issue that happened recently.  With the sad news about Simon I had not looked into updating for many years... but thought I'd try a search just to see if there was a fix.  WOW!!!  I am so thankful and heartened to see his project still alive and extended with so many new (to me) "extras".  I dug up my old USB to Serial adapter, found the drivers online (took a while!) and had my Intravee renewed and better than ever in less than an hour!

 

RichardP, thank you very much for keeping up with this... you are truly amazing!!!

Share this post


Link to post
Share on other sites
17 hours ago, RichardP said:

If anyone really can’t update their Intravee due to lack of a Windows laptop, USB serial cable or general lack of computer skills, I will always offer an update service. Just send the Intravee to me with a pre paid self addressed envelope. For overseas users, you can PayPal me the cost of return postage. PM me if interested.

PM sent.

Share this post


Link to post
Share on other sites

I just updated mine. I had very old firmware so the added features are awesome. Thank you!

But I noticed that if I’m looking at vehicle status after a few seconds it goes back to nav screen. Didn’t do that before. Is there a setting I need to adjust?

 

Share this post


Link to post
Share on other sites

The most likely cause is not using the ‘rectangles’ button to switch to audio screen priority. It’s easy to forget to do this as it’s not very intuitive.

 

 

Share this post


Link to post
Share on other sites

The button that looks like two overlapping rectangles, it's actually a head unit over a rectangle, it's position varies depending on your monitor type.  See the user guide Page 45 for it's location.  If you don't know what it is, it's the problem!

 

image.png.6dee4aa0a55593b3e6c2379648942c5e.png

Share this post


Link to post
Share on other sites

Thank you very much Richard to take care on this great project.

 

I'm running the Intravee with switch since a year or so and I'm very satisfied every single day entering my car.

 

Maybe I've overread this in the manuals and on the web so just a short question:

Will the settings remain during firmware update or do I have to configure the Intravee from scratch afterwards?

 

Share this post


Link to post
Share on other sites

Worked like a charm, thanks :D

 

Just encountered that the ivee really needs to be in its working environment, meaning connected in the trunk. Just providing power supply on my desk leads to non-recognition due to the lack of ibus.

 

image.thumb.png.5a90203ccc4819ff59f53a7477cea91d.png

 

image.thumb.png.36481edbaee1f34a8ff0c9746c67202c.png

Share this post


Link to post
Share on other sites

Yes, you need an iBus connection to wake up the Intravee.  After being disconnected for a while, connecting to 12V will usually wake it up for 1 minute which might be enough time to start uploading the firmware if you're quick.  When the upload starts the sleep timer is disabled so it won't shutdown on you half way through the update.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×