Jump to content
Bumbaclut

E34 Alpina B10 Bi turbo touring project

Recommended Posts

20210122_163821.jpg?width=1920&height=10


Drove her to BMR today, 51 miles no sweat.  I'll be honest i was shitting it leading up to this drive with what ifs.   I'm a bit silly with no breakdown cover either but i avoided the M3 "smart" motorway as if i did breakdown i didn't fancy dying and my car being written off on one of our new safer hard shoulder free motorways.  I needn't of worried it behaved perfectly and sat on the motorway with ease.  So first test passed with flying colours, well chuffed as it was a heap of parts 18 months ago

 

So at Barrys for an MOT and to sort the EML wiring which is the fly by wire throttle so it boosts fully, being main jobs.  I could feel it wants to really fly but the throttle butterfly only opens about a 3rd.   I'm not keen on the short shift gear lever (E60 545i) its got fitted so that may have to go and buy a standard throw lever.  

 

 

I've forgotten the looong gearing aswell. 70mph in 5th? 1500rpm sir 

Share this post


Link to post
Share on other sites

Just read through this, amazing job & great idea to make the touring. Looks like you’re the perfect man having own one before, make a huge difference knowing where things should go! 

Share this post


Link to post
Share on other sites

its at the bodyshop have the sills repaired welded, should be back from there soon and is ready MOT then,  BMR have sorted a few electrical issues.   I can't wait!

Share this post


Link to post
Share on other sites

IMG-20210212-WA0053.jpg?width=1920&heigh

 

Yes i picked her up yesterday its all taxed and MOT'd road legal!   It sat for a week or two as they were so swamped with other work


So it ended up going to their bodyshop to sort the sills out


IMG-20210210-WA0104.jpg?width=1920&heigh
IMG-20210210-WA0103.jpg?width=1920&heigh

IMG-20210208-WA0106.jpg?width=590&height
IMG-20210208-WA0105.jpg?width=590&height
IMG-20210208-WA0104.jpg?width=590&height


These were the two front repairs needed on the sills

 

 

 

IMG-20210208-WA0100.jpg?width=1920&heigh
IMG-20210208-WA0099.jpg?width=1920&heigh

Also some repairs on the rear of sills

 

 

IMG-20210210-WA0102.jpg?width=1920&heigh
IMG-20210210-WA0100.jpg?width=1920&heigh

 

And re stone chipped the paint.  So at least now thats all the grot removed, as although the bodywork is tatty its not a rusty pig the shell

 

 


IMG-20210211-WA0005.jpg?width=1920&heigh

 

This Marks a nice chap, he got the engine running a year ago, so he was back on it this time.    They've fixed the EML light not coming on so that has allowed full boost! this was some wiring into the cluster that need completing. The wiring was there.  Also ABS light was on permanently, i think this was an incorrect relay.  

OBC is still dead, this is suspected the unit is faulty. I've got some spares in english from American cars but they are different.   Reverse lights is some wiring in the tailgate suspected as only 4volts there but its not needed for MOT believe it or not.

they've also wired in the ASC traction plug.  The loom was there as part of the EML system So added the plug loom into it and this is working but not.    ABS is working correctly and so is ASC when engine fires up. You can press switch and turn it off. once driving however over say 10mph the ASC light comes on and wont go off. ABS still works correctly.  So basically i've run out of money as the welding spiralled and nothing every goes perfect!  So will have to save and send back.  Theres a hunch its my clocks which are a mismatch that needs sorting.   

Cruise control is working, that was just a missing clutch switch,   I'd never ran a spec check on the base car but Barry ran it through and it was a very well optioned 525i touring!

Avus blue - special order as was an M5/3 colour only
manual
LSD
heated sport leather
air con
twin sunroofs
OBC
cruise control

A fine e34 in its own right

 

 

IMG-20210212-WA0063.jpg?width=1920&heigh


I took it for a spin when i arrived yesterday and its an fucking animal! No lie, fastest car i've ever owned.  A slight tickle on 2nd on the way out had the back swinging no sweat, i caught the slide fine but wasn't quite expecting that!  It must be the lightly tweeked turbos as it gets to full boost at about 1800rpm and they come in quite hard.  The standard bi turbos are more linear and come in about 3500RPM.  I've not driven a standard one to compare but Barry has and mine feels alot stronger.  Its cold and the tyres are new but old if you get me but when the boost comes in snakes in 2nd 3rd no problem.   Its going to be fun learning to drive the hot rod as it needs a bit of respect!

When the rolling roads open i'll have to visit Charlie and get it on there see how the fueling is. In the meantime try and not thrash it everywhere and damage it.   I just need to save some more money to keep going through it. I think this will be the biggest turning point in this project.  Very chuffed and thanks to all those that have helped along the way so far 

Share this post


Link to post
Share on other sites

Such a great project this - seems like its so nearly there too, once its all sorted mechanically i assume paint is on the cards?

 

 

Share this post


Link to post
Share on other sites

i'm not 100% sure i want it like that. I've got an E30 like that and then you feel you can't use it.  We'll see i'd rather drive it and park in tescos and no worry 

 

Its ok from 10 foot

Share this post


Link to post
Share on other sites

Simon so pleased to see this on the road, it's a long while since I saw it at your old mansion. Minor correction, Avus was of course used on late model limited edition 525i sports in the UK. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×