Jump to content

Intravee Switch Source Selection Issues

Recommended Posts

As shown in the attached diagram I've been using an Intravee II on my car for several years now and it's been a really solid device.

I recently purchased an Intravee Switch to allow me to add an AUX input to the system.

So new to the system are the Switch, a new AI Net cable and the Aux input cable (Shown in green on the diagram)

However I'm having problems getting it to select the different inputs.

Sometimes it doesn't seem to find any sources, and other times it can find all sources and I can switch to a different Net input, but Src:Aux is not showing up on the MID when I select the Aux input although I can hear it playing fine.

However sometimes it won't let me switch back to the iPod, and pressing select on the MID for input Net 1 does nothing.

I'm running the latest firmware (fw-app-256 - extras V6.02-7508.blf) and have flashed it again with the Switch connected.

It also works fine when I remove the switch from the system.

What could be wrong here?


E39 Intravee Setup.png

Intravee V2 Log.txt

Edited by Eddy555

Share this post

Link to post
Share on other sites

Two questions :


1) Which ports have you connected to what on the switch?


2) The Intravee switch has configurable port types, the default is 2 AI-Net and 1 Aux, the Aux is Port 3. If you go to the About screen for the Switch, what does it say? 

Share this post

Link to post
Share on other sites

Hi Richard,


Thanks for the reply

1) I had the KCA-420i into port 1 and the Aux into port 2. I've switched the Aux to port 3 and the result is the same, I can hear audio but it's not showing it as an Aux and I can't reliably switch between inputs.

2) I can't seem to access the About for the Switch. Looking at the manual this only seems available on the UI mode 5 and 6, and as I'm running a MID I'm running UI mode 4 that doesn't seem to have that option. About just cycles through information related to the IV2.


I've just gone to the car to get this info and it wasn't finding any sources and there was a feint clicking coming through the speakers, about every second or so.

I unplugged the output on the switch and plugged it back in and the iPod worked, I could switch the the Aux on Net 3 (although it was showing Src:...) and could hear sound.

I managed to switch to Net 1 again and play the iPod and then switched back to Net 3/Aux but now I can't select Net 1/iPod. Nothing happens.

It's all a bit strange.

Share this post

Link to post
Share on other sites

Today it appears to be working. I got in the car, changed to Net 1 and the iPod was found fine. Then this evening it could switch between either inputs several times with no issue (Although I wasn't playing anything on the Aux input).

One thing I can think of is that if I play the Aux for over a minute and maybe the iPod powers down maybe it can't seem to find it again until I power up the car after rest. Just a theory but I'll try this out when I get chance.

Share this post

Link to post
Share on other sites

Tried running with Aux on the trip to work this morning, it plays the audio fine, but eventually shows No Source. After the 20 minute trip I can still switch back to the iPod. Maybe it's OK now. But it would be nice to have it show the source is Aux though. Is there a way of doing that? 

In the log file attached to my first post it seems to suggest there is no Aux input setup on the switch

SWFW: OP MODE 1 - 3 Net, 0 Aux
SWFW: AUX MODE 1 - Normal

Share this post

Link to post
Share on other sites

Using an Aux cable on the switch configured with 3 AI-Net is definitely not ideal, although I'd not expect quite the problems you're having.


Using a single line UI you'll have to use the commend line to configure the switch.  If you type the command 




it will decrease the number of AI-Net ports and increase the number of Aux ports, so running the command once with change from 3 Net, 0 Aux to 2 Net, 1 Aux.


If you run it twice by mistake, you can use the command




to do the opposite.


AI-Net ports are always the first ports, Aux the last, so in 2 Net, 1 Aux mode, ports 1 and 2 are AI-Net, port 3 is Aux.  In 1 Net, 2 Aux mode, port 1 is AI-Net, ports 2 and 3 are Aux.

Share this post

Link to post
Share on other sites

Finally got the chance to hook up to IV2 and change the setting. Works spot on now thanks, shows Aux 0 instead of Net 3 and display makes more sense on the MID,

I may have a slight connection issue with one of the Ai-Net cables which maybe causing some of my problems, but it seems to be working fine now I've reseated the connected into the IV2. Thanks again.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

By using this site, you agree to our Terms of Use.