Jump to content
JDX-90

Buzzing noise from Air Con?

Recommended Posts

Hi guys,

 

I've had the car (520d M Sport) for about 6 months now and the other day noticed a loud buzzing noise coming from the air vents.... It's very intermittent and whenever I stop to investigate the noise goes away.

 

I managed to get a video this morning and when the noise was happening opened the bonnet to confirm there's no noise coming from there.

 

It seems to only do it when the music us on, then if I mute the music the noise goes away.... Very strange.

 

I've attached a link to the video as well.

 

th_1D904D45-1607-4893-BA63-28B25D456CA3.

 

Has anyone had this issue before or can anyone offer any suggestions?

 

Thanks in advance

Joe

Edited by JDX-90

Share this post


Link to post
Share on other sites

try messing with the climate control vent (face/feet) to see if it's the vent motors. 

Share this post


Link to post
Share on other sites
53 minutes ago, sanjx said:

try messing with the climate control vent (face/feet) to see if it's the vent motors. 

 

I tried that with different direction, speed and temperature but makes no difference to the noise. Also if I close the air vents the noise doesn't change either.

 

I'm beginning to think it might be coming from the media system :/

 

If I mute the music and drive for 30 mins with air con on I don't hear the noise, then if I turn the music on after about 5 mins the noise appears. Then if I mute the music to listen to it, the noise goes away after 20 seconds or so.

 

Very strange

Share this post


Link to post
Share on other sites
10 hours ago, 535iAR said:

I would say it is interference on your sound system.  Almost as if the fan motor isn't suppressed and is upsetting the sound system.

 

That's an interesting idea, any ideas how to stop it? Or is it a case of booking into the dealer for investigation?

 

Does the manufacturer warranty cover this sort of thing?

Share this post


Link to post
Share on other sites
44 minutes ago, 535iAR said:

No idea how to fix and I would try BMW for a fix under warranty, just don't take it to a branch of Douglas Park seeing as how you are Glasgow.

 

Douglas park is the nearest one to me, do you not rate them?

Share this post


Link to post
Share on other sites

That's not so good!

 

I work 5 mins from the Douglas Park in Pinkston and the only other one is Harry Fairbairn which is too far away. I've heard mixed reviews about Douglas Park sound good and some bad.

 

Location doesn't offer much of an option for me so will see how I get on.

 

I called them this morning to ask their opinion on the issue and they said the entertainment system has it's own cooling fan and it could be that making the noise. They've said I can bring it in on Monday morning for an engineer to have a listen and look at my video and then can advise if it needs booked in.

Share this post


Link to post
Share on other sites
2 hours ago, 535iAR said:

My Mrs worked for a privately owned VW dealer up until 6m ago, in the 10 years she worked there they had cars stolen (always with keys left about) around 6-7 times, shoddy, yes very even to the point the insurance refused to pay out a couple of times on the latter ones as the garage had not showed due diligence so the garage stood the bill. I reckon it's a relatively common thing and easy to find a set of keys lying around in a busy service dept. even though they should go straight in the safe. I've also collected my cars previously from Peugeot and Vauxhall and only offered a name and reg to be handed the keys.

Share this post


Link to post
Share on other sites

Had the car in to Douglas Park yesterday morning and an engineer came out for a quick drive so I could demonstrate the issue. Luckily the noise came back while we were out which is always a good thing and the guy took it into the workshop for a quick look.

 

He came back and said the panel behind the nav / centre console has it's own cooling fan and it could be that so they need the car booked in for 2 days to take apart the centre console and investigate, then to order and fit any required parts etc.

 

They'll give me a courtesy car with no charge for the duration as well which is good. Booked in for Monday 27th.

Share this post


Link to post
Share on other sites

Update:

 

I had a day off yesterday so decided to do a bit of investigating work of my own.

 

The noise has been getting worse so I took assist the front panel to the centre console to try to see where the noise was coming from.

 

th_E6315537-BCA4-483D-9BC2-3E96FE3FBC0D.

 

It's definitely coming from the CD unit, possibly the inbuilt fan?

 

Anyone had any issues with this?

Share this post


Link to post
Share on other sites
9 hours ago, sshooie said:

If it was mine and out of warranty i would look to strip it down and clean the fan, worse case is if it's no better you change the fan.

It did cross my mind while I had some time but as it's under warranty I thought I'd better not tamper with it. Don't want to end up invalidating the warranty or giving them something to blame me with.

Share this post


Link to post
Share on other sites

Just an update on the issue...

 

The car went in on Monday morning and picked it up today - they replaced the entire head unit free of charge and gave it the first service under the service pack while it was in.

 

Also had a courtesy car for the 3 days free of charge.

 

Quite impressed with the service and happy not to have to spend a penny :D

Share this post


Link to post
Share on other sites

I’ve got a similar issue with f10 bmw 

the stereo CD player fan is making a noise constantly. The only way to stop the noise is to disconnect the battery. 
 

this only started happening after scanning the car for fault codes, while running the checks on a full system scan, not sure if it was just a coincidence 

 

 

Share this post


Link to post
Share on other sites
28 minutes ago, bmwf113.0d said:

I'd remove it and vaccuum the dust and fluff from the fan. 

Yes will do that tmr 

thanks 

 

so now after locking the car and leaving it for few mins it the fan turns off, start car and no noise for about 2-3 mins then the fan comes on and stays on 

Edited by aa86

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×