Jump to content

Search the Community

Showing results for tags 'm50tub25 engine removal'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Rules & FAQs
    • Rules & FAQ's
  • Sponsors
    • Chris Knott Insurance services
    • Cotswold BMW
    • MStyle
    • BMW Cables
  • General
    • Hello I'm New
    • General Discussion
    • DVLA and Insurance Queries
    • Picture & Video Gallery
    • Suppliers
    • Fun Stuff
    • Spotted
  • Meets & Events
    • BMW5 Meets & Events
    • Non BMW5 Trackdays
    • Other Meets & Events
  • Classifieds
    • Cars
    • Parts & Breakers
    • Wheels & Tyres
    • General Items
    • Wanted
    • eBay & Autotrader Adverts
  • Technical
    • E12 1972-1981
    • E28 1982-1988
    • E34 1988-1996
    • E39 1996-2004
    • E60/E61 2004-2010
    • F07/F10/F11 2010-2017
    • G30/G31 2017-
    • ///M Powered
    • ALPINA 5ers
    • Audio & Navigation
    • Intravee
    • Diagnostics
    • Coding
    • Detailing
    • Projects
    • Track Talk
  • Other BMW Technical
    • 1 Series
    • 2 Series
    • 3 Series
    • 4 Series
    • 6 Series
    • 7 Series
    • 8 Series
    • i Series
    • X Series
    • Z Series
    • Other BMW Tech Talk
  • Other Technical
    • Other Marques
    • Computer General Help

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Occupation


Garage

Found 1 result

  1. MikeTheSmith

    Mike's 525ix Touring

    So I am now the 10th owner of JohnWs ix touring. So far so good, it's got a lot of miles under its belt, but has been given lots of love so wears them well. It's lpg converted and is currently returning about 25mpg on gas which equates to a little over 50mpg which is way better than my petrol 525iat. It's got an odd problem which seems to just be on startup when using petrol that sometimes it is really lacking power, but when the gas ones on the power kicks in. John kindly supplied a blue temp sensor so I'll change that in. I've also purchased a trans filter for an oil change and some filters: oil, cabin and air. So far just fitted the air filter as it's an easy win. Other problems are: 3rd brake light (factory fitted option) does not work - is this an mot fail? Door tweeters exist but seem to do nothing- do I need to make a crossover and splice them in behind the kick panels? Instrument cluster odo reset not working, lights out and dodgy fuel gauge - Geoff may have kindly sourced me a replacement cluster Rusty hole it the roof at the rear where a previous aerial was - I'll pro get a dab aerial and fit it as in my old touring. Rust creeping in a door bottom and arches. Seems a little low on power when trying to accelerate up hills, it may just be the extra weight of the transmission it's lugging. Other than these items it's great! It's had a decent re spray, electric seats fitted, auto dip mirror, map lights front and rear. The 4wd certainly gives massive confidence in the corners and gives eager handling along with the rack and pinion steering. For the engine oil change opine oils and other sites seem to recommend 10w40 semi, from the records it looks like it's had 15w40 and on here people suggest 5w30??? Given that it's a 190k engine should I stick to the 10w40 "dino juice" ? I'll get some pics up soon
×