Jump to content

Search the Community

Showing results for tags 'low boost'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Rules & FAQs
    • Rules & FAQ's
  • Sponsors
    • Cotswold BMW
    • Chris Knott Insurance services
    • MStyle
    • BMW Cables
  • General
    • Hello I'm New
    • General Discussion
    • Picture & Video Gallery
    • Suppliers
    • Fun Stuff
    • Spotted
  • Meets & Events
    • BMW5 Meets & Events
    • Non BMW5 Trackdays
    • Other Meets & Events
  • Classifieds
    • Cars
    • Parts & Breakers
    • Wheels & Tyres
    • General Items
    • Wanted
    • eBay & Autotrader Adverts
  • Technical
    • E12 1972-1981
    • E28 1982-1988
    • E34 1988-1996
    • E39 1996-2004
    • E60/E61 2004-2010
    • F07/F10/F11 2010-2017
    • G30/G31 2017-
    • ///M Powered
    • ALPINA 5ers
    • Audio & Navigation
    • Intravee
    • Coding
    • Detailing
    • Projects
    • Track Talk
  • Other BMW Technical
    • 1 Series
    • 2 Series
    • 3 Series
    • 4 Series
    • 6 Series
    • 7 Series
    • 8 Series
    • i Series
    • X Series
    • Z Series
    • Other BMW Tech Talk
  • Other Technical
    • Non BMW
    • Computer General Help
    • Gaming Chat & Help

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Skype


Location


Interests


Occupation


Garage

Found 1 result

  1. Amsingh187

    535D turbo issues

    Hi guys, Took my e61 535d to two independent specialists and had two different solutions presented. First one connected a diagnostic and a whole load of faults popped up with regards to DPF/ glow plugs/ air mass/ charge pressure/ exhaust pressure. He then, Took off the engine cover and checked the vac pipes and said they looked bad and that he couldn't see the two rods from the bottom of the turbos moving when revving the engine. Told me to have the pipes replaced first before going down any other route. I do have a 4 star warranty but this will not cover such components like pipes and plugs. Nice chap, didn't charge me a penny for his time and gave me the option of contacting him if Iwanted to go ahead. £140 labour plus the pipes which I said I can get at trade price too. Second garage, looked at the pictures I hadtaken of the diagnostic and said that the plugs replacement and pipes etc would cost me £560 and can get me in next week. Now, I know it may seem that the second garage is trying to take advantage of me but what could the issues be? Obviously I would like to keep as much money in my own pocket. If the vac pipes aren't doing their job then replacing those first would be the most efficient option before going through the warranty company which would want to wriggle out of paying anything?? Anyone else had similar problems or knows which garage to trust? Any help would be appreciated and please forgive me for my naivety. Thanks. Ams. 
×