Jump to content

Cairn

Members
  • Content count

    12
  • Joined

  • Last visited

  • Feedback

    N/A

About Cairn

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Cairn

    Glow plugs

    Hi I’m looking for any help at all , I’m having a slight charging problem with my e60. For the fisrt 10 mins the car runs rough and doesn’t charge , some smoke comes from exhaust whilst it’s doing this but after 10 minutes it clears n runs smooth and charges as it should .I’ve narrowed it down to glow plug cylinder 1 but they are new plugs not long changed it’s been like this since they were change when I was changing them the connector doesn’t clip on like the rest it just sits on to the plug I’m wondering if that would cause resistance and the glow plug isn’t heating up correctly for that time which in turn send the voltage form alternator to there and car won’t charge because of this connection , is there a sensor in the clip that would not allow it to b hard wired into the glow plug and need to buy a new connecor and repair it or can it b done by bypassing it , I thought if it still had contact with the plug it should b fine but it’s my first bmw and found that any small problem can cause 100 different problems
  2. Cairn

    Battery drain issue

    Sorted the earth problem the voltage now reads the same at jump point and battery but it still wouldn’t charge the alternator and battery are both new no ground issues and as far as I’m aware the ibs is good , going to register the battery tomorrow and see if it makes the battery charge , it doesn’t charge when ticking over but when accelerating the voltage goes up to 15.3 v but will still cut out after a short while , the car is booked in for 21st for recall but had people look at it and dnt see any issue
  3. Cairn

    Battery drain issue

    So took the car to my Mates dad he’s a mechanic for rolls Royce and he done test and is almost certain that there is a bad earth connection on the car causing high resistance that’s resulting in battery drain , does this sound about right ? He tried to jump the car from battery and didn’t work but from the jump points worked first time
  4. Cairn

    Battery drain issue

    Why would the alternator charge it at that bolted when the battery shows 100% it should drop back down to around 12.6
  5. Cairn

    Battery drain issue

    Also the glow plugs failed on Xmas and I replaced the 6 of them , 2 of them weren’t working , could the glow plug module b causing any of it ?
  6. Cairn

    Battery drain issue

    I’m getting my mate to register it tonight for me to see if it helps but it should b that when the battery is full and charging it at 15.6 and the battery runs flat quickly because of the high voltage going into the battery , the battery was tested and it’s perfect got to b the regulator or the un registered battery or combination of both
  7. Cairn

    Battery drain issue

    Not yet mechanic yesterday said it shouldn’t matter it being a 07 plate
  8. Cairn

    Battery drain issue

    Will any d -can cable bowdlerised with ista plus from bimmergeeks
  9. Cairn

    Battery drain issue

    Ticking over it was 15.6v ,I’ve disconnected the ibs and it never changed anything. Trying to find out how to get ista to diagnose it myself save paying fortunes at garages each time something goes on it. Anyone any idea best play to get it from ?
  10. Cairn

    Battery drain issue

    This is the positive junction for the recall looks quite nasty to me , would that cause a power drain as well as power not reaching jump points ? IMG_0640.MOV IMG_0642.MOV
  11. Cairn

    Battery drain issue

    It’s not been in for the repair yet I had a look at the junctions and looks rusted might b the cause for no power getting to jump point but as for the over charging and not starting after a full charge would that b down to the voltage regulator on the alternator, it is a new one though
  12. Cairn

    Battery drain issue

    Hi I’m looking for any help at all , I’ve hit a brick wall with my e60 . I’m having battery drain issues even with a new alternator and battery it’s drain extremely quick my battery was on the charger till 100% popped it in the car and took it to get checked , the mechanic told me the battery was 100% and was charging perfect at 2000 revs at 3000 it was slightly over charging and was the same ticking over , jumped back in my car drove 5 minutes home turned it off and went to start again and wouldn’t start checked my battery and volts were at 11.06 , he said he tested it off jump terminals and showed battery was dead but directly from battery was showing 100% , what could cause such a battery drain issue?? And why is my jump points not showing same reading as battery , Any help would b appreciate thanks
×