Jump to content

siarach

Members
  • Content count

    10
  • Joined

  • Last visited

  • Feedback

    N/A

About siarach

  • Rank
    Newbie

Garage

  • Garage
    E34 520i
  1. siarach

    E34 Not Starting

    Thanks for this, will give it a go and see how I get on.
  2. siarach

    E34 Not Starting

    OK, this info has been good and this is what I have found. My ebox is fed from the battery underneath the rear seat, a wire is clipped in to trunking along the inside of the O/S sill, i tested the wire and I was getting 12V as it left the Batt connection but 12 inches along I was only getting 4V?? Stripped it back to find what looks to me like a fusible link? I have enclosed a pic. Does anybody know the name of this or what value it has or what can I replace it with? I have carried out a continuity test and its dead. I have resisted bypassing it just in case I cause any damage but if I did I would then get 12V to my ebox and am sure the car will start. And yes its a manual
  3. siarach

    E34 Not Starting

    Thanks this info is invaluable. Just carried out some checks and I have Batt Volts 12.8 at the B+ Term but at the Fuel p/p relay I am getting 4V?? Anybody have any ideas where I can be losing it?? This clearly is the root of my problem. in fact I am only getting 4V in the whole harness that stretches across from the B+ term to the ebox??
  4. siarach

    E34 Not Starting

    Cheers! At last something to go on, thank you so much. Will report with my findings.
  5. siarach

    E34 Not Starting

    Checked the Relays and all fine. Pic 125 what is this Term/Junction? What Voltage should I expect with the ign off/ign on? Pic 126 Green relay tested ok and I assume its the Fuel Pump Relay? Pic 127 White relay tested ok and I assume its the DME Relay? I am desperate! I have been at this now for a couple of weeks and haemorraging money with "experts" looking at it!! Any advice? Regards John
  6. siarach

    E34 520i

    Cheers & Thanks, thats what am counting on.
  7. siarach

    E34 Not Starting

    Duncan, Dislodging something seems to be possible but i dont know what? I had to take the ebox out and disconnet the ECU but it all went together with no hitch.
  8. siarach

    E34 520i

    Thanks Dan
  9. siarach

    E34 Not Starting

    Hi Folks, just joined your Forum and as you prob guess I need some help. I have a 1995 E34 520i that I have owned since 2001 and it has literally never let me down until now. I took it in to the shed to change out the wiper linkage which was a horrible job but never the less completed only to find that I cant get the car started! No Spark, No Fuel, various experts have been looking at it and I seem to be throwing money at various sensors etc to no avail. I have followed through the various test procedures and came up with very little aprt from a dropped voltage at the Fuel pump (6 Volts). Any advice on how to move fwd with this will be greatfully accepted. Regards John
  10. siarach

    E34 520i

    Hi Folks, just joined your Forum and as you prob guess I need some help. I have a 1995 E34 520i that I have owned since 2001 and it has literally never let me down until now. I took it in to the shed to change out the wiper linkage which was a horrible job but never the less completed only to find that I cant get the car started! No Spark, No Fuel, various experts have been looking at it and I seem to be throwing money at various sensors etc to no avail. I have followed through the various test procedures and came up with very little aprt from a dropped voltage at the Fuel pump (6 Volts). Any advice on how to move fwd with this will be greatfully accepted. Regards John
×