Jump to content

TrygveBMW

Members
  • Content count

    10
  • Joined

  • Last visited

  • Feedback

    N/A

Everything posted by TrygveBMW

  1. Hi all. i stuggle with rough idle only at start up when cold. no problems when the car gets some temperature. Cylinder / injector 5 and 6 shows off in the start. they are in red zone untill the car gets hot. ive tried change spark plugs. coil and injectors (used injectors. but ive changed twice and same values) No engine light. but INPA shows fault code on circulation water pump (dead) and Exhaust fault code 30E9 P2000 nox sensor Bank 1. Please give some input. I got INPA so i can record and upload video on Youtube. Cheers
  2. TrygveBMW

    Rough Idle when Cold 525i N53

    2.500£ Bill. Cant recall how The dianostic were done.
  3. TrygveBMW

    Rough Idle when Cold 525i N53

    If you pull all plugs after The car have been sitting a day or two. Maybe you can see a Wet plug or smell who is leaking.. Mechanic just pulled The head of ond inspected it. 240.000km. Engine..
  4. TrygveBMW

    Rough Idle when Cold 525i N53

    I had Idex 9. but inspected and no leak. My valves was in bad condition. That caused rough idle.
  5. TrygveBMW

    Rough Idle when Cold 525i N53

    Maybe leaking injector
  6. TrygveBMW

    Rough Idle when Cold 525i N53

    Hi. Sorry late replay. My valves was wear down and had to be changed. That caused uneven idle when Cold.
  7. TrygveBMW

    Rough Idle when Cold 525i N53

    Hello, Trygve, first about error regarding water-pump: 2E85. Unfortunately, this is a pretty common error and nothing can be done (except replacement). A few years ago I tried to open these pumps, without success (in undamaged condition)... There is a little bit more about this issue: https://bimmerprofs.com/electric-waterpump/ And now - please, check files in the attachment! As I see, some time ago all adaptations were cleared, right? Unfortunately, re-adaptation is not successfully finished. 1. flywheel is not adapted (minor problem); 2. thanks to problems with NOx sensor engine never performed Stratified charge and as the result - increased fuel consumption, no data regarding injectors, etc. NOx sensor is damaged, no doubts. NOx converter - 99.9999% too (taking into account high mileage on your car + driving with damaged NOx sensor). I don't recommend installing OEM NOx sensor, you will meet 30E9 error very soon (and - Stratified charge will be disabled again). In addition injector of 6th cylinder looks suspicious (leaking at idle), but 100% confirmation will be available only when Stratified charge will be re-enabled. At this moment I see only indirect symptoms: increased mechanical efficiency; incorrect fuel mixture for 4/5/6 cylinders, lowered offset type LTFT for the 2nd bank, disabled idle adjustment for a 2nd bank, etc. Problems with water-pump and NOx system need to be solved first. Then - re-adaptation of the engine and - additional attention to bank 2 and 6th cylinders data!
  8. TrygveBMW

    Rough Idle when Cold 525i N53

    Im in contact with Bimmer profs now for a online diagnostic. uploaded 70 screens
  9. TrygveBMW

    Rough Idle when Cold 525i N53

    Thanks! i will give this a try. it might be worth the time if i get a report ill upload it here!
  10. TrygveBMW

    Rough Idle when Cold 525i N53

    Hi! i just changed nr 5 and 6 on bank two. since they were on red. I might try to cut off each injector with inpa while running? the faulty injector will be the one disconnected were the idle is more or less the same and the rest will be worse when cut off? they are all index 9. so a default nox/ cat will not make the car run rough when cold? Cheers!
×