Jump to content

Cadwell Parker

Members
  • Content count

    881
  • Joined

  • Last visited

  • Days Won

    11
  • Feedback

    N/A

Everything posted by Cadwell Parker

  1. Cadwell Parker

    F10 Jacking on rear differential DIY

    Maybe but depends on how much quality you get for the £50. Also bear in mind if you want to lift the car on the front cross member rather than at each corner you'll need quite a long reach jack. The SGS one in the photo is just long enough to reach in and still allow you to pump the handle just enough to start lifting the car... I think I paid £140 for that one along with a pair of axle stands. The jack is very sturdy and easy to use and has paid for itself in money saved doing jobs at home.
  2. Cadwell Parker

    When TPMS sensors go bad...

    No, I'm sure it's specific to one wheel in particular. If I move the wheel to a different position on the car the the pressure difference follows it on the idrive. I'll be interested to hear how you get on with yours. Hope you get an easy answer.
  3. Cadwell Parker

    F10 Jacking on rear differential DIY

    Yes, but you can also use the centre plate just behind the diff where the cross-braces meet if that works better for you.
  4. Cadwell Parker

    Recommended Tyre brands / models for BMW

    I've had a very positive experience of Michelin Crossclimate+ tyres. Very comfy to drive on with a nice even pattern of wear across the width of tread and would have been good for 30k miles or more if I'd left them on the, as grippy as I needed them to be when engaging in more (ahem) enthusiastic driving and being an all season tyre very impressive in the winter months on icy roads. I got to try them on fresh snow one evening when they were still quite new and they were a revelation. I have separate sets of wheels for summer and winter. I'm tempted to put Cossclimates on my summer wheels but am probably going to have some PS4s fitted in the next couple of months just to see how they compare. I'll definitely be getting some new Crossclimates for the winter. I've been less impressed with the Goodyear Eagle Assymetric 5s I've been using this year. They have developed a wear pattern you'd expect to see on over inflated tyres. They're wearing more in the middle than at the edges. I've been very careful to keep an eye on the pressures so not sure what the problem is with them but I wont be buying more. As pointed out above avoid using just any old place that offers wheel alignment. Find a place with a decent reputation who you can trust to know what they're doing. Even the best equipment is next to useless in the wrong hands. If your rear camber is out of whack that could lead to excess wear on the inner edge. I've had mixed experience from Blackcircles, initially good but then had to have 2 tyres replaced which looked ok but wouldn't balance properly and another tyre which arrived visually deformed which could feasably have been attributed to damage in transit. To their credit they sorted the issues out quickly and easily but I've decided to use a guy I've found localish to my work next time. He has a full Hunter set up so I'll get the tyres fitted, road force balanced and the car fully aligned one day while I'm working. It won't be the lowest cost for the tyres but I'm happy to pay a bit more because it'll be very convenient, I won't have to spend ages scouring the internet comparing prices, I'll know the job will get done properly and any issues with the tyres will be for him to sort out.
  5. Cadwell Parker

    F10 LCi Sport / Comfort / Eco button function

    To add to @perchas reply, on my car it also changes the feel of the steering, making it feel a little heavier rather than giving you any more feel through the wheel. If you have variable dampers it also stiffens them up. There are 2 Sport modes, Sport and Sport+. There's an idrive menu option which lets you configure which functions Sport mode affects. Sport+ gives you the full works and turns off the traction control and stability aids.
  6. I've been having a bit of bother with the air suspension on my F11. It's complicated so be warned this could be a lengthly post. I think it started maybe a month ago. Soon after setting off from home I noticed a different feeling at the back of the car. There's an uneven piece of road I drive over 1/2 a mile from home anything over 30MPH loads up the suspension quite effectively and when passing over this it felt as though the suspension was compressing more than usual, possibly even touching the bump stops. By the time I'd got to the T-junction another 1/2 a mile along the road it had sorted itself out, feeling as normal and no visual sign of dropping. I made a mental note to keep an eye on things and see what developed. I had a similar feeling a few days later but again it didn't last long. Then as luck would have it I found I had a broken front spring so ordered a pair of Eibachs and carried on using the car gently to get to work and back. Once the springs arrived upon leaving the house on the way to leave the car at the garage to have them fitted I felt the same feeling over the uneven section of road but this time it didn't sort itself, getting steadily worse until the idrive lit up with the Chassis warning - Drive moderately etc. I was able to pull in to a lay-by not far down the road, switched off the engine and jumped out to have a look. The was sitting low down on the right rear corner, more so than the left but that might've been as much to do with the ground where I'd parked. I decided to restart he engine and continue driving moderately to the garage. Upon restarting the car lifted immediately and drove to the garage without further issue. I told the garage what had happened and asked them to have a look at the rear suspension while the car was with them. When I returned to collect the car it looked to be sitting lower at the back than usual. The garage agreed and said they'd found a bent height sensor bracket on the right rear corner and a fault code indicating the compressor had timed out after having to pump for too long trying to level the car. They suggested fitting a new bracket before going any further. It was only a fiver so I agreed. They had to order it from Germany so it took a week or so to arrive. They tried bending the old bracket back to roughly where it should have been before I left. The car responded by lifting slightly but was still a bit lower than usual and after leaving garage it sank lower. I continued to use the car carefully while waiting for the new bracket. The ride at the back felt different, not as firm, as though the rear suspension was not supporting the car quite as solidly as before and felt as though it had a greater tendency to squat down closer to the bump stops when going through certain dips in the road. Otherwise it wasn't too bad for a day or two but following a longish trip across country to collect a car for our daughter the ride was deteriorating quite badly. I'd been looking forward to the drive but in the end it was no fun at all. We got back too late in the day to investigate but the next morning I jacked up the back of the car at both sides in turn, removed the wheels and had a good look round for any signs of something amis. The ride had been so bad I was sure I had burst a shock absorber or something equally as drastic. I didn't find anything so just had to put the wheels back and head out to work. The car drove perfectly 45 miles each way, as though the lifting of each rear corner from the ground had reset something. I was looking forward to driving back to work the next day but 1/2 a mile from home the dropping and chassis warning were back. I'd already done a bit of searching online for clues to what might happening. I stopped and it was clear both sides had dropped. There's a lot of posts on our great forum here regarding rear suspension woes but I couldn't find anything which seemed to describe the symptoms I was getting. Widening my search I found an interesting thread here... https://www.bmwland.org.uk/index.php?threads/f11-air-suspension-sticky-thread.1477/ which seemed to describe a very similar problem to mine, as far as the dropping was concerned anyway. On the basis of this I decided to get the car to lift up then remove fuse 152 in the hope it would disable the Electronic Height Control, prevent the dropping and keep the car drivable until the cause could be narrowed down. I restarted the engine, listening under the back of the car I could hear the compressor running as the car lifted, and then a slight psshh as it cut off. I pulled the fuse straight out and I carried on driving. With the fuse out there was no dropping at all either when driving or parked up. I took height measurements at various times which varied slightly depending on where the car was parked but averaged out at roughly 590mm. That's about 30mm lower than it should be. It was fine for several days as long as I was careful to avoid loading the suspension too much, no dropping when driving or parked so I was reasonably satisfied there were no leaks from the air springs or lines. I ran the car like this for a few more days until the new height sensor bracket arrived. On the way to have it fitted I stopped and refitted fuse 152. The car immediately dropped again, this time right down to the stops. I had to mess about for 15 mins, switching off and back on again, opening and closing doors and checking fuses before the car lifted again and I could get to the garage. On removing the old bent bracket they found the joint between the end of the sensor and the bracket had seized and suggested that might be what had bent the flimsy Aluminium bracket. They fitted the new bracket, reconnected the sensor and checked for any fault codes. All good but the car would still not lift up to it's proper height. The garage thought the compressor might be failing internally and so not able to fill the air springs sufficiently to lift the car to its set height which might explain the compressor time-out fault code. They wanted to wait for an email with some details on what sort of pressure values the compressor should be achieving before they could investigate any further and I needed to get to work so I took the car, leaving fuse 152 in place to see if the new bracket would make any difference. It was still low but wasn't riding on the bump stops, there was still room for the suspension to move with the road surface and as long as I drove moderately it was ok. I made it to work and back and felt ok about doing the same the next day but during the course of my journeys the ride got progressively worse and driving back towards home it felt like the car was more or less on it's bump stops most of the way. This was late on Saturday afternoon. I called at the garage which is on my way home and caught them leaving for the day. Nothing they could do then so I just limped slowly home planning what to do about getting to work the next day. A plan formed. When I got home I jacked up the back of the car and pressed on the bellows on the air springs. They were soft, right side slightly softer than the left not totally empty but nowhere near as firm as they're supposed to be. I decided I'd try using ISTA to tell the compressor to run and see it I could get some air into the bags. That worked, after a fashion. The ' Inflate Air Bellows' command in ISTA runs the compressor for 40 seconds. The compressor started and ran as expected and both air springs were nice and firm so I let the car down off the jack expecting it to find the correct height, or at least attempt to find a height it thought was correct. It didn't, with the weight of the car back down fully on the wheels and engine running the back of the car was sitting up high looking like it'd been customised for off roading and making no attempt to adjust itself. Not ideal but at least I knew the compressor was making enough pressure to fill the air springs. I got the car back on the jack again and started ISTAs 'Bleed Air Bellows' procedure which worked as expected and both springs were completely empty. I started the Inflate procedure again but this time counted for 20 seconds then switched off the ignition. The compressor cut off. I pulled out fuse 152, lowered the car and was glad to see the car sitting at a more suitable height for driving, still a bit lower than it should be but a vast improvement. The car stayed up all night and I've driven to work and back today without further issue. For the time being I'm going to run the car with fuse 152 out and try to get round to some further diagnosis. So now I'm wondering where to go from here. It seems there are no leaks. The car only drops when fuse 152 is in place which suggests to me a problem with the EHC module or the discharge solenoid valve. If there are no fault codes associated with the EHC module the does that mean the problem must be with the discharge solenoid? But then why did the car not try to lower itself to the correct height after I inflated the bellows the first time? There might've been a fault code left from running with with the EHC fuse out. Would that be enough to prevent the system trying to level the car? Do I need to make sure all the codes are cleared before expecting the EHC to work properly? Have I actually got two simultaneous problems, the dropping and the low ride height with two different causes? Too much of a coincidence? The Eibachs fitted to the front are lower than the standard so would that have any effect on the rear? One question which crossed my mind was would the car automatically try to compensate at the back for the lower ride at the front? No, I don't think it works like that. My understanding is the rear ride height is programmed into the system and that should be what the car aims for independent of any changes the front. Well, apologies for such a long and rambling post. As you can see there's been quite a lot going on. If anyone's still reading after all that any thoughts would be welcome. Any pointers on where to look for further diagnosis before I just let the garage deal with it? Just to add the car is a 2014 LCI F11 with 111000 miles. Air springs are roughly 2 years old with 40000 miles on them. Any advice appreciated.
  7. Cadwell Parker

    F11 rear suspension, dropping and low ride height

    I've not had a lot of time for posting lately so apologies for not getting back sooner. The garage ended up fitting a new compressor and a new height sensor. They said the compressor was 'weak', presumably due to wear on the piston seal and the failed height sensor was the reason there was no signal appearing to reach the sensors from the EHC. I was disappointed they didn't try investigating further to see if they could fix the old compressor but as the new one came supplied with a new relay and solenoid valve for £339+VAT it's not too bad a price for peace of mind knowing the rear suspension should be trouble free for a good while now. I've kept the old compressor and will try to get round to taking it to bits and maybe replace the seal and dump valve if it looks like it needs one. If I can £150 for it on Ebay as a reconditioned item it'll soften the blow of the bill for this latest episode and hopefully shed some new light on what was the root cause of my issue. I'll update again here if I find out any more.
  8. Cadwell Parker

    DIY F11 air spring replacement

    I recently replaced one of the air springs on my F11. I'd already had one replaced a few months ago by an indy garage while the car was with them for some other work but after it started to drop occasionally at the opposite corner I decided to try changing it myself. Armed with the help and advice of @Munzy123 and @HandyAndy_UK among others the job was really quite easy and as long as you have a good jack and some stands available the only other equipment you'd need would be a largeish screwdriver and a 10mm open ended spanner. Oh, and a laptop with ISTA+ installed would be helpful as well. It's possible to manage without but you'll need to remove the rear underbody panels to allow access to the air suspension valve block and manually bleed the system from there. If you have access to ISTA+ there'll be less dismantling to do. Apologies for all the nerdy computer shots. I thought they might be helpful as I'd not been able to find much online showing how to use ISTA to empty/refill the sysyem. I had to buy a decent trolley jack and axle stands for the job but considering the indy garage were saying they'd need 2 hours to properly diagnose the car before making any repairs the jack and stands have almost paid for themselves already. I took a slight gamble just changing the spring without any diagnosis other than how the car was behaving.but as one spring had already been done and the car was showing 75000 miles it seemed like a reasonable bet. In the end it paid off and I'm glad to have invested in some quality equipment. To start with I connected a battery charger at the terminals under the bonnet. It wasn't the same power supply you'd find in a properly equipped workshop and only puts a slow charge into a AGM battery but knowing I was going to leave the ignition on for a while it seemed better than nothing. I also switched off everything else I could to minimise as much battery drain as possible. Next I slackened off the wheel nuts just enough to make it easier to undo them once the car was off the ground. I was only changing the spring on one side so only needed to remove one wheel but as I was fully deflating the air suspension I needed to support the rear of the car on both sides. Being an F11 I was able to use the stiffening plate behind the rear subframe as a lifting point. It looks flimsy but the supporting struts give it enough strength to hold the weight of the car. Just be sure to chock the front wheels securely as the car will have a tendency to roll forward. Once lifted high enough the car was supported on axle stands combined with rubber jack pads which fit into the jacking points. Next I used ISTA+ to fully deflate the air suspension system. After connecting the cable and establishing a connection to the car I selected the 'service functions' tab and navigated through to the option of filling and draining the air suspension. I selected the option to bleed the air bellows Then confirmed all the necessary preconditions had been met... You need to remove the 40 amp air compressor fuse which is found in the boot inside the trim behind the right hand wheel arch and numbered 182. Then clicked to confirm the bleeding procedure and then continue While the air was bleeding out I removed the wheel nuts and wheel after noting the position of the wheel on the hub. I'm not sure whether it's considered best to replace the wheel in the same position but it seemed there'd a better chance of getting it to sit flush with the hub and avoid any vibration issues later so I took a second to photograph the wheel before removing it. By this time ISTA had finished the first run through the bleeding process and was asking my if I wanted to repeat. I selected yes and clicked through the same screens as before. With the wheel now removed after the second run through I was able to feel how much pressure was left in the suspension system by pressing on the rubber bellows. It felt very soft and was easy to push into with my fingers so I guessed 2 bleeding procedures would be enough and declined ISTAs offer to repeat. The spring is secured at the bottom by three plastic tabs which engage with the the hole in the middle of the mounting. I used a suitably sized flat bladed screwdriver to push them toward the centre and so disengage them from the edge of the hole. At first I tried to unclip all three before lifting the bottom of the spring clear but I soon realised it was much easier to unclip one and twist the lower body of the spring slightly so as to prevent the first tab from re engaging while you're trying to free off the second. While holding the body of the spring in its twisted position I could then disengage a second tab. With two tabs now clear it was then easy to twist the bottom of the spring a little more in the right direction to clear the final tab leaving the spring hanging free at the bottom and clear of the mounting. To disengage the top mounting I had to turn the spring by about 45 degrees in a clockwise direction, that is clockwise if you were looking down at the top of the spring. If you look at the shape of the top of your new spring it should be clear which way you need to turn the old one. It wasn't difficult to turn, I just gripped the bellows and dust cover in both hands and the whole assembly turned quite easily. Once turned it felt quite loose and it seemed to be disengaged but was still tricky to pull down and get clear of the mounting. After trying for a few minutes and getting frustrated I stopped, looked at the spring, swore at it and tried again. This time I must've moved it in just the right way and it dropped out easily, as if mocking my previous attempts. Don't panic if it seems reluctant to come out at first. You'll soon move it just where it needs to be to pull free and you'll be left with... Take care not to twist the air line too much or it'll get kinked and need replaced or repaired using a hot coat hanger which was one method I recall reading someone had used. Next I had to undo the fitting attaching the air line to the spring using a 10mm ring spanner. . It wasn't screwed in particularly tightly and was easy to unscrew With the air line removed from the spring I pulled the threaded part of the fitting from the end after prising off the olive which grips the pipe and had a look to assess the condition of the pipe. NewTIS says the pipe needs to be in pristine condition to to ensure a good seal. Mine was not in pristine condition having score marks round the circumference presumably from the unscrewing of the fitting. I could have cut the pipe back to a clean section but would have needed to cut off almost an inch. I didn't want to leave the pipe too short or risk not making a straight cut which might not seal properly so decided to take a chance and just refit the pipe as it was. I put some tape over the open end in an effort to keep any foreign particles from entering the system. The bare air line was then able to be pulled through the hole in the dust cover and moved to one side out of the way. All that was left was to manoeuvre the spring clear of the car. This turned out to be the most difficult part of the whole job but after some perseverance I realised I had to separate the dust cover from the spring. Once I'd done that it was easy to bend the dust cover enough to pull clear and then I was able to pull the spring out from the car and give it a good inspection. It was interesting to get a good look at it. It hadn't looked too bad while on the car but now it was off and fully deflated I could see the true condition of the rubber and some of the strange symptoms resulting from failing air springs made a lot more sense. The car might drop one day but not the next. It all depends where the rubber folds. Original BMW unit with dust cover removed and Arnott replacement side by side. The Arnott one looks quite a bit smaller and came with the the new pipe fitting already in place. There was a plastic plug sealing the fitting which you need to leave in place until just before fitting the air line. I'm not sure whether you're supposed to get a new dust cover with a new spring. Mine didn't come with one but the old one looked ok and seemed to be a good fit with the Arnott spring, notwithstanding the following, so I just swapped it over. The only difficulty I had here came from the shape of the recess at the top of the Arnott spring through which the air line passes. It's a little different to the BMW unit, I guess in an effort to make it harder to trap the air line between the top of the spring and the car but makes it difficult to get a good alignment with the hole in the BMW dust cover. The hole needs to be a little lower down. Perhaps there are some specific Arnott dust covers to use with their springs. I'll look into that sometime but for now I had to get the car back together without any further delay so just had to go with what I had. I positioned the dust cover so the airline could pass through and line up as closely as possible with the connection, removed the tape I'd previously used and the plastic plug in the air inlet and pushed the air line in until it stopped. I then pulled it out gently to seal the olive as per Arnotts instructions. Re assembly is, in classic Haynes style, the reversal of the removal procedure. Offer up the top mount of the spring into its mounting hole and rotate to engage. Take car not to trap the air line at the top of the spring or you'll end up with fault codes and need to take the lot to bits again. Mine felt quite loose just hanging there but when turned seemed to be engaging positively so I was confident it was in the right place and went on to attach the bottom mount. It was difficult to pull the bottom of the spring down with enough force to engage the tabs in the hole so after a bit of trial and error I decided I'd just get it in position, try re inflating the system and see whether air pressure would do the hard work for me. I replaced the air compressor fuse and after clicking to continue I heard the compressor start working and soon after that the bellows was hard and the bottom mount was pushed fully home with tabs engaged. Referring to the photo taken earlier I replaced the wheel after giving the mating surfaces a good brush off with a wire brush and let the car back down onto the ground. It sat there, not dropping. So far so good. Torqued the wheel nuts to 140Nm, removed laptop and battery charger, put tools away and went for a drive. The Arnott spring felt much nicer that the BMW one. I'm not sure whether the ride quality degrades over time/miles or whether Arnott units are just better from the start but it's a great improvement. The car rides a lot better and the symptoms the car was displaying are no longer evident so I'm pretty happy at having done the job myself. If anyone's thinking of doing this and being put off by thought of it being too difficult... Don't think that way. As long as you don't mid getting some dirt on your hands and have the tools needed it's really very easy and will save you plenty of money for an hour or so of your time.
  9. Cadwell Parker

    Indicator Error

    It sounds to me like you need to look at this the opposite way round. If the passenger side front indicator intermittently flashes fast it means one of the other lights is intermittently not flashing at all which then causes the passenger side front light to flash fast. You need to find which light is not flashing at all when the fault occurs.
  10. Cadwell Parker

    Brake discs minimum thickness bmw health check

    I had 2 piece Brembo discs and pads fitted all round 2 years and 45000 miles ago. They've been very good with no issues at all. You should be fine with them.
  11. Cadwell Parker

    F11 rear suspension, dropping and low ride height

    It's a 2014 car, June IIRC so you may have a point re the EHC/height sensor connection but I'd hope the garages diagnostics machine would be able to tell what's going on and give us an accurate picture. Will hopefully find out more on Tuesday.
  12. Cadwell Parker

    F11 rear suspension, dropping and low ride height

    Had the car at the garage today. Compressor tested ok but when trying to set the ride height there is now no communication from the EHC module to the rear height sensors. The height sensors are active. They register a change in height if the car is rocked from side to side but they're not getting any voltage from the module. I'm wondering whether I might've upset something yesterday splitting the plug connector but if that's the case, with the plug properly back together and looking in good condition surely it could only be something to do with the wiring between the module and sensors. Odd that both sensors are getting no voltage. This is looking like it's going to be beyond my limited diagnostic capabilities so I'm taking the car back next Tuesday to leave with them all day for some more thorough diagnosis. We've pumped the air springs up to something like proper ride height, I've pulled out fuse 152 in case the car still wants to spontaneously drop and will keep using it as it is. It's not too bad at all just now with a little more air holding it up so hopefully it'll last till next week. Will update here with any developments.
  13. Cadwell Parker

    Runflats vs non runflats advice needed please

    Yes, it's ok to mix them but not on the the same axle.
  14. Cadwell Parker

    What did you do to your F07/F10/F11 today?

    Replaced the air filter which I've been trying to get round to for a while. I felt it was getting a bit overdue at 36000 miles since the last change but at least I think that's still within BMWs recommended interval of every 2nd (of their 20000 mile) oil changes. The old filter looked well used compared to the new one Plenty of gunk in the air box as well All cleaned out and put back together. I'm sure my engine will thank me Also revisited the rear suspension issue but not really any further forward there.
  15. Cadwell Parker

    F11 rear suspension, dropping and low ride height

    Thanks for that I've been having a quick look over the car today. First I disconnected the battery then split the plug on the EGG module to check for any signs of moisture, corrosion etc. Clean as a whistle so I proceeded to jack up the car and remove a wheel so I could get to the height sensor plug but that proved difficult to separate. The clip on one side was easy enough to undo but the other proved more troublesome, to the point I felt I was having to force it so much I was risking bending the new bracket which has just been fitted or breaking the plug. I'm taking the car to the garage tomorrow to have the compressor pressure tested so I just refitted the wheel and admitted defeat for the day. I'll see what the pressure test reveals and go from there. After looking at @Toughguyhuhs post I removed the compressor cover out of curiosity and it doesn't look too difficult to remove and get a look at the relief valve so depending on tomorrows results that could be my next move
  16. Cadwell Parker

    What did you do to your F07/F10/F11 today?

    I'd be interested in a link to that as well, also a diy how to would be helpful if you've time. I've been having random dropping issues and suspect the release valve but need to get round to checking the plug connectors at the EHC and height sensors before I go any further.
  17. Cadwell Parker

    F11 rear suspension, dropping and low ride height

    Thanks Matthew, it's quite a mystery at the moment. The garage did something to attempt a reset of ride height. They're using Autologic instead of ISTA and rather than setting the height to that listed in NewTis they said they'd set it to -2. -2 what I'm not sure. I guess Autologic works differently to ISTA but didn't have time to ask them to explain as I was on my way to work and had been there quite a while already. I left fuse 152 in place hoping the new bracket would fix things but the car dropped slowly over the course of the next 150 miles driving. Since getting some more air into the springs and removing the fuse on Saturday evening it's been ok having done similar mileage. I'm wary of trying to reset the ride height for now as that would necessitate putting the fuse back in, re-enabling the EHC and risking the car dropping again and refusing to lift. I really need to keep it drivable for now so I'll start by separating the plug connectors from the height sensors and EHC module and go from there. Hopefully I'll find something obvious and simple to resolve with a bit of contact cleaner. Presumably I'd be best advised to disconnect the battery before disturbing any plugs?
  18. Cadwell Parker

    F11 rear suspension, dropping and low ride height

    There was a fault code indicating the air compressor had timed out after pumping too long. As there doesn't appear to be any leaks from the air springs or pipework does that suggest the discharge solenoid is sticking open intermittently so the compressor is just pumping air straight through that rather than lifting the car? Thanks. I'll let you know how it goes. Hopefully I can find the root cause before I give up and send the car back to the garage. I'm just glad I had ISTA and was able to get the car up and running again. At least I've got a bit of breathing space and can use the car for the time being.
  19. Cadwell Parker

    What did you do to your F07/F10/F11 today?

    Yes, I remember now. Thanks for the reminder
  20. Cadwell Parker

    What did you do to your F07/F10/F11 today?

    The battery I took off my car which ISTA said was worn out still seems to hold a reasonable charge. After sitting idle the garage for a few weeks after being fully charged it still showed 12.7v on my multimeter
  21. Cadwell Parker

    What did you do to your F07/F10/F11 today?

    Just the fronts. I recall reading somewhere on here if you raise the rear ride height of an F11 it has the added effect of firming up the springs but I haven't tried it.
  22. Cadwell Parker

    F11 Diff oil

    My F11 was at the garage today for a few things including a change of diff oil. A few hours after dropping the car off the garage rang to say they'd done everything apart from the diff oil. They'd been in touch with BMW re the oil and been told they need to use the genuine BMW oil at £80 per litre, BMW refused to tell them the spec of their oil, only offering the part number saying that that is the only oil which can be used in my car and anything else will result in irreparable damage. The garage wanted to check that was ok with me before going ahead. I told them not to bother for now and after a brief search on here see others ( @sams255 and @Munzy123 ) have used SAE 75/90 oils from Motul and Castrol. How did those work for you guys? Did your diffs explode soon after? Have you done lots of mileage without any apparent consequences? Would I be correct in thinking any SAE75/90 oil from a reputable company should be just fine and I should just buy some Castrol/Shell/Motul etc and ask the garage to use that? I'd be tempted to have a go at the job myself but don't have any level ground near home which seems to be an important requirement it you want to be sure of filling with the correct amount of oil.
  23. Cadwell Parker

    What did you do to your F07/F10/F11 today?

    The new springs must've felt like even more of an improvement after driving on that. Got mine back today. Feels great at the front, tighter but not overly firm. Still got issues at the back after the air suspension threw a wobbler on the way to the garage. They found the height sensor bracket was bent so wanted to straighten it out, reset the ride height and see how things go. The car still feels and looks like it's sagging a bit at the back, mostly ok while driving but feels like it compresses more easily than before then firms up the further down it goes, almost like it was hitting the bump stop but not quite as sudden. I'm going back tomorrow so will see what they reckon.
  24. Cadwell Parker

    Do these discs look new to you?

    Yes, same as Perchas above. Here's one of mine when new, straight out of the box
  25. Cadwell Parker

    Do these discs look new to you?

    I could send you a photo of my F11 discs later. They look the same as the rears you got from BMW.
×