Jump to content

Ricky318i

Members
  • Content count

    38
  • Joined

  • Last visited

  • Feedback

    0%

Everything posted by Ricky318i

  1. Ricky318i

    G30 530i steering rumble

    Hi Alex Any resolution to your issue yet? I've had the dealership reprogram all the control units and after that, the issue seems to have subsided. It's been 4 days now I've been testing it under the same conditions as before. I'll give feedback if things change.
  2. Ricky318i

    G30 530i steering rumble

    Hi Alex Any resolution to your issue yet?
  3. Ricky318i

    What did you do to your F07/F10/F11 today?

    Yes, all you do is remove the button with a small screwdriver, then pop out the cover with same small screwdriver. The replacement can be bought from Amazon here: https://www.amazon.com/gp/product/B07WTBNVLN/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1
  4. Ricky318i

    What did you do to your F07/F10/F11 today?

    I've replaced the ugly peeling trunk release button cover on my F10 530d.
  5. Hi, has anyone experienced this error on their n57 530d or 535d? I don't have any symptoms, but I noticed this error when diagnosing the car.
  6. Ricky318i

    Swirl flap actuator errors diesel engine

    Thanks for the suggestion. Have you experienced something similar? Did it involve cleaning only, or did you replace the actuator for good measure?
  7. Ricky318i

    Heavy rain, Water leak

    Just when you thought you've seen the worst one so far, you see this.
  8. Ricky318i

    2014 Petrol N20 engine

    N20 issues are well documented. Google "N20 timing chain"
  9. I've taken the vehicle on a long drive on the freeway yesterday to test the effect of the changes I've made. The conclusion is that the vibration at 104 - 118kph is significantly reduced and the vibration under load is also significantly reduced to almost non-existent. The things is did were, in order: 1. Had both rear wheels refurbished (check for buckles, cracks and respray). They found right rear to have 3 cracks which were repaired, buckle which was repaired and the whole wheel resprayed and balanced. The left wheel was found to have numerous cracks and buckled. They refused to repair and I replaced the wheel. The mag shop gave me a loan wheel from a Z4 which gave all sorts of errors and I just decided to park the car until i get my new wheel. After replacing the wheel, the vibration was slightly improved, but still there and I was disappointed. 2. I then decided to do the road force balancing before looking for fault elsewhere on the drive train. The results were immediately noticed, however the Hunter machine showed a big unbalanced mass on the left rear tire which couldn't be balanced out. I had to replace the tire. I logged a claim through Goodyear's technical representative. They approved the replacement. The new tire was fitted and the improvement was immediately felt. No more heavy vibration at 104 - 118kph, no more droning at 80kph. Yesterday's drive was smooth and enjoyable for a change. There is still some road vibration, very slightly so, which I will accept, given this vehicle's sports suspension, run-flat tires and 19" wheel size. Hope this helps others.
  10. I haven't had the opportunity to test it on a freeway yet. I will give feedback soon.
  11. I am scheduled to visit a tire shop tomorrow. They have a Hunter road force balancing machine and they sound confident that they can eliminate the vibration under load as well as the ~100kph vibration. I will report back tomorrow.
  12. the wheel is OEM bought from BMW dealership in Cape Town.
  13. Hi guys, I've done some work on this issue with no result. I've had the two rear wheels refurbished. They had some cracks in them and one was buckled. One would've thought that this would solve the vibration ~110kph issue, but alas, no. It made no difference at all. The one wheel was badly cracked so I had it replaced with a brand new OEM replacement. My next step would be to inspect all the rubber components in the drivetrain, e.g.: diff bushes, prop shaft carrier, gearbox mount, etc.
  14. Any news on this? Is it still an issue? I've been experiencing this since I got the car and would also like some direction as to where to start faultfinding.
  15. Ricky318i

    What did you do to your F07/F10/F11 today?

    Replaced the fan button. Does a good job, but doesn't line up 100%. Looks better than my old one though.
  16. hi all, I have internet as an optional extra in my CIC and am able to connect my phone (Sony Xperia Z5, Xperia XZ2 and Samsung Galaxy A3 2016) to it no problem, but the internet doesn't actually work. It says "starting internet" or something and then hangs until eventually, it says "cannot connect to the internet, please try again later" Is there a workaround? Can one install an app on phone to tether the Bluetooth internet via an understood protocol by the vehicle? I have upgraded the CIC software to the 2014 version (latest) I have enabled Bluetooth tethering on my device I have restarted everything I have disabled music and contacts and messages and only ticked Data on CIC Anyone else having trouble connecting with their Android device to the internet?
  17. Ricky318i

    F10 2011 internet not working

    Thanks for your answer.
  18. Ricky318i

    F10 2011 internet not working

    Thanks - I will contact the dealership and ask if they can do anything about it. I will inform you guys.
  19. Ricky318i

    F10 2011 internet not working

    I don't have Connected drive. It's CIC. There is no SIM according to me.
  20. Ricky318i

    What did you do to your F07/F10/F11 today?

    Got my removable tow bar gooseneck I ordered.
  21. The TIS for that job can be found here: https://www.newtis.info/tisv2/a/en/f10-530d-lim/wiring-functional-info/non-electric-diagnosis-ned/03-body/01-noise/instrument-panel-interference-noise/repair-instructions-f10-f11-f18/GiNOSuCa
  22. I've seen these repair recommendations and my felt seemed fine, however, after two days, the problem returned in the one fixture - the fixture closest to my driver's side: See the pictures below: So before taking the dashboard apart again, I am going to see if wedging a piece of carpet between the windscreen and dash at that specific point brings down the noise, and then that failing, I will apply some silicone spray to the affected area to lubricate it of sorts.
  23. I have removed the dashboard and replaced it with a different (much better condition) unit from a 523i. I assumed that this would solve the problem with the creaking sound as the old dash had a broken bracket on the right side under the A-pillar , also two clips missing. The creaking sound became unbearable at the point when we decided to remove it. Long story short: the creaking was gone when we put the new dash in, but is slowly returning 3 days later as I add more kilometers. It is frustrating. When pushing at the points where the dash's female points go into these male fixtures, one can hear the creaking (sounds like plastic rubbing against plastic). With the dashboard out, one can see the fixture (two mounting points at the front under the windscreen. Note the felt on the two fixtures. (grey is ok, black felt is not ok). See below:
  24. Ricky318i

    What did you do to your F07/F10/F11 today?

    Replaced my whole squeaking dashboard.
  25. Ricky318i

    What did you do to your F07/F10/F11 today?

    Filled my toolkit in the trunk with a transmission unlock handle and new screwdriver + first aid kit. Mine went missing in the car's previous life.
×