Jump to content
stevewilley

What did you do to your E39 today ?

Recommended Posts

On 15/01/2017 at 9:42 PM, Piper said:

Brought her back from the deadB)

 

20170115_122926.jpg

Hi Piper,

 

I've got a 1998 non vans 540 too. As I understand it there are only 5 or 6 of these in the country. Hence I'll be keeping mine & doing it up. Interestingly, mine is green too!

spent about £2k on it since I bought it in Dec 15, but since I got it for £1031, I'm not really complaining. Mot needed soon, but I expect it will pass unscathed. It's had a complete brake overhaul and 4 new tyres recently.

next is the little bits of bodywork. 

Share this post


Link to post
Share on other sites

Straight forward service today. 

Worryingly I drained 5 litres of oil out and put 7 in. 

Is it common to use a bit of oil on an E39 530d?

Best check my oil level a bit more often! 

Your filter would probably hold a litre on its own, so likely you weren't that low

Absinthe makes the tart grow fonder.

Share this post


Link to post
Share on other sites
1 hour ago, eleanorsskipper said:

Hi Piper,

 

I've got a 1998 non vans 540 too. As I understand it there are only 5 or 6 of these in the country. Hence I'll be keeping mine & doing it up. Interestingly, mine is green too!

spent about £2k on it since I bought it in Dec 15, but since I got it for £1031, I'm not really complaining. Mot needed soon, but I expect it will pass unscathed. It's had a complete brake overhaul and 4 new tyres recently.

next is the little bits of bodywork. 

 

Sounds good buddy

Share this post


Link to post
Share on other sites

thinking of getting a f10 520D... went for a test drive in one on saturday:

 

unimpressed.PNG

 

Took my E39 530d for a 400 mile trip from london to manchester and back on sunday:

 

sticker,375x360-bg,ffffff.u1.png

Edited by IINexusII

Share this post


Link to post
Share on other sites

I went from my house in Warwick yesterday, down to Dartford to meet a man who knows his stuff and had number 1 diesel injector replaced. Then drove to Bournemouth for dinner and a catch up and then back up to Warwick. Just the 460 miles as I detoured a couple of times.

Screenshot_20170211-213518.png

Share this post


Link to post
Share on other sites

Used it for the first time this month when I drove to work..........

 

I'll admit that I was a little bit excited about using it and I wasn't disappointed!

 

 

Share this post


Link to post
Share on other sites

Replaced the battery. The last one did six years, so seems reasonable. I only use the 5 about once a fortnight at best, so a battery that isn't holding a charge is not much use.  Haven't used the car for a couple of weeks and guess what, the new battery is so flat the locking won't function.  So, chances are high that the there was nothing wrong with the old battery and I've got some fault draining the power. Bugger!  I will have to swop up on what fuse does what and start the long and boring rack of tracking it down.  Been asked many times I'm sure, but what's favourite?

Share this post


Link to post
Share on other sites
On 13/02/2017 at 5:34 PM, Doddy666 said:

What's that?

Sent from my SM-G935F using Tapatalk

It controls the heaters basically, so when (not if) your heaters either blow flat out cold or do nothing and you can't change any settings on the panel, your hedgehog has died.

 

I had a look at the wiring loom amp thing I got for pennies and made it work, then found that it had a dicky connection so unplugged it....then drove it home, hit a bump which threw up traction light, abs light and (!) light .....on the bright side at least the abs and (!) light has gone out now so after a few restarts, so I've got that going for me, which is nice.

Share this post


Link to post
Share on other sites
It controls the heaters basically, so when (not if) your heaters either blow flat out cold or do nothing and you can't change any settings on the panel, your hedgehog has died.

 

I had a look at the wiring loom amp thing I got for pennies and made it work, then found that it had a dicky connection so unplugged it....then drove it home, hit a bump which threw up traction light, abs light and (!) light .....on the bright side at least the abs and (!) light has gone out now so after a few restarts, so I've got that going for me, which is nice.

And it can run your heater motor when your car is parked so it drains your battery.

Share this post


Link to post
Share on other sites

Fitted my new BM24 unit (thanks Piper) and gave it it's first proper wash of the year, true to form its now pissing down!

Share this post


Link to post
Share on other sites

Just collected the car from an indy.

It kept going into slow mode - diagnosed as a faulty transmission position switch ( not a cheap part:().

Had the gearbox oil and filter changed at the same time.

Share this post


Link to post
Share on other sites

General clean inside and out, felt good.

Went over the engine and checked everything is good, then blasted back to london from my parents. If it wasn't for the traffic it would have been amazing.

BMW_Clean.gif

Share this post


Link to post
Share on other sites

Bought a new radiator which I'm hoping to fit tomorrow. While I'm there, I'll also replace the oil filter and oil filter housing gasket, the VANOS pipe washers, the drive belts, and the washer for the chain tensioner cylinder. Hopefully, this will sort out most of my oil seepages and my slight coolant leak. Next will be to replace my CCV system. 

Share this post


Link to post
Share on other sites

Collected the recently purchased 530i Individual from my Indy where its had a full service,new viscous fan,new thermostat and discs and pads front and rear also fitted some gloss black bonnet grilles as it had matt black in which i wasn,t keen on.

Share this post


Link to post
Share on other sites
On 2/21/2017 at 2:37 AM, DerekJr. said:

Bought a new radiator which I'm hoping to fit tomorrow. While I'm there, I'll also replace the oil filter and oil filter housing gasket, the VANOS pipe washers, the drive belts, and the washer for the chain tensioner cylinder. Hopefully, this will sort out most of my oil seepages and my slight coolant leak. Next will be to replace my CCV system. 

 

 

Replacement of the radiator and oil filter housing gasket went well. Glad I decided to do it on Wednesday, the day before storm Doris :lol: It took about 8hrs from start (waiting for the engine to cooldown) to finish  (packing everything away).

Share this post


Link to post
Share on other sites
2 hours ago, 740mick said:

Collected the recently purchased 530i Individual from my Indy where its had a full service,new viscous fan,new thermostat and discs and pads front and rear also fitted some gloss black bonnet grilles as it had matt black in which i wasn,t keen on.

 

Any pictures Mick?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×