Jump to content
RichardP

Firmware V6.02-7058 and User Guide

Recommended Posts

Changes from V6.02-7045

  • Added invalidation of ID3 tags on receipt of broadcast ID3.
  • Added debug printf when processor volume reported is not the volume requested.
  • Added 1 second timer on setting the processor volume, if the timer times out then the volume request is sent again.
  • Added debug printf on changing the processor source.
  • Added option to display the Journal and Vehicle Status in full screen mode on a MK IV Nav.
  • Added PXA Direct option which when selected causes the AI-Net port to be used when the Intravee source is selected.
  • Added switch of Processor source when PXA Direct is selected and a Nav command is detected.
  • Added light sensor trigger level for Entry and Exit lights, the will probably only work on the E46, maybe the Z4 and X3.
  • Added retry up to 10 times on sending light control messages if no Ack is seen.
  • Changed the mechanism for display disable when Intravee is paused for Phone or VR.
  • Change to FID audio menu update frequency.
  • Changed OPARM version to 64.
  • Fixed bug when changing the processor volume while reduced (in reverse) changing the volume now cancels the reduction.
  • Fixed bug when setting the clock from the Nav when the TZ setting was more then 9.5 Hours or less then -9.5 hours.
  • Fixed bug that caused the Nav type to be requested on power when in auto UI mode up even if the Auto Nav type setting was not selected.
  • Fixed bug that prevented VR commands being heard when using PXA Direct mode.
  • Removed debug printf on Net App restart.

fw-app-256 - extras V6.02-7058.zip

Intravee_Users_Guide_V6.02-7058.pdf

Intravee_Extra_Features_Supplement_V6.02-7058.pdf

Intravee_PXA_Supplement_V6.02-7058.pdf

Intravee_Supported_Devices_V6.02-7045.pdf

Edited by RichardP

Share this post


Link to post
Share on other sites

Downloader/terminal shows these messages when I turn the system off and back on:

 

Volume set 153, wanted 70

Volume set 120, wanted 70

Volume set 80, wanted 68

etc.

 

Is this normal (because of the extra debug added) or does this mean that there is something wrong?

 

After power on, map display seems to popup most of the time instead of the Intravee/text display, but maybe it gets better after car goes thru sleep period. Like it did with the 7045 version.

Share this post


Link to post
Share on other sites

Well, that's 'interesting'!

Does this settle down after a short time, or is there a constant stream of those messages?

Could you do an ai-net log of power up (feature unlock, ainetd on, reboot, ...., ainetd off, feature lock, reboot)?

Share this post


Link to post
Share on other sites

I am downloading this!

Whats'sis then? 8)

 

• Change to FID audio menu update frequency.

Edited by Shled

Share this post


Link to post
Share on other sites

FID is the rear MID in the E38 and E39, there is a change to how frequently the lower menu area is updated.

post-30340-0-83623600-1373365164_thumb.j

Edit : but of course you know that!!

The update frequency is reduced so it's only updated when the menu display flags sent by the radio change.

Edited by RichardP

Share this post


Link to post
Share on other sites

Brilliant update as always. One quick question, with theory sensor data which is lighter and which is darker? Iv set it to 46 as suggested but I'd that's too dark or too light which way should I be going for either?

Share this post


Link to post
Share on other sites

High values are more light.

So, if a value of 46 does not trigger until it's too dark, increase the value. The 'Ignore' value is in effect FF (255), in which case the lights will always come on.

Share this post


Link to post
Share on other sites

Richard, i've got a pre facelift Z4 from 2004. Is it possible to add Mirror folding support to that? I love the intravee and you're updates are superb! The only thing i'm missing is mirror folding. auto locking and coming&leaving home are working perfectly!

Share this post


Link to post
Share on other sites

When are you going to add a hidden Easter egg disco light test sequence?

I've been asked before for a 'Police car' type alternate side main beam flash, but I believe there are quite large penalties for impersonating a Police officer!

Share this post


Link to post
Share on other sites

Richard, i've got a pre facelift Z4 from 2004. Is it possible to add Mirror folding support to that? I love the intravee and you're updates are superb! The only thing i'm missing is mirror folding. auto locking and coming&leaving home are working perfectly!

So far no one has been able to find the iBus codes for folding the Z4 mirrors, they may or may not exist.

 

If you have INPA and can activate them from there while logging the iBus then this may reveal them.  As far as I know, no one has actually done this, they prefer to say that it's not possible which may not be true.

Share this post


Link to post
Share on other sites

Hi Richard,

 

Are any of these PXA updates geared towards the H800?

Yes, the 'retry' on setting the volume is aimed at preventing the problem with setting the volume on power up.

Share this post


Link to post
Share on other sites

so was ae's as dlrs ditched? i liked that option

No, you can still set Daylight Running Lights, there are now more options that can be set.

Extras -> Control -> Light Control -> DLRs. Options are Dip Beam, Front Side (equivalent of AEs) and Front Fog.

Share this post


Link to post
Share on other sites

Yes, the 'retry' on setting the volume is aimed at preventing the problem with setting the volume on power up.

 

Today dsp volume was again locked to -99 and volume adjustment didn't work. Ai-net power toggle probably would have helped but I was already moving, so it was just silence during that trip :(  Could you add an extra step for ai-net power toggle if volume setting fails after retry?

Share this post


Link to post
Share on other sites

Yes, the 'retry' on setting the volume is aimed at preventing the problem with setting the volume on power up.

Excellent!  Thanks. 

 

The issue that I've been having (and living with) is that the PXA will be stuck at -99 on startup but that any volume click will bring it back. This seems directly solvable by the retry scheme.  I'll try it and report back

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×