Neilb

Oh great... High emissions... 530d

10 posts in this topic

Hi all, got the car back yesterday after its 60k service (Merc Indy) and all seems fine. Off we go this morning and its totally flat pulling onto the m-way, hardly any boost and about 50 flat out, no warning lights! Being very low on fuel I pulled in and  filled up and on driving away it felt fine.. Next time I put my foot down it lurched and high emissions warning came on the screen with the yellow eml.

We have done about 50 miles since and it feels a little flat, had a quick check under the bonnet and the inlet pipe into the air filter had popped out! I've put this back in but it doesn't feel very secure! Hey ho, its still under ACU so BM have it Monday morning to see whats going on!

Share this post


Link to post
Share on other sites

You used to but I believe they've changed in the past couple of months, can't see them putting themselves out if its being serviced outside the network.

Share this post


Link to post
Share on other sites

Thermostats kackered, DPF not regenerating therefore blocked??

Share this post


Link to post
Share on other sites

Done about 30 miles this morning and its driving fine and the economy has increased! Lights still on though!

Share this post


Link to post
Share on other sites

It won't fix itself, check the engine temp, most likely will be stuck about 70 ish.

 

change thermostats, check codes, get it regenerating the DPF.

Share this post


Link to post
Share on other sites

Air filter not seated properley??

Had this myself once when i didnt fit the filter properley.

Check its sat 'on' the maf tube correctly.

Had a look at the Air filter yesterday and it looks ok (what a nightmare to move though!). It drove fine yesterday but was dead flat again this morning. It's at BM now, they've given me a new 320d while mines being looked at. 

Share this post


Link to post
Share on other sites

Just had the call from BMW.. Air filter not fitted properly, so the filter is broken as is some pipe on the air box, not covered by the warranty so that'll be 150 quid to put right.

However they have also found the intercooler is leaking and the inlet manifold is cracked.... Thankfully that is covered by the AUC, Phew!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now