Jump to content
markw

Remote key has stopped working and Alarm is going off.

Recommended Posts

Hi,

All of a sudden my key lost the ability to open the car remotely.

At the moment I'm having to resort to opening the car by putting the key in the door, this sets off the alarm until I can get the key into the ignition. When this started I noticed that the radio settings also changed from my standard preset display. Also the interior light timings seemed to reset themselves. (not sure if linked, but thought I'd mention)

The alarm is driving me bonkers.

Any suggestions as to what could be causing this?

I have searched the forums and was wondering if it could be the "diversity Aerial"

I have tried the other key but this doesn't work either, so this rules out a duff battery.

If the car was a PC I'd switch it off and on again.

Any help would be much appreciated.

Mark

Share this post


Link to post
Share on other sites

I've booked it in to the local BMW specialist.

However this isn't until next Thursday.

Does anyone know how to disable the alarm with just the key?

I dont understand fully with what is happening, does your alarm just come on at random times or is it bugging you that every time you

get in the car you set your alarm off because if it is the second then there is a solution when i had a problem with my central locking to get

in the car i would insert the key in the drivers side then turn it to the left first and straight away to the right which would open the car up without

alarm getting set off, this worked most of the times but at odd times it didnt.

Share this post


Link to post
Share on other sites

check all you fuses i did get caught out with this and i mean all of them it's located in the rear if there all okay then most likely will be your diversity aerial.

Share this post


Link to post
Share on other sites

Every time I open the car with the key (as the remote unlock has stopped working) the alarm goes off.

I'll try turning to the left and then straight to the right in the morning, oh and I'll also check the fuses.

Cheers.

Share this post


Link to post
Share on other sites

Every time I open the car with the key (as the remote unlock has stopped working) the alarm goes off.

I'll try turning to the left and then straight to the right in the morning, oh and I'll also check the fuses.

Cheers.

It should work then, did you try it?

Share this post


Link to post
Share on other sites

Turning the key to the left first and then right does disable the alarm, but not all of the time. Seems to be a 50/50 chance of it going off. I have noticed if the lights flash when turning the key, then the alarm disables. I checked the fuses out but can not see a problem here. I'll wait to see what the garage say on Thursday.

Share this post


Link to post
Share on other sites

When my remote key failed I had to open the door with the key and the alarm went off but as soon as the key was put in the ignition and switched on the alarm stopped so I lived with this until the key was fixed.

Incidentally I managed to repair my own key as it was simply a dry joint - one of the 2 battery terminals had come away from the solder.

So check yours first as it could be an easy free fix before visiting the stealer :)

Share this post


Link to post
Share on other sites

When my remote key failed I had to open the door with the key and the alarm went off but as soon as the key was put in the ignition and switched on the alarm stopped so I lived with this until the key was fixed.

Incidentally I managed to repair my own key as it was simply a dry joint - one of the 2 battery terminals had come away from the solder.

So check yours first as it could be an easy free fix before visiting the stealer :)

Yeah but mine does that with all the keys. I strongly suspect a module/antenna is broken.

I can start the car fine after I disble the alarm, so the batteries are fine too.

Very annoying...

Share this post


Link to post
Share on other sites

Incidentally I managed to repair my own key as it was simply a dry joint - one of the 2 battery terminals had come away from the solder.

So check yours first as it could be an easy free fix before visiting the stealer :)

Are you talking about the square key you slot into the steering column (as opposed to the old bmw diamond key)?

Yeah but mine does that with all the keys.

Have you ever used your other key though? You're supposed to rotate them every few months because they go flat if you don't use them (they recharge in the steering column while you're driving).

Share this post


Link to post
Share on other sites

Open with a Stanley knife but be VERY VERY careful not to slice yourself..!

I simply used super glue to rebond mine.

If i had to do that I'd need to pre-book a time slot in the local A&E

Share this post


Link to post
Share on other sites

Hi

My E61 suffers from poor radio reception, worse on wet days. I have been told that it is almost certainly the diversity amplifier in the tailgate spoiler. It amplifies the signal for AM & FM radio and the key entry. Try putting your key up at the top of the tailgate and pressing the button to see if it works. I am getting a new amplifier hopefully on Monday, hope it cures it.

Share this post


Link to post
Share on other sites

Hi

My E61 suffers from poor radio reception, worse on wet days. I have been told that it is almost certainly the diversity amplifier in the tailgate spoiler. It amplifies the signal for AM & FM radio and the key entry. Try putting your key up at the top of the tailgate and pressing the button to see if it works. I am getting a new amplifier hopefully on Monday, hope it cures it.

Yeah but yours is different, it is in the roof spoiler

I think mine is behind the middle brake light in the headliner, I will check this week-end

78.jpg

Share this post


Link to post
Share on other sites

from your picture it looks like the same unit. I would imagine yours would be less liable to water ingress which is what seems to cause the problems

Share this post


Link to post
Share on other sites

A common problem with the E61 tourer, water gets into the diversity antenna, top of the tailgate. You can get one from Cotswold BMW much cheaper than BMW dealer. I had same problem. DIY job as well. BMW wanted £370 +VAT

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×