Sign in to follow this  
Followers 0
colinm

"Check brake lights" warning message continually (almost) on

8 posts in this topic

Anybody know how to fix this. I guess there is a switch or something similar somewhere that needs replacing. Do you know were it is and are any special tools needed?

Share this post


Link to post
Share on other sites

Brake pedal switch imo if its intermittent.

E34 or E39?

Share this post


Link to post
Share on other sites

Have you checked whether or not the brake lights actually work? Does sound like a brake light switch or bulb holder problem to me though

cheers

Share this post


Link to post
Share on other sites

This happens to me as well though i totally forgot about the third brake light under the parcel shelf.

Better check that then.

Share this post


Link to post
Share on other sites

All 3 brake lights are working but i think the hella rear lights are l.e.d.

Please someone correct me if i am wrong but it looks like the led's are left and right of the unit.

Maybe that is messing with the control fault thingy. They are not the rear cluster that came originally when new.

Share this post


Link to post
Share on other sites

tourings had LED, salloons have a bulb iirc.

if all 3 work it might be worth chaning one at a time or just all 3 and one may be old and different resistance to the others. You seen buld go silver on the glass when the filliment vapourises and sticks to the glass.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0