Jump to content
duncan-uk

E28 535i and 525e Motronic non-start trouble shooting guide

Recommended Posts

yes I did,

 

I fallowed the instruction above and also from the link I posted earlier here.

 

I found my DME/ECU cracked. 

 

Just take your time, and slowly check as described and you should find the issue. 

Share this post


Link to post
Share on other sites

unplugged relays and unplugged the spade connector on the crank sensor, wiggled fuses and it started straight up.... driving for 30mins and cut out again, got it home now..... and its starting again!!!

Share this post


Link to post
Share on other sites

Yea its the silver one then, its clicking when i unplug it and put it back in with ignition on, is this a sign that its working? or can it still be failing?

 

£13 from bmw.

Share this post


Link to post
Share on other sites

Relay changed and hoses to afm changed too.... Driving for 4miles and cut out again and it's still turning over.

Looks like I'm gonna have to start going through the list :/

Share this post


Link to post
Share on other sites

Car wasn't starting so thought I would look at battery connectors, and guess what I see! On the positive terminal there is a nut on the opposite side to the clamp that holds a cable that's runs upto fuel relay and fuse box, that was so lose, tightened and it started first time, just ran for 10miles and no problems.... Re started drove more and seems fine. I'm pretty sure I found the problem! :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×