Jump to content
duncan-uk

Heater / blower question.

Recommended Posts

Not for me but a question from a mate of mine:

 

BMW 520d F10, 2011

The internal air blower works intermittently. Sometimes it won't work at all on startup, sometimes it will work for a couple of minutes and then stop, other times the button will be pressed and then it will start working 15mins later.
The switch and digital displays seen to be working OK.

 

Any pointers? Presumably a code scan is first port of call?

Share this post


Link to post
Share on other sites

Is it set to auto? try adjusting the blow direction to front vents etc, if its on auto it will actuate and blow to different directions (dash, front, under etc) depending on conditions and tempreatures

Share this post


Link to post
Share on other sites
22 hours ago, duncan-uk said:

Not for me but a question from a mate of mine:

 

BMW 520d F10, 2011

The internal air blower works intermittently. Sometimes it won't work at all on startup, sometimes it will work for a couple of minutes and then stop, other times the button will be pressed and then it will start working 15mins later.
The switch and digital displays seen to be working OK.

 

Any pointers? Presumably a code scan is first port of call?

 

I would read the codes as has been mentioned but, if it is blower related, I’d be looking at a failed blower regulator which is found attached to the underside of the blower housing in the top right of the engine compartment. 

 

Having the aircon on Auto isn’t going to present the issue the OP is describing. In Auto the fan is always on but at varying speeds depending on a number of decision factors. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×