Jump to content
Sign in to follow this  
Mindcheck

[E39] aux fan always spinning

Recommended Posts

Hello, to my knowledge auxiliary fan should turn on when the A/C is on, but in my case, whenever i turn the ignition on, the fan starts spinning at ~40-50%(a/c isn't on), does anyone know what causes him to spin, and how can i fix it(i tryied pluging in other aux fan, and the other one spinned too) 

Car is : 2000 3.0d E39

Edited by Mindcheck

Share this post


Link to post
Share on other sites

If it's an old pre-facelift car the aux fan speed was controlled by resistors and a simple switch. 

 

The facelift models (M54) used a coolant sensor and a PCM signal from the DDE to control fan speed in 1% increments

 

I'd connect INPA up and check for faults and certainly on the newer cars you can use INPA to control the fan speed so this would be a useful test. INPA will also display the coolant temperature

Share this post


Link to post
Share on other sites

Does the E39 have different temperature sensors for clocks and ECU? I know that previous cars I have owned this has been the case... so the clocks can show everything as being normal but the ECU is getting entirely different information. 

Share this post


Link to post
Share on other sites
1 hour ago, chicaneuk said:

Does the E39 have different temperature sensors for clocks and ECU? I know that previous cars I have owned this has been the case... so the clocks can show everything as being normal but the ECU is getting entirely different information. 

 

It's double temperature sensor, two separate circuits on the same part. So temp should also be checked with diagnostics from DDE (engine ECU).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×