Jump to content
Sickner

Coolant leak / pressure issue

Recommended Posts

Hi guys, newbie here so go easy please.

 

E60 530d 2004 160k

 

Recently had coolant level warning popping up, check coolant and little below the min level so topped up. Few days later same again, so repeat the process. 

I poured some coolant leak sealer in (just in case) and all seemed well for about a week but then its back. This happened twice since and then when next checking the tank it was almost over flowing?? Wtf.

 

Checked oil and all seems fine. No milky stuff. But after an "enthusiastic drive" I noticed the coolant tank leaking from the cap??? Plus it was foaming a bit too.

 

Car runs and drives as normal. Its coolant level is now almost fluctuating on its own every few days and is a little discoloured ever since using the leak sealer and a bit frothy. It will say its low so I top up then the next day its overflowing?!

 

Seems quite a lot of pressure in there too?? 

 

Thought head gasket but oil is fine? 

 

Please help..... its driving me insane.

 

Thanks.

Share this post


Link to post
Share on other sites

perhaps the cap has lost it's pressure seal?  Have you monitored the engine temps to make sure it's all ok?

Share this post


Link to post
Share on other sites
35 minutes ago, Dotcom1970 said:

perhaps the cap has lost it's pressure seal?  Have you monitored the engine temps to make sure it's all ok?

This thought crossed my mind. How do I do that, is this this secret menu I seen mentioned before?

Edited by Sickner

Share this post


Link to post
Share on other sites
9 minutes ago, Clavurion said:

Why on earth did you use a leak sealer compound before investigating where it's leaking from. This stuff can do more harm to the system.

I could not see any evidence of an actual leak so one thought was it could me a pinhole leak(s) somewhere which was evaporating as quick as it leaking, this would hopefully resolve it if it was the case.

Share this post


Link to post
Share on other sites
6 minutes ago, Sickner said:

This thought crossed my mind. How do I do that, is this this secret menu I seen mentioned before?

 

Yes.  Google for instructions on how to access it, or get a code reader that allows you to monitor live engine data

Share this post


Link to post
Share on other sites
15 minutes ago, Sickner said:

I could not see any evidence of an actual leak so one thought was it could me a pinhole leak(s) somewhere which was evaporating as quick as it leaking, this would hopefully resolve it if it was the case.

 

This kind of leak can usually be spotted when coolant system is pressurised. And if after that there are no visible leaks the most likely cause is EGR cooler leaking coolant in the exhaust.

Share this post


Link to post
Share on other sites

Sorry guys haven't been on for a while. Issue is still there, I have however noticed after a few tests that if I drive rather smooth and gentle it will be ok, perhaps a tiny amount of coolant lost after 3-4 days. But, if I put my foot down and after a good 20 min drive like this, i open the bonnet and theres coolant escaping and leaking down from the cap. Perhaps a new cap and drop coolant would sort??? Or anything I've missed perhaps??

 

Share this post


Link to post
Share on other sites

Run the car until it gets to temp with the idrive for vents set to hot, temp dial at hot and also fan on a medium speed so you know coolant is getting in to every area of the system. Leave the car to cool for a few hours and check again. If the car is going from low to high quite rapidly, it might be there is air in the system somewhere that's causing an issue. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×