Jump to content
wmw700

Zenon lights retrofitted to preface lift 535i

Recommended Posts

Hi All,

Just retrofitted a set of original BMW Zenon units to my 1997 535i E39 saloon, I purchased  these from e-bay and believe they were previously fitted to an M5 of similar age.

 

Everything works fine with the replacement units after fitment, only problem is I now have "Check Low  Beam Lights" warning!!!

 

I've owned the 535i from new and so can vouch for its electrical/wiring integrity, prior to retrofit there was no alarm present. 

 

I'd grateful for any suggestions as I was led to believe the units I bought were a like for like replacement! 

 

Thank you 

 

 

 

IMG_2076[1].JPG

IMG_2077[1].JPG

Share this post


Link to post
Share on other sites

The xenons probably need coding to the car. Or you can code the car not to do cold-checking for the low beams. Does the message disappears when you turn on your low beams?

Share this post


Link to post
Share on other sites

Hi,

 

Thank you for your advice, yes the warning  goes out when you turn the low beams on so I concur with you that it is coding issue.

 

Will now seek someone in the Norwich area to sort the issue .

 

Thank you once again

 

Regards

 

Mark

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×