Jump to content
Lukai

Windscreen Wipers

Recommended Posts

Hi,

 

I was just putting on some new windscreen wipers and somehow managed to snap number 4 in the image below. Now the drivers side wiper judders, I'm guessing this is the cause?

 

I just wouldn't of thought it would make that much difference...

 

Thanks,

Luke

 

image.thumb.png.bc3b77da516faa8289304ad9cc660484.png

Share this post


Link to post
Share on other sites

I didn't notice that it made much difference on mine when I left it off temporarily. My driver's side wiper judders a lot even when its got a new blade. Maybe it was because I initially used an SWF one instead of a Bosch but I think clay-barring the glass will probably make the most difference.

Share this post


Link to post
Share on other sites

That clip shouldn't make the wipers judder, as it's only there as an extra measure to hold the blade to the arm.

 

Also are you sure the blades are fitted properly, as the wiper blades for an E34 are quite difficult to get due to the driver's wiper arm having a "reverse-hook"? I remember getting a Bosch set from EuroCarParts and it was a straight fit with no problems.

 

And another thing about the judder, if the windscreen is cold/dry, then the juddering can happen for some reason - I occasionally get that on my driver's wiper blade on cold mornings as well.

Edited by Blackman

Share this post


Link to post
Share on other sites
3 hours ago, Blackman said:

That clip shouldn't make the wipers judder, as it's only there as an extra measure to hold the blade to the arm.

 

Also are you sure the blades are fitted properly, as the wiper blades for an E34 are quite difficult to get due to the driver's wiper arm having a "reverse-hook"? I remember getting a Bosch set from EuroCarParts and it was a straight fit with no problems.

 

And another thing about the judder, if the windscreen is cold/dry, then the juddering can happen for some reason - I occasionally get that on my driver's wiper blade on cold mornings as well.

 

Thanks, the new wipers are a Bosch set from ECP too, so should be correct. 

 

It seemed a bit loose without the clip, so I’ve ordered a new one so hopefully that will sort it. 

Share this post


Link to post
Share on other sites

I don't have the link to the tech note but there is a particular angle (I think it's 84 degrees for the driver's side and 87 for the passenger side) that the wiper arms are supposed to have. There's a procedure that describes using a protractor to measure and then set the angle (carefully with a pair of vice-grips). It may be that the arm's angle is slightly off causing uneven pressure against the glass.

 

Just a thought.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×