Jump to content
Andrew530dmsport

Reverse Camera G30

Recommended Posts

Has anyone had any problems with the reverse camera on the new G series?

 

A few times now when selecting reverse I get the graphics showing but no picture?  The system is on as tend not to fiddle with the PDC settings. Cleaned lens, still no picture. Once back in the car after a journey the camera then starts to work when reverse selected.

 

It’s a bit hit and miss re it operating. Due it’s first service this week so will see what the main stealers say about it.

Edited by Andrew530dmsport

Share this post


Link to post
Share on other sites

Yup, been having this issue and the I drive likes to freeze completely at times. Going into the dealers for a full software update as the previous camera replacement did not solve issue

Share this post


Link to post
Share on other sites
2 hours ago, The Livster said:

Strangely mine did exactly that yesterday. Was fine after turning ignition off and back on   

That’s how mine seems to clear itself. Will see what the dealer says when in this week

Share this post


Link to post
Share on other sites
On 15/04/2018 at 4:44 PM, Andrew530dmsport said:

That’s how mine seems to clear itself. Will see what the dealer says when in this week

Had an issue with surround camera’s on a 640. Took a couple trips but dealer sorted it ( did require some new wiring from Germany) 

Will be keeping an eye on G30 for any repeats 

Share this post


Link to post
Share on other sites

I did have problem, it was quite occasional (6 or 7 times), just turning the engine off and on didn't fix it, but leave it off a while and it was fine. I got a big software update just after Christmas which fixed the mirror not dipping and I haven't seen the issue since, of course it may just have made it rarer.

Share this post


Link to post
Share on other sites

Vehicle collected yesterday from main dealers. Rear camera issue was linked to the front pedestrian camera and a fault code within the system. Unknown to me was that both these cameras are linked for some reason? Issue now seems to have gone away. Asked about map updates and was told that BMW are still having issues with OTA updates and as such I'll need to wait until they have fixed this Europe wide issue.  

Share this post


Link to post
Share on other sites

There do appear to be a number (not sure I’d say a significant number yet) of technology related issues ranging from the up and downs of BMW’s connected portal to, map upgrades, dipping reversing mirrors, operating systems and this reversing camera one that suggests the desire to offer the technology exceeds the capability to deliver it seemlessly.

 

Come on Beemer you should be exceeding  expectations not be disappointing........ 

Share this post


Link to post
Share on other sites
12 hours ago, BacktoBeemer said:

There do appear to be a number (not sure I’d say a significant number yet) of technology related issues ranging from the up and downs of BMW’s connected portal to, map upgrades, dipping reversing mirrors, operating systems and this reversing camera one that suggests the desire to offer the technology exceeds the capability to deliver it seemlessly.

 

Come on Beemer you should be exceeding  expectations not be disappointing........ 

I'd agree. Currently no map upgrade since new, connected drive has a mind of its own, the app on the other hand has no mind at all (currently its unsure whether I have a car),  very occasionally the whole console display goes black for 2 minutes before turning back on, mirrors sometimes randomly fold/don't unfold, reversing camera will occasionally not come on, switching driving modes requires 4 or 5 pushes of the button...

And more.
Don't get me wrong - lovely, lovely car, but I'd expect at this price point for it to be flawless.

Share this post


Link to post
Share on other sites
12 hours ago, BacktoBeemer said:

There do appear to be a number (not sure I’d say a significant number yet) of technology related issues ranging from the up and downs of BMW’s connected portal to, map upgrades, dipping reversing mirrors, operating systems and this reversing camera one that suggests the desire to offer the technology exceeds the capability to deliver it seemlessly.

 

Come on Beemer you should be exceeding  expectations not be disappointing........ 

 

Remember that the G series is a new platform, only 2 years old so not all issues are ironed out yet. 

 

More importantly, I never complain when dropping my car off at the Local Dealer, I always get a great courtesy car for a good few days - 730d last time from 27/12 to 03/01. Next week, mines going in to sort the issue (permanently i hope) and I will be getting a 640d from Friday to Monday afternoon. Can't complain.  

Share this post


Link to post
Share on other sites
13 minutes ago, sjak92 said:

 

Remember that the G series is a new platform, only 2 years old so not all issues are ironed out yet. 

 

More importantly, I never complain when dropping my car off at the Local Dealer, I always get a great courtesy car for a good few days - 730d last time from 27/12 to 03/01. Next week, mines going in to sort the issue (permanently i hope) and I will be getting a 640d from Friday to Monday afternoon. Can't complain.  

I totally understand what you're saying here re how you act at the Dealers, it goes a long way to getting a good loan car. Problem still is that I'm reading about many problems with these cars, I've only had two - Spot weld on the rear shelf needed sorting to stop a grinding sound when manoeuvring and also my rear view cameras intermittent operation. But when you are paying a premium price for this marque I'd hope that all these issues would have been sorted prior to mainstream production runs. As we know they test the mules almost to destruction so I'd have thought all these small issues should have been addressed. Still having map issues and as I travel a lot in my vehicle being stuck in long traffic jams that haven't been flagged on the nav system really do hurt. A few weeks ago over an hour and a half delay on the M25 that was showing as being clear on the nav !! Hope they get this sorted soon.

Share this post


Link to post
Share on other sites
13 hours ago, sjak92 said:

 

Remember that the G series is a new platform, only 2 years old so not all issues are ironed out yet. 

 

More importantly, I never complain when dropping my car off at the Local Dealer, I always get a great courtesy car for a good few days - 730d last time from 27/12 to 03/01. Next week, mines going in to sort the issue (permanently i hope) and I will be getting a 640d from Friday to Monday afternoon. Can't complain.  

Couple of points IMO

1) Few customers except 2 years to resolve issues ! We’re not paying beta prices but full price. 

2) If I’d wanted a 730d or 640d I’d have ordered one of them, I didn’t so haven’t and don’t particularly want a courtesy car just because the car I did order doesn’t function correctly. 

 

 

Share this post


Link to post
Share on other sites

I think you guys missed my point here. These cars are more like mobiles. It’s hardly ever that the hardware fails (maybe except that spot weld) it’s usually the software - which is developed non stop - and software likes to glitch due to its vastness. You buy a new mobile and it will glitch. That’s why I’m not fussed.

 

the courtesy car point is outlet down to the fact that it’s better to have a nice courtesy car rather than a bare Mini which many dealers practice nowadays.

 

my old rejected F10 was with a dealer for the better part of 3 months, if I was given a Mini to drive at that time, I’d be furious. If the dealer tries to make your life as little of a misery as possible and fixes under warranty, I really don’t see what the problem with that is.

Share this post


Link to post
Share on other sites

Rather depends how you view it. 

 

I’m buying a package (in your terms) of hardware and software. I’m paying the price asked for both elements to function together correctly. Sure there will be failures from time to time but as I said in my original comment ‘there are a number’ and Beemer like any other manufacture must act to limit this.

 

IMO the courtesy car bit is a red herring.

Share this post


Link to post
Share on other sites

Is this anything like you’re experiencing? I’ve had this about 3 - 4 times now and to say it’s annoying is putting it mildly. I just can’t park a G31 without the camera. 

EA9B96B1-6734-4819-8FFC-A1D4E199C0C8.jpeg

Share this post


Link to post
Share on other sites

Does anyone having this issue have 360 degree cameras, or is it confined to cars that have reverse cam only?

 

I ask because I have 360 degree cameras and have never experienced this in the 6 months I have owned it. Wondering if I am just lucky, or if its in fact an issue confined to single reverse camera cars only...

Share this post


Link to post
Share on other sites
3 minutes ago, mobilejo said:

Does anyone having this issue have 360 degree cameras, or is it confined to cars that have reverse cam only?

 

I ask because I have 360 degree cameras and have never experienced this in the 6 months I have owned it. Wondering if I am just lucky, or if its in fact an issue confined to single reverse camera cars only...

I've got 360 cameras. The problem for me affects everything to do with video including video playback via my usb drive.

Edited by larriebee

Share this post


Link to post
Share on other sites
1 minute ago, larriebee said:

I've got 360 cameras. The problem for me affect everything to do with video including video playback from my usb drive.

 

Interesting, so its a full on video issue then? I hope they find a fix for this, not what you expect when you pay these sorts of prices!

 

I guess I have just been lucky up to now then (and having said that, it'll probably happen to me next time I use the car!)

Share this post


Link to post
Share on other sites
5 hours ago, mobilejo said:

Does anyone having this issue have 360 degree cameras, or is it confined to cars that have reverse cam only?

 

 

 

No problem with reverse camera on mine. No problems with anything for that matter like reversing mirror etc. Mine was a car from stock bought last October. Maybe they updated everything

 

The shortcomings I have experienced are my remote app is not as well developed as the Apple version. Maybe they will update it but I haven't complained about it. Maybe I should  

Share this post


Link to post
Share on other sites

I just had my idrive head unit replaced because of this issue. And for the issue with the parking sensors directing ghost items, there is a software update coming out on the 22nd June so if anyone had/has this issue, contact your dealer. 

Share this post


Link to post
Share on other sites

Yes i have the exact same thing especially with the sensors but apparently, the car has not stored any fault codes!

 

going back in on the 4th of June 

Share this post


Link to post
Share on other sites
3 hours ago, sjak92 said:

Yes i have the exact same thing especially with the sensors but apparently, the car has not stored any fault codes!

 

going back in on the 4th of June 

Don’t you have a case for sending it back and getting a full refund :P (sorry couldn’t help myself)

Share this post


Link to post
Share on other sites
9 minutes ago, Hudds.taz said:

Don’t you have a case for sending it back and getting a full refund :P (sorry couldn’t help myself)

 

Probably would since its been in 2 times for the same thing now but, unlike others, I'm not an utter bell end haha

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×