Jump to content
Nathan3937

Bmw e60 mad sensor

Recommended Posts

Hi all I would like a bit of advise please basically iv brought a bmw 5 series 2.5d 2006 and if bin having a few problems with hesitating at low revs and somtimes after holding foot hard down loads of black smoke cones from exhaust engine light came on iv plugged it code reader and it's showed up 3ff0 and 483d witch I know is is maf sensor and throttle actuator iv tryed unplugging my mad sensor and it drives the same can someone please help ??? Thank you 

Share this post


Link to post
Share on other sites

It sounds like your throttle actuator and possibly your maf are faulty. Trouble is you can't determine if its one or the other easily but if the maf is unplugged and engine is still badly behaved then i think its likely your throttle actuator you'd need to change first.  

Edited by SuperDave

Share this post


Link to post
Share on other sites
1 hour ago, SuperDave said:

It sounds like your throttle actuator and possibly your maf are faulty. Trouble is you can't determine if its one or the other easily but if the maf is unplugged and engine is still badly behaved then i think its likely your throttle actuator you'd need to change first.  

 

1 hour ago, SuperDave said:

It sounds like your throttle actuator and possibly your maf are faulty. Trouble is you can't determine if its one or the other easily but if the maf is unplugged and engine is still badly behaved then i think its likely your throttle actuator you'd need to change first. 

Thanks you so much really apricate that :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×