Jump to content

Recommended Posts

Is there a magical cure for the abject awfulness of the auto wipers on f10s? I sort of understand how they work - "The sensor projects infrared light into the windshield at a 45-degree angle. If the glass is dry, most of this light is reflected back into the sensor by the front of the windshield. If water droplets are on the glass, they reflect the light in different directions -- the wetter the glass, the less light makes it back into the sensor." - but I'll be buggered if I can find any meaning from this in everyday use.

 

It's crapping it down: nothing

It's barely spitting: FULL-ON MENTAL GABBA HOUSE RAVE IN WINDSHIELD WIPER LAND

 

Anyone else?  

Share this post


Link to post
Share on other sites

Mine work just fine after calibrating the sensitivity with the adjuster on the stalk.

Edited by Enzo

Share this post


Link to post
Share on other sites

As per both previous posts, adjust with the sensitivity control on the stalk and make sure the windscreen is given a thorough clean. Sometimes my wipers will be going mad for just a drizzle but that is the exception rather than the rule. I wouldn't be without them after having them on our 2 current cars. Just so much less faffing.

Share this post


Link to post
Share on other sites

Yes, obviously, I've tried adjusting the control on the stalk. I've never had a problem with auto-wipers on any of my other cars, and come to think if it, I didn't have it with my previous f10 but having read a fair amount on other BMW forums I thought perhaps it was a "thing".

 

I'm getting to the point where I might replace the wiper blades to see if that helps. Maybe mine are leaving the sort of greasy smears that I can't see but the infra red can.

 

 

 

Share this post


Link to post
Share on other sites
2 hours ago, Matthew Ashton said:

Sometimes my wipers will be going mad for just a drizzle but that is the exception rather than the rule. 

Alas, it is now the opposite for me. :(

Share this post


Link to post
Share on other sites

I’m not sure if it applies to BMW’s but I’ve had it on other brands where the windscreen has been replaced and subsequently for a variety of reasons the rain sensor is no longer pressed hard against the screen making it impossible for the sensor to accurately assess the amount of rain on the screen. So long story short if the screen has been replaced at some point check that the rain sensor is firmly pressed against the screen.

Share this post


Link to post
Share on other sites
11 minutes ago, sshooie said:

This F11 is by far the worst car I've had with auto wipers, their nigh on schizophrenic. 

 

The ones on my E60 were far worse than the F10 ones!

Share this post


Link to post
Share on other sites
5 hours ago, DickieG said:

So long story short if the screen has been replaced at some point check that the rain sensor is firmly pressed against the screen.

This! 

Share this post


Link to post
Share on other sites

Saying all this, was just pulling into the station car park this morning and all of a sudden the wipers went

 

17 hours ago, jannism said:

FULL-ON MENTAL GABBA HOUSE RAVE IN WINDSHIELD WIPER LAND

 

Must have been having a "moment".

Share this post


Link to post
Share on other sites

Mine have moments, but I have narrowed it down to when the car is facing the sky going up hill as the worst moments when it just goes all out mental. 

 

Going along certain parts of the M2/A2 it really hates as there is plenty of inclines and it just seems incapable of realising that it is just the sky. It has done it since I have had it though and I am used to it being stupid and reduce the sensitivity down.

 

The only other annoying bit is when stationary it won't wipe the screen urgh.

Share this post


Link to post
Share on other sites

Going in for its second service tomorrow so I'll ask if anything's up. Going to test drive a new X3 while it's in :o (easier than trying to book a courtesy car). 

Share this post


Link to post
Share on other sites

I find mine work really well. I have the sensitivity switch set one down from most sensitive. Only thing I don't like much is that they hardly ever move when you are stationary at the lights. It was same with my E91. I know they wipe as soon as you move off but still ...

Share this post


Link to post
Share on other sites

I took it in and explained the situation with the wipers - a very familiar story. After discussing them for a bit the service receptionist made a note to get them looked at. Apparently, it's a very common complaint and whatever it is that they've done seems to have worked. My only gripe is that they seem to have topped up my screenwash with water. Nothing spraying out of the left side for about 100 miles this morning until the ambient temperature warmed up. That's never happened before. Besides, the temperature didn't even go below -3 so plain water really has to be the culprit. Cheeky sods.

 

The X3 was nice and irritatingly, the family preferred the ride. I personally couldn't live without the extra two cylinders though. Also happy to admit that, despite thoroughly enjoying all the bells and whistles of BMW's latest lovely interiors, getting back behind the wheel of my 5 was the best part of the day.

Share this post


Link to post
Share on other sites
53 minutes ago, welshpug said:

putting the demister on will help that btw.

Presuming you mean the front demister, when I turn mine on it's like there's a Typhoon taking off on the bonnet! Can it be adjusted?

Share this post


Link to post
Share on other sites

are there two buttons on the newer cars?  only one on my E34, it heats up the mirrors and washer jets as well as rear screen (well it would if the wires weren;t broken as they all are!)

Share this post


Link to post
Share on other sites
20 hours ago, welshpug said:

putting the demister on will help that btw.

19 hours ago, AndyM said:

Presuming you mean the front demister, when I turn mine on it's like there's a Typhoon taking off on the bonnet! Can it be adjusted?

Tried yesterday after I posted this and discovered that when the front demister setting is on, it is possible to adjust the fan speed but keep demister mode on. B)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×