Jump to content
petelucherts

530d Starting Issue

Recommended Posts

Hi

Please help....purchased a 530d m sport with a starting issue, every now and again it will not have the battery power to start (starter motor clicks, dash flickers , windows are slow etc)  it generates lots of faults and has latched the airbag fault ....all other clear from driving..

 

Googled it to death and it looked like it could be the BST (would explain the airbag light) but removed the cover around the pyrotechnic and all looks good.

 

Removed the scuttle cover and ecu cover and found slight corrosion to the power pins to the connector to the DME, cleaned the ECU and connector with electrical connecotor cleaner and made sure the lid was silicon greased and sealed.  Could this cause the issue? the corrosion was so minor and I can understand it causing ecu issues but not battery drain (starter motor issues).

 

The fault is so so intermittent that its hard to know if fixed, runs like a champ 99.9999percent of the time..

 

Any advice would be great.

 

Pete

Share this post


Link to post
Share on other sites

Alternator? this is a starting issue....although i wouldnt put it past bmws electronics? could it be related?

 

ibs? is that intrlligent battery sensor...read to just disconnect it?

Edited by petelucherts

Share this post


Link to post
Share on other sites

this is something other than alternator I think. As once running its running with no issues etc yes?

 

 

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

also where your jump start connection point is under the bonnet, put a socket on the connection at the back of that and ensure it is tight. Also grease these points, battery cable runs directly yo that point, then from there is jointed down to the starter motor. I had major issues on an e70 X5 which ended up being this connection!! Id thrown starter motor at it by that point aswell!! annoyingly.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I bought 530d with new battery and alternator, supposedly.  After a few months got all the stupid dash messages, plus if I left the doors or boot open for 1/2 hr it wouldn't start. Put meter on cigar socket and saw that it sometimes didn't charge for 10m then 15-16v. Seems the new alt was just a paint up with new brushes. Replaced reg and solved charge problem, easy job with alt in situ. However I think the 8month old battery was toast from going flat and getting roasted. Replacement and now all good.  Tried disconnect of ibs, didn't help.

 

Share this post


Link to post
Share on other sites

ORDER DATE

14 Apr, 2017
ORDER TOTAL
£47.99
+ £12.99
postage
Order ARG144 ALTERNATOR Regulator BMW 520d 525d 530d 535d 2.0 2.5 3.0 d xd E60 E61View similar itemsView seller's other items
ARG144 ALTERNATOR Regulator BMW 520d 525d 530d 535d 2.0 2.5 3.0 d xd E60 E61
 
ARG144 ALTERNATOR Regulator BMW 520d 525d 530d 535d 2.0 2.5 3.0 d xd E60 E61
( 251836623240 )
 
 
Got all sorts of faults , tranny, steering, battery, charge etc.
I think I preferred my E39!

Share this post


Link to post
Share on other sites

thanks for all the advice . car seems sorted.

 

for anyone looking at the same issues....battery, voltage regulator (on alternator), cleaned ecu onnectors of slight corrosion (under passengers wiper area).

 

pete 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×