nitro chimp

525d Power issues!

8 posts in this topic

Hello fello members, I hope someone can shed some light on a new problem I've been getting from my ever so troubled 525d Auto.

 

I'll start by saying its a 2001 525d touring auto. It all started yesterday, I stated the car and I heard this weird groaning sound from what appears from under the passenger seat (fuel pump), She started without hesitation, drove to the doctors which was 10 minutes away without trouble, all worked fine. However, I got back to the car, it wouldn't start (just cranked over). I tried again, nothing. I took the key out, waited about 5 seconds and tried again, She fired right up and has worked ever since. However today. I've hammered her, she kicked down and she pull's right up to 4,200rpm and bounces at 4,200, you feel the whole car jolt a bit then she changes up but feels like shes strangled for power.

 

I've lately been having problems with the auto box when going for an overtake it just rev's its nuts off and wont change up (looking like a complete tit) unless you change the gears manually. Also tried today when she seems to not go past 4,200, this time i'd change gears manually and the gearbox changes up then instantly goes down the gears again as though its the wrong gear to only bounce at 4,200rpm? For as long as I've owned the car it seems a bit lazy from a stand still, for example, your on the slip road on a busy roundabout and you see an opportunity to go for it, by the time the gearbox wakes up your nearly getting side swiped! also when engaging reverse its slow to respond in which you can blip the throttle before anything happens. If in reverse and you sat on the brakes you can hear and feel of whats like gearbox judder!

 

Here's some info that might help:

She has 146,200 miles and no evident transmission fluid change, no paperwork for anything really!

Drivers rear tyre close to legal limit

A slow puncture on passenger rear tyre but all tyres had just been pumped up during this 4,200rpm problem!

The past 4 days its been low on fuel, just at the quarter mark. My friend who I bought the car from has told me he'd replaced the fuel pump as he told me he ran it on near empty!

I have no engine management light nor do have trans fail safe!

It has had its swirl flaps blanked and an EGR delete, again my friend had that done.

I've only used premium diesel and from the same petrol station.

 

I've uploaded a video of exactly whats going on, just hope the forum allows it to work!

 

Edit: Tomorrow I'll have a go at seeing if she'll rev past the 4,200 mark while stationary to rule out the trans

 

Any advice would be greatly appreciated.

IMG_9620.MOV

Edited by nitro chimp

Share this post


Link to post
Share on other sites

When my 530d wouldn't rev past 4k it was indeed the fuel pump under the passenger seat.

A couple of times I also had to turn the ignition on/off for it to start or lean under the car and give it a thump.

It's a very easy job to replace.

My advice would be not to buy a cheap pump. A friend did this. It was very noisy and lasted 9 months .

 

Sent from my SM-N9005 using Tapatalk

 

 

Share this post


Link to post
Share on other sites
4 hours ago, lestere said:

When my 530d wouldn't rev past 4k it was indeed the fuel pump under the passenger seat.

A couple of times I also had to turn the ignition on/off for it to start or lean under the car and give it a thump.

It's a very easy job to replace.

My advice would be not to buy a cheap pump. A friend did this. It was very noisy and lasted 9 months .

 

Sent from my SM-N9005 using Tapatalk

 

 

Thanks for the reply. I have looked up how much a pump is from BMW and I'm looking at a ball point of about £190. I've looked on eBay and they're going for as little as £30! That i wouldn't get. I've got one saved that's £70. I've drove it today now i'd put another £30 in premium diesel and its dry outside the obc reads 130miles, It goes to just over 4k, bounces for less then a second then changes up, much better then last night. I did it again, went up to over 4k and changed just fine. so it must be the pump. I don't like to red line an engine in any situation but i'll try and see if it will rev past the 4,200rpm mark whiles stationary.

Share this post


Link to post
Share on other sites

Check out Euro Car Parts... managed to get a Pierburg pump from them for about 120 quid with discount code. 

 

I still ill have the old one that came off my car... fairly sure it's fine as I swapped it to fix a different problem (and it made no difference) so would at least help you rule it out? You could have it for... dunno... 25 quid?

 

 

Edited by chicaneuk

Share this post


Link to post
Share on other sites
3 minutes ago, chicaneuk said:

Check out Euro Car Parts... managed to get a Pierburg pump from them for about 120 quid with discount code. 

 

I still ill have the old one that came off my car... fairly sure it's fine as I swapped it to fix a different problem (and it made no difference) so would at least help you rule it out? You could have it for... dunno... 25 quid?

 

 

That's amazing, thank you. Where you based? I'm currently in Blackpool despite my account saying Manchester. Will be going back at some point!

 

Did you sort out your problem?

Share this post


Link to post
Share on other sites

No. Not sure what is up with mine though the problem is infrequent enough that it's not a big issue.

 

Regarding the pump, I would be happy to post it over to you of course. How urgently do you need it?

Edited by chicaneuk

Share this post


Link to post
Share on other sites
10 hours ago, chicaneuk said:

No. Not sure what is up with mine though the problem is infrequent enough that it's not a big issue.

 

Regarding the pump, I would be happy to post it over to you of course. How urgently do you need it?

Ah, I see. Whats exactly going on with yours?

 

I'm in no mad rush to be honest, I'm due to see family on Friday but I can borrow a car if need be. My car does work and bar the very occasional non start and the loss of power top end of the rev's, today she has been fine, I can still potter around town till a replacement arrives. PM me with a PayPal email address and I'll forward you some cash. How much including P&P?

 

Your a life saver :D

Share this post


Link to post
Share on other sites

Let's just say £25 posted? I'll try get over to the lock-up this evening and post it tomorrow for you. I'll PM you my details now.

 

Mine is just having a problem with an occasional power hiccup / cut out when giving it full throttle.. as if I've just let off the power even though the the throttle pedal is to the floor. But if you let off the gas and then accelerate again it's fine. Suspect is the diesel pressure relief valve in the engine bay but BMW want about £100 for a new one which is a bit of a piss take.. and it's so infrequent that I'm not in a big rush to change it. 

Edited by chicaneuk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now