Sign in to follow this  
Followers 0
Steve540

Newbie.. rough cold idle

9 posts in this topic

Hi so i litteraly just joined the forum after a couple of years off searching on it i decided to make an account 

Ive got a rough idle problem but ill introduce my 540 1st

Winter this year i sold my 520 and bought a 97 540 113k montreal blau auto

I couldn't afored a manual im only 20 lol

Anyway it wouldn't run up to temp so i put in a new tstat and discovered the old one was drilled out

Gave the car a good service and put a factory airbox in

So since the car had been running lean jn petrol (13mpg) i wonder what harm it has done to the engine. I clean the idel control valve which was blocked with carbon i guess thats due to the car running so lean on petrol 

So on a cold start the car sounds awful. Throwing 5 miss fire codes also. However once its running for 2 or 3 mins if you restart her she starts with a nice rev and falls down to a smooth idle 

Just got e38 parallels diamond cut and put onto the 540

 

20170211_152821.thumb.jpg.42ef0636649732cd946904c01afe085a.jpg

20170624_093709.thumb.jpg.ff200322f676e093374eefa06569ed9a.jpg

FB_IMG_1499532945772.jpg.f88224e95bc5b1caf29e9d2dd6c2a490.jpg

FB_IMG_1499534327446.thumb.jpg.e29d327d8bfe8c69a6424b19955f0a39.jpg

20170714_155714.thumb.jpg.d3e3de62e1f93e8183a2488a967faeb4.jpg

Share this post


Link to post
Share on other sites

How's the MAF? Have you tried running the car without it to see how it is and what codes are thrown, if any?

 

Are the cats ok, no rattles/signs of them collapsing etc?

Share this post


Link to post
Share on other sites

Ive done the maf thing before but i didnt realy understand what i was doing. I remember having the car on, disconected the maf and the car stalled immediately. I will redo the test to see if anything has changed. There is a bad rattle blow out in the exhaust unless thats a dodgy cat??

I found this huge vac leak after i got the car... not sure if it should be blocked which it now is or if there is a pipe belonging to it 

20170312_162844.thumb.jpg.20bda81c818af55f9f23c615d73f5a7c.jpg

20170312_162851.thumb.jpg.0357665f96d83e8b5ec70c45bf8973b5.jpg

Share this post


Link to post
Share on other sites
1 hour ago, Steve540 said:

Update i unplugged the maf and the car is running slightly smoother in cold 

So confused lol

 

Well; ether give the MAF a good clean with specific MAF cleaner (don't use anything else); or, replace it with a genuine one (not a cheap eBay jobby) otherwise you'll soon be having issues again!

Share this post


Link to post
Share on other sites

Replaced the ccv today despite breaking 1 little clip but its fine

20170812_100119.thumb.jpg.c200acbc94f50f07686997ea703c9354.jpg

Old one wasnt a pretty sight. It had a hard black residue on the orange sealant part

Anyway so far cold start up is alot smoother!! Not as smooth as warm but i think thats to be expected

The car now turns on without the MAF plugged in after a slight cough 

Thanks for your help guys 

One more thing 

I have still to clean the maf but since the car now starts with it unplugged what does that mean?

Share this post


Link to post
Share on other sites

Generally if the car won't start with the maf plugged in the maf is dead. Also worth checking the o2s as if it runs well cold but starts getting rough when warm, the o2 sensors only become active in closed loop and when cold it's open loop, so that could also be an issue?

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

 ^^ To add to the above, check the exhaust system as even a small leak before the o2 sensors can play holy f*ck with the mixture.    

 

Nice socks by the way!! ;):)

Edited by NWJW
pink socks......

Share this post


Link to post
Share on other sites
9 hours ago, NWJW said:

 

Nice socks by the way!! ;):)

Haha i tried to hide my matching boxers :D

Mu exhaust system isnt great i think the cats are wrecked because the car ran cold for 2 years which ment it done 13mpg if u were lucky lol 

Once i get the back box either removed or replaced with a magnaflow muffler i will investigate 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0